The MU forums have moved to WordPress.org

Fatal Error (Mysql) on WPMU 2.7 (26 posts)

  1. nz26
    Member
    Posted 5 years ago #

    I was installing the new version of Wordpress MU on my server and it came up and said what my new user/pass are. So I clicked on the login button and it displayed these words:

    Fatal Error

    If your blog does not display, please contact the owner of this site.

    If you are the owner of this site please check that MySQL is running properly and all tables are error free.

    Database Tables Missing.
    Database tables are missing. This means that MySQL is either not running, WPMU was not installed properly, or someone deleted wp_site. You really should look at your database now.

    What do I do now?
    Read the bug report page. Some of the guidelines there may help you figure out what went wrong.
    If you're still stuck with this message, then check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories
    If you suspect a problem please report it to the support forums but you must include the information asked for in the WPMU bug reporting guidelines!

    I have checked in my cpanel to see if mysql is up and running and it is. The tables it wants are all there but I don't know what to look for in them to check for errors

  2. VentureMaker
    Member
    Posted 5 years ago #

    I'd try to reinstall rather than bugging with this :)

  3. pro01
    Member
    Posted 5 years ago #

    I get the same error. At first I thought it might be a WAMP problem, as I tried to install it locally, but now it's the same on the live server. It's so freaking annoying and has nothing to do with standard WP installation.

  4. noeljcorpuz
    Member
    Posted 5 years ago #

    Me too
    I got that error too

  5. tanvir
    Member
    Posted 5 years ago #

    Are u migrating wp from any previous version? if not then try this

    1. Check the database & host name in wp-config.php file. Sometime if you copy the db or host name there may be a extra blank space which may cause this error.

    if this doesn't work then try this.

    1. Back up your database.
    2. Remove al the tables with wp_ prefix
    3. Back up your current wp_config,php [you can move it on a temporary folder]
    4. Then simple run the installation

  6. henrywp
    Member
    Posted 5 years ago #

    I had the same problem before, I put

    display_errors = Off
    register_globals = Off

    in htaccess.dist.

    The problem go away if i don't modify this file.

  7. noeljcorpuz
    Member
    Posted 5 years ago #

    I Have Installed it Already
    And it is now working
    Try to reinstalling it again

  8. monpelaud
    Member
    Posted 5 years ago #

    Hi,

    I have the same issue: "Database Tables Missing etc ...".
    Have you find how to fixe this issue ?

    Best regards

  9. drew3000
    Member
    Posted 5 years ago #

    I checked the database and there doesn't seem to be any tables installed. This is, of course, after wiping and reinstalling.

  10. tanvir
    Member
    Posted 5 years ago #

    do u get any massage from installation???

  11. drew3000
    Member
    Posted 5 years ago #

    Sure. The same as before.

    Fatal Error
    If your blog does not display, please contact the owner of this site.

    If you are the owner of this site please check that MySQL is running properly and all tables are error free.

    Database Tables Missing.
    Database tables are missing. This means that MySQL is either not running, WPMU was not installed properly, or someone deleted wp_site. You really should look at your database now.

    What do I do now?
    Read the bug report page. Some of the guidelines there may help you figure out what went wrong.
    If you're still stuck with this message, then check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    If you suspect a problem please report it to the support forums but you must include the information asked for in the WPMU bug reporting guidelines!

    It's not creating any tables in the database. Very strange. Does anyone know how many fields go in the database table? I was thinking of just adding them manually and then seeing if the thing worked at all.

  12. tanvir
    Member
    Posted 5 years ago #

    ok first try with a different prefix rather then wp_

  13. drew3000
    Member
    Posted 5 years ago #

    tried it. Just repeats the same thing, so that's not it. Have a prefix I like better now, though, so good on that.

  14. tanvir
    Member
    Posted 5 years ago #

    point is WP insert a tons data in to the tables during install. ok give me ur mail address i'll send you the sql script as it's 434 line :D

  15. drew3000
    Member
    Posted 5 years ago #

    Thanks. I'm at andrewfordlyons@gmail.com

  16. vikassah
    Member
    Posted 5 years ago #

    I am facing same issue. Can you please send me the sql script as well at theadreview@gmail.com? Thanks.

  17. conpeo
    Member
    Posted 5 years ago #

    I redone overall, new version MAMP, reconfig ports, wp-config changed prefix wp_ to mu_ ... etc
    change etc/hosts, after admin registration done, but failed to login. same problem with u guys "Fatal Error", Database table missing. I checked the database table, its created.

    Could be 2.7 bugs? but no proof.
    Tanvir, the script working?
    pls help, I need to run local wpmu.

  18. tanvir
    Member
    Posted 5 years ago #

    To run it on localhost you have to follow these steps:

    Open and edit this file C:\WINDOWS\system32\drivers\etc\host
    Add 127.0.0.1 localhost.localdomain after 127.0.0.1 localhost

    If you have created a blog say, named “test”, you will need to edit this file again - add another line: 127.0.0.1 test.localhost.localdomain

    Next go to C:\xampp\apache\conf\httpd.conf (I installed xampp in Drive C )

    Enable this line by removing the “#” sign:
    LoadModule rewrite_module modules/mod_rewrite.so

    Change this line:”AllowOverride None” to
    AllowOverride FileInfo Options

    Did you follow all these?

  19. conpeo
    Member
    Posted 5 years ago #

    swear, strictly follow the configuration.

    Tried two different system failed.
    MAMP/ XAMPP on OS X
    WAMP on WinXP

    both system show Fatal Error (database table missing)
    still no clue.

    Doncha remains the same READme file inside the folder. never update.

  20. pro01
    Member
    Posted 5 years ago #

    The problem seems to be it just does not add any values to domain and path tables for some reason - they are there, but blank. And even I add them myself, it crashes with paths being incorrect. I'm really pissed at that point.

    And why the heck there is no any sustainable explanation of the extra fields in wp-config, and what is the correct way of setting them? Should not be a big thing, but it just does not work. Damn.

  21. conpeo
    Member
    Posted 5 years ago #

    finally working on localhost, solved!
    (Local wpmu with MAMP in OS X)

    Don't follow out-dated READme file bundle with installation folder.
    Don't create wp-config.php manually

    Put the fresh new folder to htdoc.
    change the 777 mode for two folders: wordpress-mu & wp-content
    update etc host - 127.0.0.1 localhost.localdomain (use terminal)
    done, start your engine!

    blah...blah... (u know the rest)

    hope tis help

    ------------------

    no doubt, new version backend admin control interface is getting more & more functionality & complexity...

    I still like the wpmu 1.2 ... (the most handy)
    due to security issue & open source.
    what to do! (shrug)

  22. temporalrift
    Member
    Posted 5 years ago #

    For me, the problem has been that the tables are written, but data hasn't been added to them. I had to go in and manually add values for the default blog, then manually add the site_admins line to the wp_sitemeta table. I'm trying to get an installation running on my personal webhost and at work. I don't have much control over my personal webspace and I assumed that might be the reason I was having issues at first, except that now I'm having issues at work, and I can configure that server.

    Right now, I'm running into a problem with the redirects for posts and, most importantly, assets (pictures, plugins, etc). I think the root of it is a misconfigured htaccess file (the installation didn't write one like it's supposed to) or a lack of specifics on which paths need to be relative to what in wp_config. I'm really just about ready to install individual wp blogs and attempt to chain them together myself.

  23. tzmartin
    Member
    Posted 5 years ago #

    MU dynamically generates the wp-config.php file. Manually uploading it prior to installation may cause a "Fatal Error".

    Try this:
    Remove wp-config.php from your server. Upload wp-config-sample.php and visit your index page for your MU root installation. From this point you can enter your database credentials and setup your site.

  24. johanhorak
    Member
    Posted 5 years ago #

    Hi tzmartin

    I am not sure how to contact you but I have a similar problem with an existing site that I stuffed up. Can you see if this idea of yours will work on an existing site that I upgraded http://mu.wordpress.org/forums/topic.php?id=11864

  25. sergiofores
    Member
    Posted 5 years ago #

    Hi tanvir,

    I am facing same issue that vikassah and drew300. Can you please send me the sql with 434 lines script as well at sergiofores@gmail.com? Thanks.

  26. stephendeo
    Member
    Posted 4 years ago #

    ok I fixed this problem

    To resolve this issue do a search in your "db" for the "path /cgi-system/" i'm running wordpress mu in a sub folder so i'm not sure if the same applies if you're running in the root dir. Basically if you want your wordpress mu to appear as http://www.yourdomain.com/blahogs/ you'll need to change everywhere in the db that has /cgi-system/ to /blahogs/

    it worked for me

    ps. make sure you change it in wp-config.php file as well.

    $base = '/cgi-system/';
    to
    $base = '/blahogs/';

    also if you are using dreamhost and wordpress mu is point you to cgi-system still you can resolve the issue by visiting this forum:
    http://mu.wordpress.org/forums/topic/4605?replies=7

    Thanks
    Stephen

About this Topic