The MU forums have moved to WordPress.org

SubDomain - New User 403 Error - GoDaddy Install (49 posts)

  1. jlynch401
    Member
    Posted 5 years ago #

    Hello

    I can access posts for my main blog - but when I try and access a newly created sub.domain.com blog - I get a 403 Forbidden error.

    Settings:
    Mod_rewrite IS enabled , default on GD and I can view my posts on my main blog

    Deluxe hosting Wild Card * set up correctly with static IP.

    .htaccess file :
    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    DirectoryIndex index.php

    I have been reading about "httpd" file editing ala:
    Options FollowSymLinks
    AllowOvverride FileInfo Options

    But I don't appear to have access to such.....

    Any Idea what I am missing?

    Thanks
    Frustrated Nooooob.

  2. VentureMaker
    Member
    Posted 5 years ago #

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Try commenting out these strings.

  3. jlynch401
    Member
    Posted 5 years ago #

    Thank you for the quick reply Venture,

    I know you will probably shake your head but I am not sure I understand....

    When you say commenting out the strings do you mean replacing the text in caps with data?

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    If so what do I need to put there?

    Too Noob

  4. jlynch401
    Member
    Posted 5 years ago #

    Also error log reads:
    [Sat Mar 21 08:41:42 2009] [error] [client 70.188.146.226] (13)Permission denied: file permissions deny server access: /var/chroot/home/content/n/a/b/nabarkeeper/html/favicon.ico
    [Sat Mar 21 08:41:45 2009] [error] [client 70.188.146.226] (13)Permission denied: file permissions deny server access: /var/chroot/home/content/n/a/b/nabarkeeper/html/favicon.ico

    Thank you

  5. VentureMaker
    Member
    Posted 5 years ago #

    String:
    RewriteCond %{REQUEST_FILENAME} !-f

    Commented out string:
    # RewriteCond %{REQUEST_FILENAME} !-f

    By 'commenting out' I mean temporary disable those strings by telling the server that they are comments, instead of totally deleting them.

  6. jlynch401
    Member
    Posted 5 years ago #

    Well I know you are shaking your head now because I do not ow how to do that.... : )

  7. VentureMaker
    Member
    Posted 5 years ago #

    OK, backup your current .htaccess file, delete it, create a few .htaccess file and paste the following into it:

    RewriteEngine On
    RewriteBase /

    # uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

  8. jlynch401
    Member
    Posted 5 years ago #

    Thank You Venture.... Did as you said...

    Created in notepad, uploaded as ASCII renamed to .htaccess

    Still get Page Error:
    Forbidden
    You don't have permission to access / on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at AppStuff Port 80

    AND My Error Log reads:
    [Sat Mar 21 11:49:07 2009] [error] [client 70.188.146.226] (13)Permission denied: cannot read directory for multi: /var/chroot/home/content/n/a/b/nabarkeeper/html/wp-admin/

    Where before it was (file permissions deny server access)
    Is Now: (cannot read directory for multi:)

    Also I have tried it both with and without adding the sub domain in my domain manager.(subdomain.rootdomain.com) Should it work either way?

    Thank you.

  9. rdmedley
    Member
    Posted 5 years ago #

    What are you using to upload your files? Are you making sure you have the correct permissions on uploading?

    Also MU handles the subdomain end of things. You don't add your own records for subdomains. Make sure you have wild cards for your domain set.

    *.yourdomain.com

  10. jlynch401
    Member
    Posted 5 years ago #

    wildcard is set....*

    I am using the GD FTP Client.

  11. rdmedley
    Member
    Posted 5 years ago #

    jlynch401

    Can you check what your directory and file permissions are.

    Do you know how to use chmod? if not here is a link.
    http://www.math.unh.edu/~student/tutorial/WWWtutorial/account/account.html

  12. jlynch401
    Member
    Posted 5 years ago #

    RDmedley...I do appreciate the direction and the tutorial.
    Thank you everyone for your patience....
    I am still gettin the errors below:

    [Sat Mar 21 16:32:00 2009] [error] [client 70.188.146.226] Directory index forbidden by rule: /var/chroot/home/content/n/a/b/nabarkeeper/html/bartender/

    [Sat Mar 21 16:32:00 2009] [error] [client 70.188.146.226] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.

    Godaddy makes it pretty fool proof allowing you to choose the permissions n the cpanel

    They Allow you to toggle the owner and/or the user

    to Read, Write or Execute any directory....

    I have allowed all for the time being just to get the subdomain issue resolved to no avail...

  13. andrea_r
    Moderator
    Posted 5 years ago #

    Who is the owner on that directory?
    And, you didn't say if wildcard vhosts were set up in httpd.conf.

  14. jlynch401
    Member
    Posted 5 years ago #

    HI Andrea... When you ask if the wildcards are set you mean the dns?

    <Settings:
    Mod_rewrite IS enabled , default on GD and I can view my posts on my main blog

    Deluxe hosting Wild Card * set up correctly with static IP.>

    I am the owner of the directories though hosted on GoDaddy.

    What am I doing wrong that is not allowing me to generate these subdomain users?

  15. jlynch401
    Member
    Posted 5 years ago #

    Anyone??? Help????

  16. VentureMaker
    Member
    Posted 5 years ago #

    I am the owner of the directories though hosted on GoDaddy.

    Andrea asked about Linux 'owner'. If go to your WPMU via FTP - do you see files/dirs ownership?

  17. jlynch401
    Member
    Posted 5 years ago #

    Venture,

    When I go into the FTP via....the client on Godaddy or using IE or Mozilla...I can view the files/dirs in the root ( wp-admin, wp-content, wp-includes and files..... as they are all in the root, not within a "WPMU" directory.

    Where would I see Ownership? And....is that the way it should be set up? Or should I indeed have a directory: "WPMU" within the root containing the above?

  18. VentureMaker
    Member
    Posted 5 years ago #

    got a screenshot of what you see via FTP?

  19. jlynch401
    Member
    Posted 5 years ago #

    Venture....I'm behind major firewall here at work so trying to get creative in providing that screenshot for you....thanks...

  20. jlynch401
    Member
    Posted 5 years ago #

  21. VentureMaker
    Member
    Posted 5 years ago #

    First of all, don't use IE for FTP things.
    Get FileZilla http://filezilla-project.org/download.php?type=client

    It will show you files/dirs permissions and owners.

  22. jlynch401
    Member
    Posted 5 years ago #

  23. VentureMaker
    Member
    Posted 5 years ago #

    OK, this is better :)

    Now, when you upload files via FTP - you use login '3763549'?

  24. jlynch401
    Member
    Posted 5 years ago #

    no....I don't kjnow where that number generates from...godaddy perhaps

  25. jlynch401
    Member
    Posted 5 years ago #

    I can start from scratch if that would be best.....
    No data will be lost...

  26. VentureMaker
    Member
    Posted 5 years ago #

    this number is owner of files/dirs.
    now, can you change owner?

  27. jlynch401
    Member
    Posted 5 years ago #

    That is the number on all of my directories and files.....do I need to edit it? If so How so?

  28. VentureMaker
    Member
    Posted 5 years ago #

    In FileZilla select dirs and files, then right click, select change ownership menu.
    Try to change owner to your FTP login... If it won't work - change it back to what you have now :)

  29. andrea_r
    Moderator
    Posted 5 years ago #

    "HI Andrea... When you ask if the wildcards are set you mean the dns?

    <Settings:
    Mod_rewrite IS enabled , default on GD and I can view my posts on my main blog

    Deluxe hosting Wild Card * set up correctly with static IP.>

    I am the owner of the directories though hosted on GoDaddy.

    What am I doing wrong that is not allowing me to generate these subdomain users? "

    There's TWO places you need to set up wildcard subdomains. One in the DNS area, and one in Apache.

  30. jlynch401
    Member
    Posted 5 years ago #

    OK I don't see anywhere to select files/dirs and even attmpt to change ownership.....sorry :(

About this Topic

  • Started 5 years ago by jlynch401
  • Latest reply from cvaughan02