The MU forums have moved to WordPress.org

Are you sure you want to do this? error (27 posts)

  1. nejko
    Member
    Posted 4 years ago #

    I have just upgraded my wordpress MU from old 1.0 up to 2.8.1 (gradually) and it looks like everything works so far.

    However, if I try to add an Editor for a blog this way:

    - I create a new user;
    - I go to "Blogs" and then click "Edit" and then "Add a New User" and enter the username of the new user and role "Editor"

    I get this error message:

    ----
    Are you sure you want to do this?

    Please try again.
    ----

    That's it. Any ideas how to solve this? I've tried and deactivated (and also removed) all the plugins, but no luck. Also tried and deleted all the cookies.

    Thanks,
    Nejc

  2. authcode
    Member
    Posted 4 years ago #

    I'm getting a similar error after upgrading from 2.7.1 to 2.8.1 when I try to edit a blog and change the "Public" setting from "Yes" to "No" or vice versa.

    ----
    Are you sure you want to do this?

    Please try again.
    ----

    Haven't found a solution yet, other then manually editing the database.

  3. ithyn
    Member
    Posted 4 years ago #

    This seems to be caused by the "check_admin_referer" function.

    The fix I put in place, temporarily, is to go into /wp-admin/wpmu-edit.php and comment out line 183:

    check_admin_referer('editblog');

    This fixes the problem and, so far, has not caused other issues. But be aware that I'm not sure what the lack of that function will effect.

  4. jamescollins
    Member
    Posted 4 years ago #

    I am using the latest version of WPMU available from the 2.8 branch in trac (2.8.1a-alpha) and I can edit a blog and change the public setting without any problem.

    I can also add a user via the edit blog page without any problems.

    As per http://trac.mu.wordpress.org/log/branches/2.8, there have been quite a few bug fixes since 2.8.1 was released last week, so its possible that one of the changes listed on that page corrects the problem.

    If possible, I suggest trying the latest version available from trac and seeing if it fixes your problem.

    If it doesn't, I suggest submitting a bug report here: http://trac.mu.wordpress.org

    That way the problem can hopefully fixed for everyone.

  5. authcode
    Member
    Posted 4 years ago #

    Following on from my previous post: I don't seem to have this problem with blogs created after I upgraded to 2.8.1.

    I'll get the lastest version from trac as suggested.

  6. williamsba1
    Member
    Posted 4 years ago #

    I can confirm this is a bug in WordPress MU 2.8.1. The problem has been resolved however in the latest trunk. I installed rev 1886 and the problem is fixed. I can now add users to blogs.

    If you are having this problem install the latest version of WPMU from the trunk here:

    http://trac.mu.wordpress.org/browser/trunk

    The download link is at the very bottom of the page labeled ZIP ARCHIVE

  7. williamsba1
    Member
    Posted 4 years ago #

    Donncha just confirmed WordPress MU 2.8.2 will be released early next week which will include the fix for this issue.

  8. TheRider62
    Member
    Posted 4 years ago #

    I just upgrade to the very latest 2.8.2. And then I tried to add that user to that blog that I wanted to add for awhile. Still doesn't work :-(

    I am getting this error message when pressing "Update Options":

    "0 ist eine geschützte WP-Einstellung und kann nicht geändert werden."

    Yes, this is a german-language install. Using qLanguage plugin, the language of the dashboard has been set to english. This message still comes in german. strange, but may be due to qLanguage. It guess it translates to:

    "0 is a protected WP-property and cannot be changed."

    Is this a new phenomenon? Or did the fix not find its way into the 2.8.2 build for some reason?

  9. agreda
    Member
    Posted 4 years ago #

    I'm running 2.8.2 and I get this same error when trying to save widgets. The little status wheel next to the save button also just spins continuously once a widget is added.

    So ... I can't add any widgets! Any ideas for a fix are greatly appreciated. Thanks.

  10. agreda
    Member
    Posted 4 years ago #

    Bump... I've been staying current with upgrades, now running 2.8.4a and this issue continues. Attempting to save widget edits results only in the "WordPress Failure Notice" ...

    Are you sure you want to do this?
    Please try again.

    Any and all thoughts appreciated. Thanks!

  11. andrea_r
    Moderator
    Posted 4 years ago #

    And what do your error logs say?

  12. agreda
    Member
    Posted 4 years ago #

    Quite a bit actually :-\ but based on the time, frequency, and my IP address, this error occurred at the times I received the error...

    [Thu Aug 13 09:50:14 2009] [error] File does not exist: /home/tripawds/public_html/wp-logo.gif

    I confirmed the file is indeed missing, but this is a fresh upgrade to 2.8.4a ... should it be there? And if not, why would the img be getting called when trying to save a widget?

    Thanks for asking.

  13. andrea_r
    Moderator
    Posted 4 years ago #

    No, there's no graphic files in the root folder. So something is looking for that file, but in the wrong spot.

    Hrm... what plugins are running?

  14. agreda
    Member
    Posted 4 years ago #

    Thank you for your thoughts! We are running ...

    mu-plugins
    Avatars*
    Custom Content Dashboard Widget*
    Invites*
    Logout Redirect*
    MP Plugin Manager
    Personal Welcomes*
    Post Indexer*
    Comments Indexer*
    Dashboard Feeds*
    First Comment*
    Global Header
    Signup TOS*
    Simple Sitemaps*
    Supporters*
    Widgets*
    - Avatar
    - Blogs
    - Recent global Comments Feed
    - Recent global Comments
    - Recent global Post Feed
    - Recent global Posts
    - Supporter
    - Support Badge
    *WPMU Dev Premium

    plugins
    All in One SEO Pack**
    cforms*
    NextGEN Gallery*
    Simple:Press Forum*
    Subscribe To Comments**
    Text Link Ads*
    TypePad AntiSpam
    Unfiltered MU**
    WP-SpamFree**
    *main blog only
    **activated for Supporters only

    FYI: I placed a copy of the wp-logo.gif file in the root directory, and attempted to save text widget edits. The error did not display and no error was written to the logs. But, the widget did not save either, the progress wheel just kept spinning, and spinning, and spinning and probably still is...

    Will attempt to isolate plugin conflict – in my copious free time! ;-) Thanks again.

  15. andrea_r
    Moderator
    Posted 4 years ago #

    Usually, the process is to disable all plugins (including mu-plugins) see if you get the same error. If not, it's a plugin or a conflict between two plugins.

    If you still get the same error on a "clean" install/upgrade, make sure you got all the files upgraded properly.

  16. masonjames
    Member
    Posted 4 years ago #

    Hello all, I just updated (using automatic update... I know I know) from 2.8.6 to 2.9.1 and am getting this error (Are you sure you want to do this?
    Please try again.) as well.

    Is it for sure a plugin conflict? I'm deactivating them now and will report back.

  17. masonjames
    Member
    Posted 4 years ago #

    Update: Plugin Name: WPMU Plugin Manager, Version: 2.0

    That was the culprit. Once that was deactivated. Everything's up and running again! Guess we need a new version.

    -masonjames

  18. MerlinWz4
    Member
    Posted 4 years ago #

    I'm using 2.9.1 as well and had this exact same problem today. I noticed that it only happened when I went to Site Admin...Options...Allow New Registrations and changed that option from 'Disabled' to 'Enabled. Blogs and user accounts can be created.' The only way I could finally get rid of it was to wipe everything related to Wordpress and put a fresh copy back. I would really like to allow folks to self-signup for a blog. Anyone else see this problem or know of a fix?

    David

  19. MerlinWz4
    Member
    Posted 4 years ago #

    Just for a little more information, when I changed other options under Site Admin...Options..., I had no problems. It worked like a champ.

  20. andrea_r
    Moderator
    Posted 4 years ago #

    trac ticket filed just a few minutes ago stated they had this, but hitting the "upgrade" button sorted it all out.

  21. MerlinWz4
    Member
    Posted 4 years ago #

    Thanks Andrea - I tried that but still have the same problem. Luckily, I was able to rollback to a good snapshot and get it back easier, but the problem still isn't fixed. Since I'm new to this, do you have any idea how long these sorts of things take to get worked out?

  22. andrea_r
    Moderator
    Posted 4 years ago #

    The devs go by what is in trac, not the forum.

    http://trac.mu.wordpress.org

    If nobody reports an issue, or confirms it's still a problem, then the devs don;t know and it doesn't get fixed.

    So go to trac, login with the same user/pass as here, look at the tickets & find the one that deals with this issue and add more to it.

  23. attacker08
    Member
    Posted 4 years ago #

    hi, i am new to here. I updated to 2.9.1 and i have the same problem, when i clicked on update, search or anything the same message showed up. anyone knows how to fix this problem? thanks! is it something wrong with my index.php?

  24. MerlinWz4
    Member
    Posted 4 years ago #

    The solution in trac worked great for me. I had to add insert one record into my wp_sitemeta with a new metakey of "no_anti_spam_nag" and a metavalue of "1" and now I don't have anymore problems. Good Luck all.

  25. tyronerubin
    Member
    Posted 4 years ago #

    This helped me and was pretty simple thanks
    http://trac.mu.wordpress.org/changeset/2057

  26. nicsco
    Member
    Posted 4 years ago #

    I've had the same error while updating Wordpress-Mu from 2.9.1 to 2.9.1.1.

    The issue was caused by plugin: WPMU Plugin Manager, version: "2009-9-16".

    As I've disabled the plugin, I could update without problems.

  27. rajanpanicker
    Member
    Posted 4 years ago #

    When I tries to install new wordpress theme by upload,its showing the same error.Anyone knows a work around for this.I have no plugins installed as I just setup my blog. Google for information, but all in vain.I am newbie,so please help me to get around this problem

About this Topic

  • Started 4 years ago by nejko
  • Latest reply from rajanpanicker