The MU forums have moved to WordPress.org

one sub-domain only allows view of admin (3 posts)

  1. anointed
    Member
    Posted 4 years ago #

    I can't figure this one out.

    When I first setup wpmu, I created a number of sub-domain blogs for later use. Everything was perfect until today, at least this is the first time I noticed the problem.

    The problem is simple: I have one blog xyz.domain.com where when you go to view it, you are shown the login page instead of the site. Ok, weird... so I login, and I'm immediately sent to the wp-admin side. No matter what link I click anywhere, from view post, to change theme, everything goes directly to the wp-admin.

    I have no way of viewing any page outside the admin, only on this one particular blog.

    I have looked at every single setting in the admin, and see nothing that could cause this.

    Has anyone seen this behavior before, and maybe have a solution?

  2. seb_m
    Member
    Posted 4 years ago #

    I had this problem the other day. It sounds like xyz is your "Dashboard blog" - basically, when you have multiple blogs hosted on your WPMU installation, you have to choose one of them to always take you straight to the admin area. I would create a new blog called "dashboard", then go to Site Admin -> Options and set "Dashboard Blog" as "dashboard".

  3. anointed
    Member
    Posted 4 years ago #

    thank you seb, I would not have figured that one out as my understanding of the 'dashboard blog' was totally different than it appears to work as.

    I removed the setting and it changed the root blog to dashboard, which is still viewable, so problem is solved.

About this Topic

  • Started 4 years ago by anointed
  • Latest reply from anointed