The MU forums have moved to WordPress.org

How to Install Wordpress MU on IIS 7 on Windows 2008 Server (8 posts)

  1. dh
    Member
    Posted 4 years ago #

    I'm always asking for and searching for help in places like this, especially because we host Wordpress (and now WPMU!) on Windows servers!

    Hopefully this will help other people that want to run Wordpress MU on Windows. We used Wordpress MU Version 2.8.6 and are running IIS 7 on Windows Server 2008.

    I'm just going to tell you how we got WPMU running, not how to install PHP and MySQL and all that stuff. There's plenty out there about that, but less about this specific topic:

    How to Install Wordpress MU on IIS 7
    ------------------------------------

    Download Wordpress mu

    Extract and copy into desired directory on IIS 7 web server

    Give IUSR user account modify and write permissions on the directory in IIS

    Create database and user with all permissions to use it in MySql
    Navigate to the location of your site (where your files are stored on IIS)

    Enter the required information in the mu installation screen – make sure your server address isn’t a single word – such as ‘mysite’, use ‘mysite.com, even if your mu installation is internal. We tried installing our site at ‘mysite’ for testing purposes, everything worked as described below, except we couldn’t log into the admin side using Firefox or IE 8 – only safari could log us in, something to do with the cookies used to process login.

    We used sub-directories, we couldn’t get sub-domains to work.
    Enter all the other details on the mu installation screen as expected, then press install.

    We got a 500 Internal Server Error, but not to worry, everything’s been created!

    Normally the admin password would be e-mailed to the address you entered on the previous screen, but in our case it wasn’t (on-going issues with the php mail function and receiving mail to our Exchange 2007 Server).

    What we did to get round this was to go into the database in phpMyAdmin and manually change the password (user_pass field in the wp_users table) to one of our choosing, but be sure to use the ‘md5’ function to encrypt your password before you update your table.
    Go back to your server address to see the home blog running as it should.

    Log in with the ‘admin’ user and the password you’ve just set.
    We didn’t have to make any changes to get pretty permalinks working (I’m sure you would on IIS 6 though – they seem to be the default option with mu. What we did do though is remove /blog/ from the permalink structure under Blog > Edit. I don’t know why this was added by default, but we don’t want it, so removed it. We for some reason it didn’t work the first time we navigated to a page, we got the not found error, although the link we tried was pointing to the correct location – without /blogs/

    We can now create and manage as many blogs as we like (sub sites actually) and we’ve even got the WPDirAuth plugin working with them.

    Hope this helps someone.

  2. andrea_r
    Moderator
    Posted 4 years ago #

    Thansk! :) Now I can point people somewhere.

    The /blog/ part gets inserted on the main blog in subfolder installs to help with permalink collisions. If, for example, you had created a page called "themes" and then a blog called "themes" WPMU has no idea which one to serve.

  3. dh
    Member
    Posted 4 years ago #

    Hi Andrea, thanks for that, plus it makes sense, but we use wordpress as a cms and including the /blog/ bit didn't make sense to us :)

    We always seem to be overcoming these wordpress / IIS issues in the past few months, and just wanted to document somthing for a change, and hopefully help other people. Hope it does!

  4. ssandison
    Member
    Posted 4 years ago #

    Enter the required information in the mu installation screen – make sure your server address isn’t a single word – such as ‘mysite’, use ‘mysite.com, even if your mu installation is internal. We tried installing our site at ‘mysite’ for testing purposes, everything worked as described below, except we couldn’t log into the admin side using Firefox or IE 8 – only safari could log us in, something to do with the cookies used to process login.

    I managed to get the login working by adding the following to wp-config.php:

    define('COOKIE_DOMAIN', false);

    I encountered the same issue working on a corporate intranet. I am using this in a sub-directory model install of WordPress MU 2.8.6 and there seems to be no ill affects. Obviously you would need to test it thoroughly if you plan to use it in a production environment. I will post any problems that I find.

  5. mrco
    Member
    Posted 4 years ago #

    I needed to do this on IIS as well..so i followed these instructions, I only had 1 problem

    when I go to http://resheske.net/resheske/ and click on the hello world entry (http://resheske.net/resheske/blog/2010/01/13/hello-world/) I get a "Page Not found" error, I went ahead and removed directly from the address the '/blog' portion and it worked. So I went and removed it from the Permalink Structure, but even though the address no longer has '/blog' in it, it still gives me a "not found " error. The curious part for me is that if I add /blog to the url address it works...so it only works at the opposite of what the permalink structure says...

    any suggestions?

    ---
    edit:
    Just for the record..this just started working after a while. I guess this is some sort of hiccup ?

  6. dh
    Member
    Posted 4 years ago #

    hey mrco - it's a strange one that, we encountered the exact same thing too to start with. Removed it from the permalink structure, still got an error, refreshed a few times and all was good.

  7. sporty
    Member
    Posted 4 years ago #

    this is a great post - I hope someone in the know can also add to it (or post a GOOD link) on the other parts - "how to install PHP and MySQL and all that stuff", for us bunnies which don't know what all that stuff means or the best way to get mysql onto iis 7.5

    cheers
    ewart.

  8. cpmrgmt
    Member
    Posted 4 years ago #

    Hi

    I am new here and just dealing with the Permalinks after having a hard time installing WPMU. Following your directions I got to fix the login issue but now, i cannot make the pagees-links work whenever i choose any Permalink option but default. And with default chosen, Byddypress just does not work. What could I do?

    I could not understand where to locate the '"Blog > Edit"' for me to modify it, there is not such an option under WPMU Admin Menu neither folder in my site domain.

    Thanks.

About this Topic