The MU forums have moved to WordPress.org

Fatal error: Call to undefined function wp_die() (34 posts)

  1. nbenton
    Member
    Posted 4 years ago #

    I have installed WPMU on several servers, but installing version 2.9.1 repeatedly gives me this message:

    Fatal error: Call to undefined function wp_die() in /homepages/6/d247401802/htdocs/wp/wp-includes/wp-db.php on line 1147

    I have taken down the wordpress code several times to be sure there isn't a file missing, and each time I try to install I set up a new MySQL database to be sure there isn't something in the database causing the error.

    Does anyone have any advice?

  2. locolbd
    Member
    Posted 4 years ago #

    It seemly means you already have tables with the prefix wp_ in the database you are trying to install wordpress mu in. If you are currently using that database for the orginal wordpress installation i would advise that you create a new database for wordpress mu.

    Else you would have to drop the tables in the old database the have the wp_ prefix

    hope this helps

  3. nbenton
    Member
    Posted 4 years ago #

    Every time I retry, I set up a new database - I'm on my 7th. I guessed that it might be a database, and I also guessed that it might be that I did not copy the WPMU files completely, or that a file had been changed in a prior installation. So I also repeatedly erased the files and re-uploaded them.

    I don't think that your advice can solve the problem I am having since I've repeatedly tried that and failed.

  4. nbenton
    Member
    Posted 4 years ago #

    I'm up, but this is what worked.

    I loaded the previous version of WPMU (2.8.6) and it installed using the same process and steps that did not work for WPMU 2.9.1.

    I then used the upgrade feature of the old version to upgrade to 2.9.1.

    This suggests to me that there is something different about 2.9.1 what was causing the failure to install, but this is just one user's experience.

  5. andrea_r
    Moderator
    Posted 4 years ago #

    We installed it fresh locally and didn't get the error - worked fine. Not sure what your issue is.

  6. gregorydickson
    Member
    Posted 4 years ago #

    I had the same problem with a fresh install of Wordpress MU at fatcow.com (hosting provider). I am going to try installing a previous version

  7. styler388
    Member
    Posted 4 years ago #

    I've had the same problem too (On SiteGround)...

    Looks live installing a previous version is in order!

  8. VBPartners
    Member
    Posted 4 years ago #

    I'm having the same problems installing 2.9.1.

    I'd like to try to install the 2.8.6, but can not find where to get/download that version?

    Can someone point me in the right direction?

    thanks!

  9. reboltutorial
    Member
    Posted 4 years ago #

    I'm having the same problem too :(

  10. blackandwhite
    Member
    Posted 4 years ago #

    i had it too I deleted my domain added it again anddid the instalation and I got a white, i mean blank screen.... I'm going try to install version 2.8 and upgrade see if it will work...

  11. flippinmonk
    Member
    Posted 4 years ago #

    I've have the exact same problem with the same version. I've installed countless versions of wordpress and wp mu and no matter how you setup the database or recopy the files on 2.9.1 it still gives the "undefined function wp_die()" error. I'm going to download MU 2.8 and i'll let you know if there are any issues.

    It most likely is the wp_ database extension conflicting if you are doing multiple installs but setting up seperate database should fix that.

  12. donncha
    Key Master
    Posted 4 years ago #

    Check your plugins. The "role scoper" plugin caused that problem. If it's that, the author will need to update the plugin.

  13. andrea_r
    Moderator
    Posted 4 years ago #

    I just tested this again, locally, fresh install, fresh database.

    It worked flawlessly.

    Make sure your db user is assigned to the database, has ALL permissions, and has a password great than 6 characters.

  14. carlofardella
    Member
    Posted 4 years ago #

    Hi Guys,

    Just a quick note.

    I was having the exact same problems described above and andrea_r's post regarding the mySQL password worked for me!

    Just ensure that there is a password on your local setup.

    Regards,
    Carlo

  15. jeremypound
    Member
    Posted 4 years ago #

    Just to add a little help, I wanted to share how I resolved this. First, I was experiencing the problem because I assumed the database access was LOCALHOST, as the setup screen suggests. Some hosting providers use more specific addresses, such as Media Temple's Grid Servers.

    Once I realized this was the case, I updated this field by copying and pasting it, and it brought along a space after it. Seems the input fields are not trimmed on submit, so make sure you don't have a space after your data.

    Removed the trailing space from my db address and setup finally succeeded.

  16. patsar
    Member
    Posted 4 years ago #

    I had the same problem on the Dreamnost when I use the http://mysql.mydomain.com/ as server name. The installation worked fine with mysql.mydomain.com as server name.

  17. cshbell
    Member
    Posted 4 years ago #

    This error message (Call to undefined function wp_die()) will also occur if the MySQL username and/or password is incorrect. To be fair, it’s a user error, but ideally WordPress MU should trap this problem and handle it more gracefully than a PHP error screen.

  18. andrea_r
    Moderator
    Posted 4 years ago #

    It usually does. This was a last minute bug that crept in.

  19. MissGruurly
    Member
    Posted 4 years ago #

    I'm having the same issue, tried all of the same things - nothing is working. I've:

    - checked the database name and password, both are fine. password is 8 characters (letters and numbers), and user name has all permissions;
    - I'm installing to a subdirectory as per my host, and have erased and uploaded twice thinking maybe it was my install (it wasn't);
    - confirmed that localhost is my host name.

    My guess is that the issue with the other wordpress installs on my root and within other subdirectories on my site, but any fix I've tried along these lines has led to a missing wp-config file error.

  20. MissGruurly
    Member
    Posted 4 years ago #

    Ok, I'm a fool.

    Simple fix for me.

    I was using just my user name (xxx) to set up the database when plugging in the data to the WPMU setup, when I should have been using the database name, _, user name (wpmu_xxx).

    It worked, all is well.

    I'm sheepish.

  21. 20twoes
    Member
    Posted 4 years ago #

    I used localhost.localdomain instead of just localhost for my database and it worked.

  22. georgiegrace
    Member
    Posted 4 years ago #

    @cshbell, I was having this problem and it was just that user error.. I'm *very* sheepish. The error message made me think it was something way more complicated, so thank you for adding it to the thread.

  23. SimpleWP
    Member
    Posted 4 years ago #

    Don't forget to clear history in your browser!

    I was all but dead with this problem until I did that.

    In my case, I already had my website up and running, but I'd piled up enough errors from my attempts with plugins to restart the whole site fresh. Then I had the error message described above.

    Fatal error: Call to undefined function wp_die() in / (snipped) /wp-includes/wp-db.php on line 1147

    I did complete reinstalls of the database, and uninstalled everything to do with WPMU on my Godaddy deluxe hosting account. I tried fresh names for my database and for my directory. It had all worked earlier, so it should have worked. Still I got the same error.

    Then I switched browsers and it worked! I moved from Firefox 3.5.5 to Safari 4.0.4 and did not get the error any longer. I suspect I should have cleared the history (cache, ect) from the browser.

    I am a Noob to WP and to WPMU and to site administration. I intend to use wpmu to manage 10-20 websites for 8 consulting clients. The premise is that it will be easier than making separate platforms for each. Also that they will be empowered to make their own updates.

    Am I likely to be seeing more bugs (user errors) like this one once I have the site up and running with my main plugins and themes tested?

    I don't like the risk of long down times while I figure things out.

    Thanks for any thoughts, and I hope my browser discovery helps.

  24. SimpleWP
    Member
    Posted 4 years ago #

    Yes, that was it.

    Clearing browser history, I was able to do a complete site reinstall without bugs.

    So far, so good.

  25. ToreGu
    Member
    Posted 4 years ago #

    I had the same problem and thanks to Andrea I understood that it was user priviledges that was not set.

  26. fluve
    Member
    Posted 4 years ago #

    Hi

    I did read throhg all the posts, but I still cannot get Wordpress Mu up and running on Xampp on localhost. The XAMPP install is a clean install, which I did dnot change.

    This is what I did
    Create a new database : Name FluVe
    Create a new AdminUser : Name FluVeAdmin
    Added all rights for My Sql and database FluVe.
    Created password 8 characters letters and digits.

    I Put my wordpress mu in the subfolder wpmu in htdocs.

    Hostsfile
    Added
    127.0.0.1 localhost
    127.0.0.1 localhost.localdomain

    Changed the httpd.conf file as folows:
    LoadModule rewrite_module modules/mod_rewrite.so

    I changed the sections into
    '#
    # "C:/xampp/cgi-bin" should be changed to whatever your ScriptAliased
    # CGI directory exists, if you have that configured.
    #
    <Directory "C:/xampp/cgi-bin">
    AllowOverride AllowOverride FileInfo Options
    Options None
    Order allow,deny
    Allow from all
    </Directory>
    and
    # First, we configure the "default" to be a very restrictive set of
    # features.
    #
    <Directory />
    Options FollowSymLinks
    AllowOverride FileInfo Options
    Order deny,allow
    Deny from all
    </Directory>

    Added to the end
    NameVirtualHost 127.0.0.1

    <VirtualHost 127.0.0.1>
    DocumentRoot c:/xampp/htdocs/
    ServerName localhost
    </VirtualHost>

    Than I go to 127.0.0.1/wpmu and get the installsheet.
    Fill in the parameters
    Submit
    and get
    Fatal error: Call to undefined function wp_die() in C:\xampp\htdocs\wpmu\wp-includes\wp-db.php on line 1147

    Please can anyone tell me what I missed.

    Thx in advance

    Klaas

  27. andrea_r
    Moderator
    Posted 4 years ago #

    That error shows if you mess up your DB details.

  28. diddycentre
    Member
    Posted 4 years ago #

    hope this works.

    i think this problem just database name and database username.

    make sure your database name and username is same.

    User : tiki_otaiinf
    Database: tiki_otaiinf

    thanks

  29. SteveAtty
    Member
    Posted 4 years ago #

    My username and DB name are not the same and I've no problems at all

  30. strategicblend
    Member
    Posted 4 years ago #

    We're also having the same issue and it has nothing to do with incorrect db info being entered. That is 100% correctly being entered each time.

    I've created 3 new databases and each has this issue.

    I'm going to try going back to a former version of WPMU and then upgrade after the fact (as previously mentioned above).

    I'm curious if the WPMU dev team has any official solution for fixing this in the code?

About this Topic

  • Started 4 years ago by nbenton
  • Latest reply from Quentin80