The MU forums have moved to WordPress.org

wp-signup.php on line 392 , Cannot modify header information (10 posts)

  1. tohave
    Member
    Posted 7 years ago #

    Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/wp-content/themes/default/header.php:5) in /home/public_html/wp-signup.php on line 392

    Hi,

    I searched but nothing found. This is strange cause MU was working (not as I wanted but..) till this happend. There is no space at the beginig or at the end of either header or sign-up files, files are not modified since last stable setup. Any suggestion welcome

  2. tohave
    Member
    Posted 7 years ago #

    Please any one can help? My site is down !

  3. nexia
    Member
    Posted 7 years ago #

    there is no default php line in header.php, and there is no line 392 in wp-signup, so someone played with the files...

    deactivate all your plugins and try again...

  4. tohave
    Member
    Posted 7 years ago #

    Hi Nexia,

    Line 392 is exist on mine and is this line:

    header( "Location: http://{$current_site->domain} {$current_site->path}" );
    I have to add that I did translate the words but it was working before.

    I also disabled the plugins as you said, but problem is remaining.
    Please could you thin of other possibilities?

  5. coolrasta
    Member
    Posted 7 years ago #

    I am facing the exact same issue ... Like tohave I checked everything as explained in other threads ...But still get the error message ... Think it has sometthing to do with rewrite rules maybe ...
    Follow up

  6. tohave
    Member
    Posted 7 years ago #

    It seems to me that I should remove MU and do what ever I like. Like fisshing or skying... joking

    Still problem is there. I tried to reinstall the MU but there was a question: will I loose all setting and blogs that I got already?

  7. corourke
    Member
    Posted 7 years ago #

    tohave:
    Did you contact your host? Check files again (including reuploading the entire site).

    If that doesn't work try this:

    1. backup your database.
    2. Delete your database and all blogs.
    3. Reinstall wpmu
    4. Import your database backup.

    If it still doesn't work post here again.

  8. scole
    Member
    Posted 7 years ago #

    This problem is a simple one, but may be hard to locate.

    The problem is that somewhere before the header was called there's a blank line. The script is seeing this blank line and stating that the header was already sent.

    To fix, what you need to do is find the blank line. :)

    I recommend looking at the code and find out what is before the header(...). You are looking for a blank line that is not within php code.

    For example...

    {html code}

    <?php ... code ...
    ?>

    In between the html code and the <?php is a blank line. This has to be removed.

    Hope this helps.

    Good luck,
    S. Cole

    (p.s. I had the same problem with my wordpress install too)

  9. scole
    Member
    Posted 7 years ago #

    Also... The space may not be in the same file but in another file that is called before the header(...) is ran.

    S. Cole

  10. tohave
    Member
    Posted 7 years ago #

    Hi all,

    I just ruined the entire site, databases and all weblogs.

    I have no problem to solve now. and going to start a fresh installation.

    I was thinking if the backup utility affects the files or not? I had some script chanded after backing up the site.

About this Topic