The MU forums have moved to WordPress.org

Upload creating directory, what is upload path? (9 posts)

  1. aowpmu
    Member
    Posted 7 years ago #

    I have installed WordPress MU and it is working great. However, I have a problem with the upload function. When I try to upload I do not get an error, but it does not post the upload. The directory structure is being created, but there is actually no files in the directory. What should I check for? My upload path is currently set as "wp-content/upload"

    Thanks

  2. nexia
    Member
    Posted 7 years ago #

    on wpMU, the upload dir3ctory is : /wp-content/blogs.dir

    you have to chmod 0777 it when starting WPMU, as written in the documentation

  3. aowpmu
    Member
    Posted 7 years ago #

    Changed the upload directory to /wp-content/blogs.dir and chmod to 777, but it still does not upload the file. Any other suggestions?

  4. aowpmu
    Member
    Posted 7 years ago #

    I still can't upload any file with a post. Is this a mod_rewrite problem? I have the directories chmod to 777 and have the upload path set to /wp-content/blogs.dir .... I have seen a lot of mod_rewrite files floating around, so what is the correct one to use? I have the same problem with the file upload with both the stable release of wordpress mu and the nightly build. Is there any other help you can provide on this so I can get file uploads to work?

    Thanks

  5. andrea_r
    Moderator
    Posted 7 years ago #

    On a fresh install, you shouldn't have to tell MU where the upload path is. Stable or night shouldn't matter, neither shoud the default htaccess.

    Actually, now that I'm poking around, I can't see where you would even change it. MU figures out where, on its own based on blog ID what directory the files should go in, under /wp-content/blogs.dir/. As long as permissions are set right on those directories, it should create numerical subfolders based on that blog id, then a year folder, followed by a month folder, finally dumping the file in there.

    I suspect it's probably some sort of server issue. Either with permissions or the amount of subfolders allowed.

  6. aowpmu
    Member
    Posted 7 years ago #

    It is creating the subfolders in the correct directory (under /blogs.dir/1/files/2006/12/), but there is just nothing in these subfolders. When I tell it to upload a file it does not give an error it just returns me back to the "Write Post" page. I do not get the Browse All button. The folders are being created, but my files are not going in that folder.

    When I first installed MU, the upload path was /wp-content/upload but there was not a /uploads folder, so I was wondering if my upload path was wrong.

    I am just kind of confused as to how the folders are being created, but the file is not going in there? Does that lead you to suspect anything else???

    One other side note, I installed regular Wordpress onto the same webserver, and it had absolutely NO issues with uploads.

    Thanks.

  7. lunabyte
    Member
    Posted 7 years ago #

    The path wasn't wrong, initially. If someone were to view an uploaded file, that's the path that they'll see. The rest is done on the back end, with htaccess.

  8. aowpmu
    Member
    Posted 7 years ago #

    I have set my path back to what it was originally (wp-content/upload) and I have the permissions set to 777. However, I still have the same problem with the file not uploading. The folders are being created for all the blogs under the blogs.dir ( i.e. /blogs.dir/1/files/2006/12/ ) folder when I try to upload a picture, but the file is not being placed there. I think this is why I don't see the Browse button on the upload section as I should. Is there anything else I can try? Is there a problem with my .htacess file? Any other suggestions?

  9. Anonymous
    Unregistered
    Posted 6 years ago #

    This worked for me, using a Plesk environment:

    Make sure the web server user (apache in my case) is a member of the group owner of the blogs.dir folder (psacln in my case.) Doing this enabled me to keep the blogs.dir and subfolders 775.

    usermod -G psacln apache

About this Topic