The MU forums have moved to WordPress.org

1 2 3 4

WPMU Avatars Released! (91 posts)

  1. suleiman
    Member
    Posted 7 years ago #

    Credits

    FINALLY! A WPMU Avatar pack that works! :)

    But truly this isn’t a moment for me to bask in any kind of glory. Virtually 95% of the work that has gone into this plugin pack has come from other plugin authors for WordPress–they are a fantastic community of developers and they deserve full credit for what they do.
    Most notably, the Profile Pics plugin was originally done by Hannah Grey, with major modifications to make it MU compatible by WDuluoz.

    Usage

    After installation, users will be able to navigate to their Profile page and upload their own photo. The photo will appear next to their comments across your WPMU site, and, if they use my Author Profile Enhanced widget, in their sidebar next to their “About Me” text. For a demo see http://suleiman.hadithuna.com.

    For more information and to download visit http://suleiman.hadithuna.com/wpmu-avatar-pack-release/

    Digg it if you like it!

  2. drmike
    Member
    Posted 7 years ago #

    Thanks,
    -drmike

  3. suleiman
    Member
    Posted 7 years ago #

    no prob drmike

  4. drmike
    Member
    Posted 7 years ago #

    Considering my solution was breaking the signup procedure on my setup...

  5. Ovidiu
    Member
    Posted 7 years ago #

    @suleiman

    the idea behind this was to get a local avatar system, right?

  6. suleiman
    Member
    Posted 7 years ago #

    yes.

  7. findtj
    Member
    Posted 7 years ago #

    I just upgraded to your new system and I am having troubles with it... It seems that the changes to the user profile are blog system wide. So if two different users on their respective blogs use the same widget, it only will show only one person's data...

  8. suleiman
    Member
    Posted 7 years ago #

    Findtj, what do you mean by the changes to the user profile system being blog wide?

    If you were using the previous plugin pack, you will notice that images were being saved by blog_id. This did not work well, because users would delete blogs but retain ther username for blogging purposes etc., In addition when two users were authors to the same blog, then the widget would have peculiar results on those blogs because their images were saved as blog_id.jpg.

    The new system uses user_id.jpg. It pulls the correct information into a variable called $blogownerid from the post_author row in the wp_$blogid_posts table. And this is much better, for the aforementioned reasons.

    If several of your users have already uploaded images under the old system, what you should do is copy those images into your new wp-content/avatars/.

    Then lookup what user owns which blog, and rename the jpg file linked to their blog to link instead to their userid. (e.g., user "Suleiman" has a blog_id of 23 but a user_id of 1. Under the old uploader a file calld 23.jpg would have been used. Rename that file to 1.jpg and the new widget will work again)

    You should also remove from your profile.php page any hardcoded form information, and delete from your mu-plugins folder the old "fergcorp.." php file.

  9. findtj
    Member
    Posted 7 years ago #

    Ok, I think I am following you on this... and I did not delete the fergcorp doc.... so I have removed all the old stuff and am re-installing it...

  10. findtj
    Member
    Posted 7 years ago #

    yes.. if you your latest install, and the fergcorp doc installed then you get dual profile picture boxes in the profile page. still testing....

  11. findtj
    Member
    Posted 7 years ago #

    hmm, ok now I run into where the author_profile.php widget does not work unless it is in the mu-plugins folder. It does not show up on the widget page when placed in the mu-plugins/widgets folder...

    ideas?

  12. findtj
    Member
    Posted 7 years ago #

    Ok... I have given up for the time being and am not using it. I have hardcoded in the look/feel of the last one in a text box... to get by in the meantime. sarahj.yakimablogs.com.

    The short take:
    a: The image management tool is much better than the last, however I was unable to get any images to show up.
    b: The text from the admin profile showed up in all of the other blogs using the widget, ignoring the text from the individual blog owner/admin's profile/about.

    Also of note. I am using wordpress-mu-1.0. I am concerned that I may really screw things up if I attempt to upgrade to mu 1.1 - and 1.0 is working well enough right now.

    Hope this helps in this widget development.

  13. suleiman
    Member
    Posted 7 years ago #

    that is very strange findtj, do you have other widgets that work fine from the /mu-plugins/widgets folder?

    Have you disabled the old author profile plugin?

  14. findtj
    Member
    Posted 7 years ago #

    yup to the mu-plugins folder. funny enough, your empowered.php file. Otherwise all of my other widgets are running in the plugins or mu-plugins folder.

    I will post my plugin list next

  15. suleiman
    Member
    Posted 7 years ago #

    findtj, i'm a little confused, all of your widgets are running fine in the mu-plugins/widgets/ folder? or the /mu-plugins/ folder?

  16. findtj
    Member
    Posted 7 years ago #

    mu-plugins folder:

    anarchy_media_player
    author_profile
    custom_anti_spam
    delete-blog
    delicious
    empowered
    global-categories
    gsearch
    king-rss
    misc
    mycss
    pjw-mime-config
    pluggable
    profile-picture
    signup_anti_spam
    untimate_ga
    widgets
    (folders)
    anachy_media
    custom-anti-spam
    MyCSS
    widgets

    ------

    plugins folder:

    adsense-deluxe
    get-recent-comments
    subscribe-to-comments

    (folders)
    king-includes
    polls
    wp-contact-form

  17. suleiman
    Member
    Posted 7 years ago #

    findtj, author_profile, as with all your other widgets, should be in the mu-plugins/widgets folder, or in the plugin folder.

  18. findtj
    Member
    Posted 7 years ago #

    The widgets that are working in the widgets folder are the 'empowered.php'

    When I installed mu 1.0 it did not have a widgets folder. Only when I installed your empowered.php was I needing one. Everything else worked when it was installed in the mu-plugins folder.

    Does that answer your question? Thanks for the help btw.

  19. findtj
    Member
    Posted 7 years ago #

    They only seem to work in the mu-plugin folder. I guessed it had something to do with mu1.0.

  20. findtj
    Member
    Posted 7 years ago #

    Yea, if I have the author_profile.php in the widgets folder, it does not show up at all. Once I put it in the mu-pugins folder it does....

  21. findtj
    Member
    Posted 7 years ago #

    I am going to pull the plugin out again, other than deleting it, how do I 'disable' it? thx.

  22. suleiman
    Member
    Posted 7 years ago #

    rename to .phps

  23. findtj
    Member
    Posted 7 years ago #

    ok.. reinstalling...

  24. suleiman
    Member
    Posted 7 years ago #

    good luck, i'm heading out to eat so I may not be on here to help for a while I'm afraid.

  25. findtj
    Member
    Posted 7 years ago #

    Thanks though. I just re-installed following your directions and not putting the author-profile.php in the mu-plugins folder. So the result: the widget did not show up. However, the MyCSS and the profile pictures tool works. I will look at it again tomorrow. Maybe I am missing something else...

  26. suleiman
    Member
    Posted 7 years ago #

    is anyone else having these problems with the release?

  27. drmike
    Member
    Posted 7 years ago #

    I haven't installed it yet. I'm still working on the signup issue and moving servers.

  28. suleiman
    Member
    Posted 7 years ago #

    moving once again? I seem to have recalled you moving not too long ago doc!

  29. kosir
    Member
    Posted 7 years ago #

    I have a problem with this version and have already posted this in your blog. Anyway everything looks like it works but users can't upload pictures even tho everything is chmodded correct.

  30. suleiman
    Member
    Posted 7 years ago #

    Koshir, which browser are you using? Try using FF or Opera and then see if it works. (uploads are broken in ie7 for the time being)

1 2 3 4

About this Topic

  • Started 7 years ago by suleiman
  • Latest reply from scorpianrules007