The MU forums have moved to WordPress.org

posts and page links not working (9 posts)

  1. qza
    Member
    Posted 7 years ago #

    After upgrading to wpmu 1.2.1, posts, pages and categories links not working on some blogs. Also when I try to post on those blogs, it returns 500 error.
    When I try to access posts, pages or categories on those blogs, it gives following warning in the header:

    Warning: Invalid argument supplied for foreach() in /home/myusername/public_html/wp-includes/classes.php on line 88

    Line 88 of wp-includes/classes.php is this:

    foreach ($rewrite as $match => $query) {

    What might cause this? Thank you in advance.

  2. qza
    Member
    Posted 7 years ago #

    Didn't know what was the problem, but it was fixed by creating new pages in each blog.

  3. metaface
    Member
    Posted 6 years ago #

    I had the same problem and found that the problem was caused by invalid data in the rewrite_rules option field of the wp_x_options table

    (When I saw this warning, clicking on post titles generated 404 not found errors for that blog)

    By restoring this value the problem went away.

  4. Farms2
    Member
    Posted 6 years ago #

    Any ideas for a global fix for, say, tens of thousands of blogs :)

  5. drmike
    Member
    Posted 6 years ago #

    Do me a favor and check to see if resaving the permalinks solves the issue. If it does, I think I can work out a fix for you.

  6. Farms2
    Member
    Posted 6 years ago #

    Hmmm, having fixed it I need to find some more errors first - I'll get back to you.

  7. Farms2
    Member
    Posted 6 years ago #

    And the answer is, yes it does... all I had to do was go into Options>Permalinks and the problem went away.

    I strongly suspect it's realted to having non English characters somewhere these have copped up on Japanese and Norwegian edublogs.

  8. drmike
    Member
    Posted 6 years ago #

    Hmm, while you're on that topic, are you switching charsets in MySQL when it comes to blogs with non-english characters?

  9. davex
    Member
    Posted 5 years ago #

    I too found that all of my links that referred to other pages or individual posts in my blog caused a sort of circular logic error and would fail to a 404 or TRY AGAIN page.

    I fixed it (after several hours of searching etc) by

    :: downloaded the current version of WordPress

    :: went to http://YOUR BLOG NAME/blog/wp-admin/plugins.php page and deactivated all plugins

    :: deleted the wp-admin and wp-includes directories in the /blog folder

    :: copied the new WordPress files (not the folder, but it's content's) into the /blog directory

    :: went to http://YOUR BLOG NAME/blog/wp-admin/ to check for db error messages

    :: went to http://YOUR BLOG NAME/blog/wp-admin/plugins.php page and RE-activated all plugins

    :: MOST IMPORTANT STEP!!! Went to http://YOUR BLOG NAME/blog/wp-admin/options-permalink.php and made sure DEFAULT is chose under COMMON SETTINGS (mine was set to DAY/TIME) and click SAVE CHANGES

    and it worked better than ever!

About this Topic