The MU forums have moved to WordPress.org

Email Not Sending, Problem With Server Settings (4 posts)

  1. donloper
    Member
    Posted 6 years ago #

    I recently migrated several blogs from a GS server with MediaTemple to a DV server. Upon transferring the blogs, no emails will send out from any of them. There are no errors, everything appears to work fine, even in the logs, except that nobody receives any emails. If I use the Swift SMTP plugin I can get emails to send, but that has caused some conflicts with another plugin I have.

    Needless to say, it's obvious there is some server setting that is preventing the emails from actually going out and I should be able to fix this without changing any WP code. Does anybody know what settings I should be checking?

  2. tdjcbe
    Member
    Posted 6 years ago #

    Check with your host and see if they have enabled php to send emails on that box.

  3. cafespain
    Member
    Posted 6 years ago #

    Are you sure they are not sending? Have you checked your Spam folder on your email client?
    I had a problem at one point where all of my emails got marked as Spam and I needed to add a reverse DNS entry in my DNS to get them through (well I added it, and had done a few other things as well when it started working - so it was one of them).

    How are you finding the DV?

  4. donloper
    Member
    Posted 6 years ago #

    I like the DV server thus far. Sure beats running your own server, and I like the level of control it gives above and beyond most hosting packages.

    Problem solved! I guess it pays to contact support sometimes. After spending 5-6 hours trying to figure this out myself, I asked Mediatemple support for help and got this back, which solved the problem:

    I tested out the forgot my password for the badbillboard site and i see that the email is being sent out to a mwi.com address.

    You can take a look at the mail logs located at

    /usr/local/psa/var/log/maillog

    The reason that you will not receive this email is that the mail for mwi is hosted elsewhere and mail for mwi.com is enabled on the server locally. Disable the email for this domain and any other domain that has been created here on your server and also has mail hosted elsewhere.

    You can disable mail & dns for the domain, by

    1) login to plesk
    2) click domains
    3) select the domain ( mwi.com )
    4) click mail
    5) switch off

    If you continue to experience difficulties please provide us with more information such as the domain that is experiencing the issue where the domain is trying to send email.

    Best Regards,

    Frank Escobedo
    Senior Customer Support
    (mt) Media Temple
    <v> 877-578-4000
    <f> 310-564-2007

    ---------------------------

    So apparently it was sending to other people, just not mwi.com email which is what I use. Of course I didn't bother to ask anyone else if it was working for them...I just assumed it wasn't working at all.

    To explain this in another way, the problem was that the email address I've been using for all my blogs is mwi.com, and I use a hosted exchange server for mwi.com email, meaning I don't host my mwi.com email on the same server as the mwi.com website.

    But since email was activated on the web server for mwi.com, which is also hosted on the same dv server as these blogs, when the blogs went to send email to mwi.com addresses they would say "Hey, mwi.com is hosted right here on the same server, so we don't need to go out and check DNS, we can just send it right on over without going out to the Internet at all." and so it would send it to the local mail server for mwi.com, which as I said I'm not using, hence the disappearance of said emails without any errors showing up.

About this Topic

  • Started 6 years ago by donloper
  • Latest reply from donloper