The MU forums have moved to WordPress.org

Wordpress MU Couldn't find constant VHOST (29 posts)

  1. LostHalfwayThere
    Member
    Posted 5 years ago #

    I have been trying to install Wordpress MU, but have run into the following problem, it always gives this error:

    Warning: constant() [function.constant]: Couldn't find constant VHOST in /home/wiredtr/public_html/yourpress.co.cc/wpmu-settings.php on line 33
    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.

    I checked the debugging section, and did not have any luck. The site is located here: http://yourpress.co.cc/

    Please help.

    Thank You

  2. VentureMaker
    Member
    Posted 5 years ago #

    Looks like Apache VHOST directive and/or wildcard subdomains for yourpress.co.cc aren't set up properly.

  3. tdjcbe
    Member
    Posted 5 years ago #

    The debugging includes information that you need to include here. (ie walk us though with specifics as what you did to install the software.) Thanks though for looking at it. You're already doing better than most folks around here it seems like.

    It does sound like you modified the wp-config.php file yourself instead of letting the software do it. Best bet, if this is what you did, would be to delete the wp-config.php file, .htaccess as well, clear out the dbs and start again.

  4. LostHalfwayThere
    Member
    Posted 5 years ago #

    Alright, i deleted the .htaccess and the wp-config, and now all thats left is the wp-config-sample.php. I also dropped the database, but it seems that the problem is still there. :(

  5. andrea_r
    Moderator
    Posted 5 years ago #

    If it still shows "NO site defined on this host" then it still thinks it's installed somewhere. Double-check everything.

    wp-config-sample.php is only used on install.

    make sure you uploaded all the files needed.

  6. LostHalfwayThere
    Member
    Posted 5 years ago #

    Ok, so I redownloaded it, didnt change anything, and uploaded it. It did the same thing :(

  7. tdjcbe
    Member
    Posted 5 years ago #

    Can you make sure you;re setting the directory that mu sits in as writable by the webserver?

    What is vhost defined as in the wp-config.php file?

  8. andrea_r
    Moderator
    Posted 5 years ago #

    Make sure when you re-uploaded you do it into a CLEAN and empty directory, not just overwriting what's there.

  9. LostHalfwayThere
    Member
    Posted 5 years ago #

    I made it writable, and did completely empty the directory, but to no avail. vhost isnt defined as anything, because in an earlier post, somebody said to lot the software modify it. However, if I do define it as something, nothing happens either.

  10. andrea_r
    Moderator
    Posted 5 years ago #

    So...

    if you completely empty the directory, and then go back to your domain name, what do you see?

    I mean delete everything in public_html or whatever, do not reupload files, just leave it bare - then check.

  11. LostHalfwayThere
    Member
    Posted 5 years ago #

    I emptied public_html, and it just said Index of / like its suppuse to. So I dont think its the auctual server.

  12. andrea_r
    Moderator
    Posted 5 years ago #

    Just checking. :) I know it's not the zip.

    And just to clarify:
    - you downloaded the zip
    - unpacked it on your computer
    - then uploaded the files in that folder to public_html?

    And please tell me you're not editing the config file. :)

  13. VentureMaker
    Member
    Posted 5 years ago #

    OK, now try to install WPMU there and follow all instructions. See what happens next.

  14. LostHalfwayThere
    Member
    Posted 5 years ago #

    Should I follow the instructions supplied here, which say just to upload it and let the script modify it, or use the way the readme says and modify the config file and then upload it?

  15. andrea_r
    Moderator
    Posted 5 years ago #

    "or use the way the readme says and modify the config file and then upload it"

    The readme for WordpressMU does NOT say to use that.

    modifying the config file is for single-user wordpress. Nowhere in the multi-user version does it say to modify the config file.

    That's why you've been getting these errors.

    So just upload the files and let the script do it, because that's the way it's supposed to be done.

  16. LostHalfwayThere
    Member
    Posted 5 years ago #

    Your right, I just reread it, and it doesnt, I guess I just was delirious when I read it or something. Anyway, I downloaded it, unzipped it, and uploaded it, and it still gave the error. Is there any setting I need to change before I upload it?

  17. andrea_r
    Moderator
    Posted 5 years ago #

    no, there's no setting.

    there must be a stray file somewhere, that's all I can think of, because it *never* shows that info unless it's looking in the database and can't find the right blog.

    When you upload all the files in the zip to the root, you see an install screen, straight off.

    Make absolutely sure that wp-config.php does NOT exist, and that the database is completely empty.

    Do you know how to unpack the zip on the server and move the files to the right spot?

  18. LostHalfwayThere
    Member
    Posted 5 years ago #

    Well, the database is empty, however, since I didnt put any information in the wp-config file, then should it even know how to connect to the database? Also, could the fact that I have some other things installed on that host be affecting anything? Oh, and in response to your post, I know how to unpack a zip file to a place on the server, and move it to the right spot.

  19. andrea_r
    Moderator
    Posted 5 years ago #

    It comes up with an install screen if the files are placed there correctly. And it asks you to fill out the db info and all kinds of other stuff.

    So yeah, if you can unpack it on the server, try it that way.

  20. LostHalfwayThere
    Member
    Posted 5 years ago #

    Alright, I did that, and it worked, I think I found the problem, but Im not sure whats causing it or how to fix it. When I put wordpress MU in its own folder on the domain, it will work, but as soon as i put it in the root directory, it gives that error that I previously mentioned. What could be causing this?

  21. benspak
    Member
    Posted 5 years ago #

    I'm having the same exact problem, is there a way to get WPMU to run in the root directory?

  22. tdjcbe
    Member
    Posted 5 years ago #

    Sure it, the readme file runs your though it. Have you followed all of the steps in there? You may also want to review this thread as well.

    Required reading linked to from the readme file: http://codex.wordpress.org/Debugging_WPMU

  23. Mpalmer22
    Member
    Posted 5 years ago #

    I'm having this same problem as well. I've tried it a couple of times. I think the issue may have something to do with trying to install WP MU on a sub-directory. I want to install it on something.whatever.com .

  24. kipas
    Member
    Posted 5 years ago #

    you can see the http://mu.wordpress.org/forums/topic.php?id=9542, i have the same problem,

    Warning: constant() [function.constant]: Couldn't find constant VHOST in /home/****/public_html/hartipsimorangkir.web.id/wpmu-settings.php on line 33
    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.

    when i want install the wpmu in my shared hosting in add on domain hartipsimorangkir.web.id, in this case, in my root /home/****/public_html/, i install a wordpress,

    i search in the google. and the end a find the way/trick to resolve the problem, (I have found this case when i do its the same in localhost), i rename the file wp-config.php of the wordpress in the root to another, for example wp-config1.php, and then lets go to install the wpmu on the addon domain, after this installation wpmu finish, don't forget to the rename wp-config1.php to wp-config.php

    for example, i success install wpmu in http://hartipsimorangkir.web.id (addon domain), and http://hartipsimorangkir.web.id/batak is the sub directory

  25. kipas
    Member
    Posted 5 years ago #


  26. obeythefist
    Member
    Posted 5 years ago #

    It took me all day to get an answer to this problem. Just like everyone else, mine was a clean install, no edited files, no tables in the database.

    As stated in the post above (thanks!): The problem was that I had my domain pointing to a subdirectory of the root of my hosting account (as I'm guessing many WP installs do) and on the root is a standard WP install for an entirely different domain. The WP mu installer seems to look for a config file at the root level if it doesn't find one in its own directory.

    To fix, I had to rename my wp-config.php file for my root install to something else (temporarily taking that site down in a very ugly manner), then run the installer again. This time it informed me there was no config file and gave me the option of creating one, then the form for setting database variables finally came up.

  27. awarner20
    Member
    Posted 5 years ago #

    @obeythefist,

    Thank you so much for sharing your answer! I just ran across this in my install and used your method to fix it:)

  28. hlr
    Member
    Posted 4 years ago #

    Hi,
    I had a similar situation here (upgrading WordPress MU to 2.8.3 resulting in
    Warning: constant() [function.constant]: Couldn't find constant VHOST
    but my findings are somewhat different.
    There was no WP config file in the root. I deleted all other WP installations elswehere, the also the one I was upgrading - no result.
    even installing WPMU in the root didn't bring any relief.
    Then I began to suspect the wp-config.php. All other WP upgrades I've done keep the wp-config.php file. WMPU doesn't doe that - the file is no longer compatible.
    I took the sample config file, edited it to fill in
    DB_NAME
    DB_USER
    DB_PASSWORD
    $base
    DOMAIN_CURRENT_SITE
    PATH_CURRENT_SITE
    and I set VHOST 'no'. Yes - now I have a WPMU installation.

    Remaining problem: I can't log in. I am recognized (WP tells me if password is incorrect) but the login screens comes back forever - no way of getting to wp-admin.

    If I can't find a solution within two weeks, that will be the end of WPMU for me.

    CU

    -hlr

  29. andrea_r
    Moderator
    Posted 4 years ago #

    How far back did you upgrade from? What was the version you had before the upgrade?

About this Topic

  • Started 5 years ago by LostHalfwayThere
  • Latest reply from andrea_r