The MU forums have moved to

Single Blog is Blank (21 posts)

  1. mikeboy3
    Posted 15 years ago #

    Hi all,
    I just updated to WPmu 2.7 SVN, and everything was working fine, but all of a sudden, one of the blogs just stopped loading, it just loads a blank page, I cannot even access wp-admin for that blog, it also loads blank. I have tried nearly everything:

    1- Deactivate/Re-activate plugins
    2- Update all plugins
    3- Deleted plugins from server
    4- Deleted all mu-plugin files (including BuddyPress)
    5- Disabled and enabled all themes
    6- Deleted and re-installed the blog's theme
    5- Deleted all WPmu 2.7 files and re-copied them
    6- Deleted WPmu 2.7, replaced with WPmu 2.6.5 files
    7- Deleted 2.6.5 files and replaced with 2.7 SVN
    8- Cleared Cache, restarted server
    9- Reviewed .htaccess file ( )
    10- Deleted wp-config.php and re-installed

    I don't know what else to do, it was working this morning, and then it just stopped, please help!
    I'm now checking the server error logs to see if anything shows up.

    WPmu version:
    SVN 2.7

    Faulty blog:

    Working blog:

    Main site:

    Thanks in advance

  2. mikeboy3
    Posted 15 years ago #

    please, someone, this is urgent

  3. VentureMaker
    Posted 15 years ago #

    Anything in your error log?

  4. andrea_r
    Posted 15 years ago #

    Did you look at that blog's db files?

  5. mikeboy3
    Posted 15 years ago #

    VentureMaker, there is a repeating error,

    andrea_r, what am I looking for there?

  6. VentureMaker
    Posted 15 years ago #

    This means that not enough memory is allocated for php on your server. Raise php memory limits.

  7. mikeboy3
    Posted 15 years ago #

    but that should not be causing this problem, it's another problem, isn't it?

  8. andrea_r
    Posted 15 years ago #

    Are you by any chance running buddypress and sitewide tags?

    And have you disabled the buddypress recent posts widget?

  9. mikeboy3
    Posted 15 years ago #

    Im running only BuddyPress, and the single post widget was not called in that blog. I tried deleting buddypress and all other plugins, to no avail.

    I contacted my hosting's support regarding the DNS wildcard configuration and got this answer:

    "Looking at the DNS for the domain I can see that you do have a wildcard setup properly for this domain. I believe the reason you are currently receiving this blank page is because you do not have a physical hosting environment for the subdomain Once the domain is created correctly in Plesk the subdomain should no longer display the blank page."

    Should I setup a sub-domain for the blog? would that do any difference, I thought WPmu did not need this

  10. andrea_r
    Posted 15 years ago #

    Your host is wrong. tell him you're running WPMU and the wildcard handles all requests for subdomains. None need to exist on the server. MU then looks it up in the db and serves the right files.

    Check the db and look over that blog's tables to see any differences between it and one that works. make sure plugins on that blog have all been disabled.

    What did the error logs say?

  11. mikeboy3
    Posted 15 years ago #

    this is going to sound like slaughter, but I tried something and I pinpointed the error to a single table.

    I went to my phpMyAdmin, and deleted all tables that where not used anymore, like those left behind by several plugins. The non working blog ID is 2. That did not fix the problem, I then noticed that the wp_2_options was different than the wp_26_options (the blog that works) so, I manually tried to correct as much as I could, but that did not fix it either.
    (Let the butchery begin...)

    I went to the wp_blogs table and changed the Blog ID from 2 to 26, then, the address was accessible, of course, with the other blog's posts (ID 26).

    Then I renamed wp_2_posts to wp_26_posts, and all my posts where now being displayed, same for wp_2_comments.

    wp_2_options however, when renamed to wp_26_options loaded the blank page. So I believe the error is a misconfiguration in the BlogID 2 wp_2_options.

    I noticed that wp_2_options goes on for 155 pages of 250 entries each, totaling 38,750 entries in this table, out of which, I can only see copies of one entry:

    19941 0 cron a:5:{i:1230995297;a:1:{s:10:"polls_cron";a:1:{s:32...

    now, what could this be? should I delete all of them manually?

    Edit: there is another entry: doing_cron

  12. andrea_r
    Posted 15 years ago #

    Yeah, delete all the duplicate blog options. Sort by option name and nuke all those cron ones. the look like they are related to a poll plugin. they certainly aren't default ones.

    I've noticed some stuff like that too before, although not that many entries. It's like a hiccup or something.

  13. mikeboy3
    Posted 15 years ago #

    there are many different duplicate entries. A couple of them poll related, I am organizing them by option_ID, that should tell me which where the first ones to be created.

    I already deleted about 25,000 cron and doing_cron entries...

    we will see


    so far, problems with repeated:

  14. mikeboy3
    Posted 15 years ago #


    I will keep posting as they appear, there can't be many more, over 30,000 deleted

  15. mikeboy3
    Posted 15 years ago #

    Well, 38,457 deleted entries later, I have a working blog!
    Thank you very much andrea_r and all who helped!

  16. jamescollins
    Posted 15 years ago #

    Hi mikeboy3,

    Glad to hear you got things working again.

    Out of interest, which version of WPMU were you running before you tried to upgrade to WPMU 2.7 trunk?

    A few months ago I came across a similar problem with duplicate wp_option records, however the problem was fixed in WPMU 2.6.2.

    I'm wondering whether the duplicate records were introduced before the upgrade to 2.7, or as a result of the 2.7 upgrade.


  17. mikeboy3
    Posted 15 years ago #

    jamescollins: I was using 2.6.5 before the upgrade.

    I just checked my wp_2_options again, and its packed with:

    at least 400 of them... It's starting again. There must be some cron process triggered in this blog that just keeps looping!

    here is the option_value for each:

    doing_cron: 0

    Active mu-plugins:
    Buddypress 1.0b
    Incsub Support Module
    Google Analytics for WPmu (Rafik_ga)

    Active Plugins:
    Akismet 2.2.3
    NextGEN Gallery 1.0.2
    Wordpress Video Plugin 0.69
    WP-Polls 2.40
    WP-SWF Object 2.0
    WP125 1.2.1

    How can I check to see which one is causing the conflict?

  18. jamescollins
    Posted 15 years ago #


    What is the value of the autoload columns (yes or no)?

    Are the duplicate wp_2_option records also occurring in the other blogs in your WPMU installation?

    If it happens in all of them, then it's probably a mu-plugin causing it.

    If it is only happening in blog id 2, which plugin(s) are only activated in blog id 2 and not activated in the other blogs?

  19. andrea_r
    Posted 15 years ago #

    Deactivate all the ones in plugins. rename or remove the ones in mu-plugins. Add them back one at a time, wait, check the db.

  20. mikeboy3
    Posted 15 years ago #

    I believe the problem is the wp-super-cache plugin with the blog, but it is only on that blog in particular, the rest seem fine.

    now the entry: wpsupercache_gc_time is part of the repeated ones. Over 1400 by now...

  21. mikeboy3
    Posted 15 years ago #

    jamscollins, autoload value is "yes" in all entries, It does not happen in all of them, just the BlogID 2, I'm trying what andrea_r suggested, testing one by one.

About this Topic

  • Started 15 years ago by mikeboy3
  • Latest reply from mikeboy3