The MU forums have moved to WordPress.org

Problems installing WPMU on Dreamhost (13 posts)

  1. baker1181
    Member
    Posted 13 years ago #

    I have set up WPMU before on a diffrent host, but for the life of me I can't get it to work on Dreamhost. I do not think it is a hosting error, I think I am just plain forgetting something. I am not getting any WPMU related errors when i got the the site, projectinfini.com . Instead I am getting an error not found. So far I have set up my Mysql database, and placed a untouched copy of WPMU in the directory.

    What am I missing?

  2. VentureMaker
    Member
    Posted 13 years ago #

    Well, I see 500 error on projectinfini.com
    Looks like you have some crap in .htaccess file
    Did you try to use custom php settings following DreamHost wiki, or maybe something else?

  3. baker1181
    Member
    Posted 13 years ago #

    No I didn't change any php settings from the host.

    I thought the .htaccess was for host using cpanel and it could be deleted if your host doesn't use cpanel, which dreamhost does not

  4. VentureMaker
    Member
    Posted 13 years ago #

    No, WPMU NEEDS its own .htaccess
    So I think here's your problem - you deleted .htaccess file :)

    Go ahead, take htaccess.dist from WPMU installation package, upload it and rename to .htaccess

    Also, edit the line RewriteBase BASE/
    and make it RewriteBase /

    Be sure to read this: http://en.wikipedia.org/wiki/Htaccess

  5. andrea_r
    Moderator
    Posted 13 years ago #

    "I thought the .htaccess was for host using cpanel and it could be deleted if your host doesn't use cpanel,"

    No, that was for people havign issues *installing* where cpanel keep replacing the htaccess file with a blank one and won;t let the installer create the needed one.

    If all you did was place the WPMU files in the directory and get an error immediately, look for another WP install in the same account, and check and make sure the folder permissions are correct. Like if you unpacked a zip of MU on the server, that might do it...

  6. baker1181
    Member
    Posted 13 years ago #

    Still a problem, I do not have any other copy of WP on teh server. It was a blank server I had just purchased the hosting acccount.

    I editied the .htaccess file as Venture instructed, but still the same issue.

  7. andrea_r
    Moderator
    Posted 13 years ago #

    If you placed the files there and there's already a .htaccess file, remove it via ftp.

    Then try to run the install.

    And please tell me you didn't edit wp-config.php. :)

  8. demonicume
    Member
    Posted 13 years ago #

    LOL dreamhost... Futurehosting FTW... or anyone other than dreamhost.

  9. baker1181
    Member
    Posted 13 years ago #

    @demonicume I use other hosting, but dreamhost at a new years days sale for two years of hosting + domain for 11 bucks. I don't care what hosting company you like, but that is two good of a deal to pass up.

    No there was not an .htaccess file already on the seriver.

    No I treid editing wp-config my first time installing WPMU; I learned my lesson that time around.

  10. baker1181
    Member
    Posted 13 years ago #

    any more ideas

  11. andrea_r
    Moderator
    Posted 13 years ago #

    It's $11 bucks wasted if you can't get your site running on their servers.

  12. Indeedle
    Member
    Posted 13 years ago #

    Hi there,

    Just checking, did you check out the dreamhost wiki?

    I know it can be run as I managed to install and get running Wordpress MU recently on my own dreamhost account (and it's still running).

    Eg: When setting up the domain did you make sure the www option was turned off (as in forcing users to go to the site minus the www?) That caused some issues for me (ended up redirecting in a loop I think)

  13. halles
    Member
    Posted 13 years ago #

    i have installed wpmu (2.6 & 2.7dev) on dreamhost and ran into no problems at all...

    as Indeedle pointed out, wpmu needs to drop the www. before the domain. I never had any troubles with that cause i never use www. anyway.

    Install from scratch... and don't delete any files.... it should work.

About this Topic

  • Started 13 years ago by baker1181
  • Latest reply from halles