The MU forums have moved to WordPress.org

Domain Mapping Help (26 posts)

  1. Guru06
    Member
    Posted 13 years ago #

    Good Morning, hopefully someone is awake to assist me on an issue.

    I searched and searched and saw a reference to my problem but none of the threads had responses. So ill try my luck and start my own thread.

    I am using Donncha Domain Mapping plugin with Cpanel and Enom. I went into enom and added my IP for the A record www, @, and *. Great now doing a traceroute it is pointing to my server! But when I try the url I am stuck on the Cpanel Success Page.

    I have tried deleting the mapped domain from the subdomain (blog1.blogs.com)and adding it again and I get the same result. Am I missing a step? I saw a mention of cpanel in the install file but it seems incomplete. Any suggestions? Thanks

  2. cafespain
    Member
    Posted 13 years ago #

    Is you main domain working?
    Have you added the domain in Cpanel as a parked domain? Or set up your webserver to accept any domains?

  3. Guru06
    Member
    Posted 13 years ago #

    Maybe that was the step I was missing, I had not attempted to park the domain, I assumed I didnt have to and the plugin would handle that. I will try that, but if end users apply domains on their own how will I know which domains to park? There is no notification of a new add on domain.

    Accept any domain? Will that eliminate me having to park domains? Thanks for your suggestions.

  4. Trent
    Member
    Posted 13 years ago #

    I also had to put the main domain at the top of my Virtual Hosts (listed first) for it to work properly as well.

  5. Guru06
    Member
    Posted 13 years ago #

    Trent I havent had a chance to try the other suggetion but thank you for yours. You placed the main domain at the top of your VHost as well parking the domain? Or did you just move the main domain up?

  6. andrea_r
    Moderator
    Posted 13 years ago #

    "I will try that, but if end users apply domains on their own how will I know which domains to park? There is no notification of a new add on domain."

    None of that is covered in the plugin. you'll have to figure out how you want to handle that on your own.

    Is it something you'll be doing every time? A paid upgrade? Something automatically done for everyone?

    All those require a different approach.

  7. Guru06
    Member
    Posted 13 years ago #

    That is definitely something I was thinking about, I believe a paid upgrade is the best option right now.

    I am going to try the suggestions offered in a few, once I warm up. Its bitterly cold right now in Chicago.

  8. Trent
    Member
    Posted 13 years ago #

    @Guro06 I point all my addon domains at my IP address of the server through DNS and only have the virtual host for my main WPMU domain. Since it is pointed at the IP address, WPMU gets the addon domains and then Donncha's plugin directs it to the right blog. If the domain mapping is not setup in the blog settings, it just goes to the main WPMU domain until it is setup on a blog.

    I don't have a vhost for any of my addon domains that WPMU is working with for domain mapping. They just hit my IP address through DNS is all.

    Does that make sense?

  9. Guru06
    Member
    Posted 13 years ago #

    Kinda... The way you describe it, it appears like you have dedicated IP for your site, which may be an "easy" fix.

    Is that the case?

  10. Trent
    Member
    Posted 13 years ago #

    Not a dedicated IP for the site itself, but for the server. This obviously wouldn't work with shared hosting without your own IP, but works on all VPS and dedicated hosting solutions.

  11. cafespain
    Member
    Posted 13 years ago #

    I have something similar. A dedicated IP for the server, but I have a wildcard domain set up in Litespeed, so if any traffic for a domain that isn't setup with alternative details arrives then it gets sent to WPMU.

  12. Guru06
    Member
    Posted 13 years ago #

    Right Right... sorry its been a long day. I keep reading your post to make sure I understand it since you are online right now. One more question what do you mean by "only have the virtual host for my main WPMU domain."

    Thats it for now, I am going to grab a cup of coffee and have at it again and I will report back later tonight to say how it went.

  13. Trent
    Member
    Posted 13 years ago #

    In my apache configuration file. This obviously is not my entry, but you get the idea :)

    <VirtualHost 192.168.0.1>
    DocumentRoot /path/to/my/wpmu/html
    ServerName domain.com
    ServerAlias http://www.domain.com *.domain.com
    </VirtualHost>
  14. h1pst3r88
    Member
    Posted 13 years ago #

    I'm working on this exact project right now... and it's cold in Boston too!

    @Trent:
    When you park the domain, do you "manage the redirection" there via cPanel? Or, do you create a new DNS zone for each parked domain through WHM?

    @Guru06:
    I am in the same situation, thanks for posting. I think I've setup the DNS wildcard correctly via WHM, and am now trying add Trent's httpd.conf edits (it's a little goofy in WHM as I can't edit the virtual host section directly -- I need to add it as an include). Am I correct in thinking that I need to add this entry to the end of the virtual host entries?

    Thanks in advance!

    h1pst3r

  15. h1pst3r88
    Member
    Posted 13 years ago #

    OK -- Got it!

    I had everything right, except the A-record for the domains I wanted to map needed to be changed to the IP that MU was on (it was pointing to the IP I opened my account with not my MU server). I also realized that I had to make that DNS record change through the Business Parallels control panel for my VPS rather than in WHM.

    Once I did that AND used Trent's virtual host code snippet for httpd.conf (which I added as an include through the WHM apache services control panel) it works perfectly.

    Thanks Trent! (many hours spent on this -- and now many many hours saved)

    h1pst3r

  16. Guru06
    Member
    Posted 13 years ago #

    Update: The site in question was not showing up in my httpd.conf file but it was working fine. So I opened up a ticket with my NOC and they couldn't figure it out either so then they opened a ticket with cpanel. Hopefully this will get resolved today, I'm anxious to get it working.

    I just wanted to thank you all for your help

  17. h1pst3r88
    Member
    Posted 13 years ago #

    Not sure if this is good or bad...but I didn't need to add my mapped domains as parked or add-on domains. It worked for me by:

    1. Pointing the domains to my VPS'nameservers.
    2. Making the A-name records for the domains to be mapped point to MU's server (dedicated) IP.
    3. Adding the wildcard DNS and virtual host entry into httpd.conf for the MU server using Trent's entry above modified for my settings.
    4. Creating "sub.mu-server.com" and domain mapping it to "sub.com" using donncha's plugin.

    Now, when I type in "www.sub.com" I get the MU-powered blog which is actually "sub.mu-server.com". However, in the address bar, it actually says, "sub.com".

    Is that OK that it's not "www". How can I get that to resolve to "www" or is that the expected behavior of Donncha's plugin?

    Also, does anyone know definitively the SEO implications of domain mapping in this way with MU? It seems completely straight forward from a DNS perspective, but does anyone have experience from an SEO point of view?

    Thanks!

    h1pst3r

  18. tdjcbe
    Member
    Posted 13 years ago #

    Not sure if this is good or bad...but I didn't need to add my mapped domains as parked or add-on domains.

    Actually you're just doing it manually. Same idea though. All depends on what hosting software you;re running.

  19. h1pst3r88
    Member
    Posted 13 years ago #

    I'm running Business Parallels/WHM/Cpanel -- it seems to me I should have been able to do it in a more automated way, but having it working is relief enough for the moment.

    Thanks,

    h1pst3r

  20. andrea_r
    Moderator
    Posted 13 years ago #

    "Is that OK that it's not "www". How can I get that to resolve to "www" or is that the expected behavior of Donncha's plugin? "

    That's the expected default behaviour across MU.

    As far as SEO goes, makes no difference.

  21. Guru06
    Member
    Posted 13 years ago #

    I am still working on this issue with cpanel, they just upgraded my software to see if that helps. But H1pst3r88 (thats a lot to type LOL) I have a question:

    You say in step 1 "Pointing the domains to my VPS'nameservers"

    You change the nameservers AND use A Records? Isnt the nameservers an unnecessary step? I thought the A record took the place of the nameservers. Its a possibility I am wrong though.

    By the time this is over we will have a pretty good step by step to use :)

  22. h1pst3r88
    Member
    Posted 13 years ago #

    @ Guru06:
    The domains were being transferred and we wanted to use our host's nameservers. I guess I could have left them where they were and changed the A-record there, but I thought that wasn't a best practice -- that it was always better to have my domains pointed to my host's nameservers. Anyway, it would work either way, methinks.

    However, I only needed to change the A-record because it wasn't pointing at my MU server IP, but at another IP I own -- if I only had one dedicated IP I wouldn't have needed to make the A-record change.

    AH -- and one other thing I forgot above, I made the DNS wildcard entry via WHM DNS zone editor.

    @andrea_r:
    Thanks for this answer.

    Good luck, Guru!

    h1pst3r

  23. Guru06
    Member
    Posted 13 years ago #

    Turns out once I got the update from cpanel which fixed the bug where my site wasn't showing up in my vhost all I had to do was add the IP to the A-Records it picked it up just fine. But I did change the IP address of the site so it wasn't using the same one as all the other hosting accounts on the server. Thanks for everyone's help! This community is a great resource.

  24. Guru06
    Member
    Posted 13 years ago #

    I have noticed now, that the account using domain mapping doesn't have the option to upload using the flash uploader, it immediately switches to the older version. The accounts not using domain mapping has the flash uploader. I do remember seeing a thread about that so I will head there.

    I am not complaining just stating what I found, I am ok sacrificing one for the other :)

  25. alunsina
    Member
    Posted 13 years ago #

    i just tried domain mapping and it worked on afraid.org. no messy configuration. afraid.org is a Free DNS Hosting, Dynamic DNS Hosting, Static DNS Hosting, subdomain and domain hosting.

    hope that helps someone.

  26. rahul286
    Member
    Posted 13 years ago #

    @h1pst3r88 & @andrea_r
    Check following topic for having "WWW" prefix solution...
    http://wordpress.org/support/topic/206285?replies=3

About this Topic