The MU forums have moved to WordPress.org

Install issue: "There doesn't seem to be a wp-config.php file." (42 posts)

  1. tza79
    Member
    Posted 13 years ago #

    I am attempted to install a new version of Wordpress MU (I downloaded the latest version from trac) and I am getting an error when I try to install it. I put everything in the root directory and make sure all directories and files had file permissions of "755", but when I go to the index page, I get this message:

    "There doesn't seem to be a wp-config.php file. I need this before we can get started."

    It has a button to create a configuration file, but when I click it, it just refreshed the page and doesn't create anything. Any ideas?

    Thanks!

  2. slambert1971
    Member
    Posted 13 years ago #

    You will need to make sure that the folder where you have MU installed has write permissions so the software can create the wp-config.php file. Without write permissions, it can not do what you want. After the file is created, you can remove the write permissions.

  3. andrea_r
    Moderator
    Posted 13 years ago #

    Are you *sure* you got it from here?
    http://trac.mu.wordpress.org/

    Because that message does not show in MU, only in single user WP.

  4. tza79
    Member
    Posted 13 years ago #

    Slambert1971: I set the folder and all the files to 755. Then I tried to set everything to 777, and I still get the same error. It seems like it wouldn't be a write permissions at that point would it?

    andrea_r: Yeah, I got it from the mu trac. The error message appears in http://trac.mu.wordpress.org/browser/trunk/wp-load.php

  5. andrea_r
    Moderator
    Posted 13 years ago #

    So when you just dump the MU files where you want them, and browse to that directory, what do you see? This message?

    Is the package in a subfolder with another WP in the root?

  6. westpointer
    Member
    Posted 13 years ago #

    "Is the package in a subfolder with another WP in the root? "

    I'm having the same problem as the original poster and my WP mu install is in a subfolder (that has a sub-domain redirect) with a live WP install at root.

    Is there anyway to fix this without killing the root install?

  7. tza79
    Member
    Posted 13 years ago #

    andrea_r: I have a normal version of Wordpress running in my webroot. I created a subdomain for MU and set the root of that subdomain to the folder that I dropped the MU files in. I double checked the permissions and then browsed out to the subdomain - mu.example.com - and that is the error message that I got.

  8. andrea_r
    Moderator
    Posted 13 years ago #

    Then it's reading files from the root WP install.

  9. tza79
    Member
    Posted 13 years ago #

    Is there a way to avoid it reading the files from the root WP install?

    The weird thing is that I tried doing the exact same thing on a different account with a subdomain and it worked. However, that's my test account and I can't use it. Any ideas?

  10. andrea_r
    Moderator
    Posted 13 years ago #

    Eh, not really - there's core WP code in there that travels up one directory.

    usually people with this setup have a different issue with it actually reading the root config file. You could try disabling that long enough to get it installed.

  11. alunsina
    Member
    Posted 13 years ago #

    i think i got into this same problem and it got fixed by copying the wp-config-sample.php and naming it wp-config.

    hope that works for you.

  12. superbison
    Member
    Posted 13 years ago #

    I had the same problem. Installed a second MU in a subfolder.

    I followed Andrea's suggestion:

    "You could try disabling that long enough to get it installed."

    Took out a few files and then put them back all in about 1 minute of down time for the root WPMU.

    note: Multi-site manager plug-in essentially gives you as many MUs as you want. (I wanted separate mu set-ups)

    BTW: Thank you for the solution.

  13. superbison
    Member
    Posted 13 years ago #

    a few minutes later, this subfolder MU install shows successful blog creation but i'm getting page load error:

    Address Not Found!

    hmmm... ;)

  14. antorome
    Member
    Posted 13 years ago #

    I am having the same problem when installing it in a subfolder.

    When installing MU, it doesnt create the wp-config or actually install anything either. I doesnt create the tables into the database.

    May be its a problem when configuring these lines, i havent found detailed documentation on this.

    define('DB_COLLATE', '');
    define('VHOST', 'VHOSTSETTING');
    $base = 'BASE';
    define('DOMAIN_CURRENT_SITE', '' );
    define('PATH_CURRENT_SITE', '' );
    define('BLOGID_CURRENT_SITE', '1' );

    Can anyone say what to put in each one of these lines if for example the installation is made on:

    http://www.xxxxxx.com/blogs/
    and the path is
    /public_html/blogs/

    BTW: The error I get is this one:

    Fatal Error
    If your blog does not display, please contact the owner of this site.

    If you are the owner of this site please check that MySQL is running properly and all tables are error free.

    Database Tables Missing.
    Database tables are missing. This means that MySQL is either not running, WPMU was not installed properly, or someone deleted wp_site. You really should look at your database now.

    What do I do now?
    Read the bug report page. Some of the guidelines there may help you figure out what went wrong.
    If you're still stuck with this message, then check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    If you suspect a problem please report it to the support forums but you must include the information asked for in the WPMU bug reporting guidelines!

    Thanks!

  15. andrea_r
    Moderator
    Posted 13 years ago #

    "May be its a problem when configuring these lines, "

    Do NOT configure wp-config.php. This is the big difference between installing MU and installing WP.

    Actually, if you had just dumped MU in the folder and looked at it, it tells you right on the screen.

  16. TheGarage
    Member
    Posted 13 years ago #

    I was having the same problem as described by the original poster and yes I do have a wp install in the parent directory. After considering the solutions described, I decided to just reinstall into MyDomain.com/blogs/wpmu.

    To reinstall you need to Drop all the MySQL tables, delete .htaccess and wp-config, then navigate to the /wpmu directory to run the install again. If using subdomains simply point all your subdomains to /blogs/wpmu/.

    That solved the problem for me.

  17. MattKern
    Member
    Posted 13 years ago #

    Here was my solution. Keep in mind I did this in my sandbox and have not done extensive testing, but it all looks good initially...

    1. I took my root wp install and copied ALL the files and folders into a temp folder.
    2. I went to my wpmu subdirectory and the install worked as advertised.
    3. After the wpmu install finished, I went back to the root and moved my base wp install from the temp folder back into the root where it belongs.

    So far so good.

    Obviously your root install will be hosed for the few minutes that you are doing the wpmu install.

  18. TonyBrown
    Member
    Posted 13 years ago #

    Installing MU in the root helped resolve this problem for me as well but another error message popped up afterwards which read:

    " Server error!
    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

    If you think this is a server error, please contact the webmaster.

    Error 500
    yep.luxuryhotelwebhosting.com
    Thu Mar 5 21:34:18 2009
    Apache/2.0.54 (Debian GNU/Linux) mod_auth_pgsql/2.0.2b1 mod_ssl/2.0.54 OpenSSL/0.9.7e "

  19. TonyBrown
    Member
    Posted 13 years ago #

    After running the setp I get an installation complete screen which reads:

    "Installation Finished!
    Congratulations!
    Your WordPress µ site has been configured.

    You can log in using the username "admin" and password xxxxxxxxx

    Directory Permissions
    Please remember to reset the permissions on the following directories: "

    Once I click login I get the following message:

    "Server error!
    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

    If you think this is a server error, please contact the webmaster.

    Error 500
    yeptestsite.luxuryhotelwebhosting.com
    Thu Mar 5 21:39:22 2009
    Apache/2.0.54 (Debian GNU/Linux) mod_auth_pgsql/2.0.2b1 mod_ssl/2.0.54 OpenSSL/0.9.7e "

    Anyone got any suggestions? This is becoming a pain in the butt

  20. MrBrian
    Member
    Posted 13 years ago #

    Your shared host is the prob, gotta take it up with them or switch.

  21. casualx
    Member
    Posted 13 years ago #

    I ran into this same problem. I tried to install Wordpress µ in a subdirectory on a shared host, and it kept giving me the "no config.php" error.

    To solve the problem, I did something to what MattKern suggests above. However, rather than moving everything in my home directory, I just temporarily move the wp-config.php file of my root wordpress install. Then I went through the Wordpress µ installation without any problems, and then moved the original wp-config.php back to its original location.

    Everything seems to be working fine for me so far.

  22. infosultan
    Member
    Posted 13 years ago #

    Thank God, I did it. :)

    Here's how I have approached this issue.

    When you have a regular (single) Wordpress installation on the root of your site or the main domain of your hosting account, you will receive the "There doesn't seem to be a wp-config.php file." error message when you try to install Wordpress MU on a sub-domain or add-on domain of your site.

    Here's how to fix it.

    1. Log in to the root directory of your site (where you have also installed the "regular" Wordpress)

    2. There is a wp-config.php file in there. Rename it to something else. Something like thisis-wp-config.php or something else, as long as there is no file of similar name in there.

    3. While still in the root directory of your site, upload the Wordpress MU zip or tar file.

    4. Extract the zipped Wordpress MU package.

    5. There should be a new unzipped wordpress-mu folder in the root directory.

    6a. Rename the unzipped wordpress-mu folder to the subdomain that you want to install it on. Eg. Rename it to blog, etc.

    ***If you are not installing Wordpress MU in an addon domain, skip step 6b below***

    6b. If you are installing Wordpress MU in an addon domain that you are hosting on the same account. For example, mydomain.com is your main domain (and root directory) and you are hosting myothersite.com on it. You should delete the directory for your addon domain.

    For example, if you already have a directory called myothersite.com for that domain appearing in the root directory of the mydomain.com site, you should DELETE the myothersite.com directory.

    Now, rename the wordpress-mu to myothersite.com.

    7. DO NOT change the permissions on myothersite.com (or the subdirectory where you are installing Wordpress MU, if you are not installing it on an addon domain) to 777

    8. CHANGE the permissions on the wp-content folder of myothersite.com to 777.

    9. Type in the myothersite.com or subbdirectory where you installed Wordpress MU on.

    10. The Wordpress MU installation page should load. Fill in the blanks with your MySQL database info and others and finish the installation.

    11. On the next page, copy the temporary password and click on the link to login by typing in "admin" as username and the generated password as your password.

    You should be taken to your Wordpress MU admin area.

    12. Go back to your root directory and rename the config file that you renamed to wp-config.php and save it.

    13. Go to the wp-content folder of your Wordpress MU installation and change the permissions to 755.

    Go blow your trumpet. You have just created a phenomenon! Bravo.

    I hope this helps.

    God Bless! :)

    Sincerely,
    Muhammad

  23. behnt
    Member
    Posted 13 years ago #

    infosultan

    THANK YOU!!!!!!!!!!!!!

    Now to go and see what I can do....

  24. dpd1998
    Member
    Posted 13 years ago #

    Thank You infosultan, it worked for me as well!

  25. niafirman
    Member
    Posted 13 years ago #

    terima kasih - thank you infosultan, it worked for me as well

    question : regarding point 6b.
    is it same effect if you just delete cgi-bin folder only
    rather then delete "the myothersite.com" directory?

  26. infosultan
    Member
    Posted 13 years ago #

    Hi all,

    I am sorry I haven't logged in here for a while.

    I am happy that it worked for some of you as well. :)

    Niafirman, I am not qualified to advise you on what to or not to do with the cgi-bin folder. I am not sure what the effects will be. I also don't know whether this may cause some "damage" to your site or not.

    The steps I have outlined above seem to work fine and without risks. But if you feel confident and knowledgeable working with the cgi-bin folder you could try it or (best option) talk to your technical support representative (first).

    All the best,
    Muhammad.

  27. bestofnj
    Member
    Posted 13 years ago #

    Infosultan,

    First of all thank you for your help with the install. Your directions got me much further along in this process than any I had tried before. I am having a problem now though with my install.

    I get the Install page for every new blog I set up with this message:

    Welcome to WordPress µ. I will help you install this software by asking you a few questions and asking that you change the permissions on a few directories so I can create configuration files and make a directory to store all your uploaded files.

    If you have installed the single-blog version of WordPress before, please note that the WordPress µ installer is different and trying to create the configuration file wp-config.php youself may result in a broken site. It's much easier to use this installer to get the job done.

    See the MU install main page:

    http://bestofnj.com/blogs/

    Do you know what I need to do? Does anyone know? I have searched everywhere and have not found a solution yet.

    Thanks for your help,
    John of BNJ

  28. andrea_r
    Moderator
    Posted 13 years ago #

    Are you on GoDaddy?

  29. bestofnj
    Member
    Posted 13 years ago #

    Andrea,

    Thanks for responding. No, I am on Hostgator. I think everything is set up correctly with them.

    John

  30. itsluy
    Member
    Posted 13 years ago #

    Thanks InfoSultan, your info worked great!

About this Topic