The MU forums have moved to WordPress.org

Installing Wordpress MU locally on my pc? (21 posts)

  1. mayansoldier
    Member
    Posted 15 years ago #

    Hi! I want to install wordpres MU in my pc because i'm about to add budypress to my simple wordpress so i want to change from simple wordpress to wordpress MU and install wordpress. However, budypress themes are a little complicated so i want to develop the theme for my site. I want to do it on my pc as i did with my simple wordpress theme but i'm having trouble installing Wordpress MU. I can install simple wordpress but not wordpress Mu. I'm using XAMPP and installing Wordpress MU 2.7 beta.
    Please help!!!!
    thanks a lot for the help people...

    (PD: sorry if i am a little confusing...)

  2. andrea_r
    Moderator
    Posted 15 years ago #

    Change the hosts file on your computer to make localdomain something like localdomain.wpmu. That can be anything as long as it's something.something.

    Then install it like usual.

  3. mayansoldier
    Member
    Posted 15 years ago #

    Oh thanks for the help but I dont really understand it since im a little nobish on this! sorry!
    Could you be a little more specific?

    EDIT: Ok I found some tutorials with master google about how to edit my hosts file but what ip should i write?

  4. sewpafly
    Member
    Posted 15 years ago #

    127.0.0.1 is the loopback address (means it's the computer that you're on).

  5. mayansoldier
    Member
    Posted 15 years ago #

    thanks a lot! I hope it works but i trust you since i saw many of your posts before
    Thanks!!!

  6. andrea_r
    Moderator
    Posted 15 years ago #

    Well, it gives the same advice on the install screen. :)

  7. mayansoldier
    Member
    Posted 15 years ago #

    haha
    awww it didn't work!
    could someone help me "more specifically"?
    I already added 127.0.0.1 wordpress.wpmu. to my hosts file but when i go to wordpress.wpmu. it gets me a not found page.
    Please help!!!

  8. andrea_r
    Moderator
    Posted 15 years ago #

    Remove the end . after wordpress.wpmu

    (end of sentence)

  9. lemonad
    Member
    Posted 15 years ago #

    WP's setcookie function is a little finicky but it seems like one can set COOKIE_DOMAIN to '' in wp-config.php to be able to use hostnames without dots (like http://myintranet/):

    define( "COOKIE_DOMAIN", '');

    I'm not sure if there are any downsides to making this change though. Anyone?

  10. alunsina
    Member
    Posted 15 years ago #

    @mayansoldier
    there is a step by step instruction (really, really step by step for noobs like us ;) ) on this thread:

    http://mu.wordpress.org/forums/topic.php?id=10479

    hope that helps.

  11. mayansoldier
    Member
    Posted 15 years ago #

    Thanks for all your replies.
    The guide alusina gave me seems pretty good. I will try it and tell you if it worked

  12. mayansoldier
    Member
    Posted 15 years ago #

    mmm... and don't know if i did something wrong but this is the third time i have followed step by step the guide but still i cannot install it. However, Thanks for all the help. I don't want to become too annoying so i will develope my theme on an dummy wordpressmu at my free hosting service.
    However, i will be checking this thread if someone has some idea that can help me
    Thanks for all the help people anyway!!!

  13. mayansoldier
    Member
    Posted 15 years ago #

    Sorry for the triple posts but i want to tell you that i found the solution. I don't know why but my real hosts file didn't exist. I was editing a file named hosts.msn. I found this http://www.hostingformula.info/step-by-step-install-wordpress-multi-user-in-localhost-adding-host/ tutorial and found that my hosts file was wrong! so i created it and my localdomain.wpmu adress is working now. I wonder i can install wpmu!
    Thanks!

  14. mayansoldier
    Member
    Posted 15 years ago #

    Well i couldn't get wp mu to work but if anyone has the same problem try this guide http://www.hostingformula.info/step-by-step-install-wordpress-multi-user-in-localhost-make-permalink-work/ . It is really step by step althought it didn't work for me. I don't know, what am i doing wrong?!

  15. alunsina
    Member
    Posted 15 years ago #

    what do you mean you cant get it to work? were you able to install it though with errors? or not installed at all? what step are you stucked on?

    :)

  16. mayansoldier
    Member
    Posted 15 years ago #

    I can't install it at all.
    I can register my own domain at the hosts file but it keeps getting me "could not establish connection to database" error when i go to my wordpress folder!
    sorry and thanks XD

  17. alunsina
    Member
    Posted 15 years ago #

    what xampp version are you using? when i get that error, it means i forgot to start mysql: mysql_start.bat. even if i'm using the full version i do this manually just to be sure.

    hope that helps.

  18. mayansoldier
    Member
    Posted 15 years ago #

    Thanks!
    I'm using xamp lite.
    What I found curios is that I can run Simple wordpress and i make sure mysql is started on the xamp control...
    I will try with full version to see what happens...

  19. ssvijay
    Member
    Posted 15 years ago #

    Thank you very much Mayansoldier. I also had same problem like you. i also fixed that problem given your link http://www.hostingformula.info/step-by-step-install-wordpress-multi-user-in-localhost-adding-host/

    thanks. thank you very much.
    wish u all the best.

  20. ssvijay
    Member
    Posted 15 years ago #

    And yes Mayansoldier. it is also completly working on full version of xampp. i tried on full verson.
    thanks.

  21. amskape
    Member
    Posted 14 years ago #

    Hello Sir,

    I Install Wordpress MU as You Directed as in the Readme. Installation is Success,But When I create a user Blog eg: it's name is firstone then the url is : http://localhost.localdomain/wpmu/firstone/ But when I visit this page I got a 404 page Not Found Error. How it can Avoid? As an Experience I copy all files in /wpmu installation Folder to this /wpmu/firstone folder. Then I got the page, but When I click some links like Comment , I got another page Not Found 404 Error.

    Sir , please Give a Work arounf for it .... I know Copy the Content to
    new folder is not a Solution..... I am working in Red Hat Linux Fedora
    Core 8 PC .... ok I am waiting your Reply... Kindly give a Solution as Early as Possible.....
    You can contact me : anes.pa@amskape.com

    With Great Regards
    Anes P.A

About this Topic

  • Started 15 years ago by mayansoldier
  • Latest reply from amskape