The MU forums have moved to WordPress.org

What themes work with MU now? (34 posts)

  1. rlwpub
    Member
    Posted 16 years ago #

    What themes actually work with MU now?

  2. gwagenknecht
    Member
    Posted 16 years ago #

  3. drmike
    Member
    Posted 16 years ago #

    I've thrown up a list of the one's I've brought into my setup here. These include the ones found in the theme pack. Some do require some editing though. (ie the addition of widgets) I haven't found any though in that list that did not work though with MU.

  4. andrea_r
    Moderator
    Posted 16 years ago #

    Hey, drmike - there's a few there by one designer I'd like to have. Didn't get around to widgetizing them myself. Care to share? Please? :)

  5. drmike
    Member
    Posted 16 years ago #

    Which ones? I'm guess I can release them since they're GPL'ed.

    Just added the three themes created by Michael Martine. Those had to be widgetized as well.

    I've got an alpha of the Aqua theme from phpBB that I'm planning on using for my site that I hope to release sometime as well.

  6. andrea_r
    Moderator
    Posted 16 years ago #

    Girl in Green and Reflections (it's pink). 99% of my users are women, and a small percentage are teens, so they'll love this.

  7. drmike
    Member
    Posted 16 years ago #

    Reflections was a *cough*. I'll post them later on today. :)

  8. drmike
    Member
    Posted 16 years ago #

    Widgetized WordPress Themes

    Hope this helps,
    -drmike

  9. andrea_r
    Moderator
    Posted 16 years ago #

    Thank you. :)

  10. Yoshi_S
    Member
    Posted 16 years ago #

    Hello guys,

    I have updatet my Blog-Service to nightly build 2006-06-04.
    Now a couple of themes are not working correctly ano more, I have got the package who is postet here in the forum.
    My customers often use the "black-letterhead" theme, but this doesn't work any more. All I get when I activate it, is a white page without any HTML-Code inside the source.
    Can anybody help me, get this template work again?
    Thank you in advance :)

  11. Yoshi_S
    Member
    Posted 16 years ago #

    Please an answer, I don't think that I am the only person with this problem :(

  12. macosx
    Member
    Posted 16 years ago #

    call me a newbie (I admit 2 B 1 ;), but please help me understand what I am doing wrong:

    I download the themespack 0.1, un-zipped it and put the first theme's folder "anthurium(tp)" into wp-content/themes/ set owner & permission recursively for the directory.

    I went to my blogs themes admin page http://blog.co.ro/wp-admin/themes.php

    ...but all I see there is:

    "Anthurium Mix MU Template is missing."

    No matter what theme I try or where I download them from, always the same problem.

    I am using the latest nighty (wpmu-2006-07-21).

    Thank you!

  13. kahless
    Member
    Posted 16 years ago #

    That particular theme is one of a handful in the pack that are broken. Did you try any of the other say banana-smoothie, batavia, blueberry-boat, etc.? These all work for me and I got them from the theme pack. I just gave up on the broken ones, although I think you would probably just have to change a path instance that is trying to call the template to get them to work.

  14. macosx
    Member
    Posted 16 years ago #

    Hello kahless,

    thanks for your input.

    All themes show the same behaviour:

    "Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description
    Anthurium Mix MU Template is missing.
    Banana SmoothieMU Template is missing.
    Batavia MU Template is missing.
    Blueberry BoatMU Template is missing."

    Now where can I change a the path instance that is trying to call the template? In wp-admin/themes.php?

    thank you.

  15. kahless
    Member
    Posted 16 years ago #

    Something is not right with your setup. You shouldn't have to the path instance globally. Do any themes you download from the WordPress theme site work? Every theme I have downloaded from the theme site has worked as expected.

  16. drmike
    Member
    Posted 16 years ago #

    Actually, no. Those themes are bugging. We've discussed it before already here in this forum along with the solution.

  17. kahless
    Member
    Posted 16 years ago #

    No Mike, only a handful of the themes were buggy. They were

    Anthurium Mix MU
    Dark Maple MU
    Juicy
    Tropical Breeze
    Zen MinimalistMU

    No one reported problems with

    Banana SmoothieMU
    Batavia MU
    Blueberry BoatMU

    that I ever saw. That is why I think there is something else going on for macosx.

  18. andrea_r
    Moderator
    Posted 16 years ago #

    Most of those where really old themes that I converted. They may have something at the top of the stylesheet, an extra line perhaps, that could be taken out. In older version, you could declare a theme to use and a different stylesheet (I think), so I bet my money on that's what's doing it.

  19. andrea_r
    Moderator
    Posted 16 years ago #

    Think I found it. In any of those themes, look at the style.css. If the first line says something like "Template: tropical-breeze", take it out. Newer version of WP & MU expect the first line to be "Theme Name" (after the comment of course).

    Dunno why they all work fine for me, including those users on Macs. But at least it's a dead-easy fix.

  20. drmike
    Member
    Posted 16 years ago #

    That was how pre-1.5 (I think) WordPress themes worked. They needed that in there. (That's what was suggested in the other thread as well.)

    Not sure why these other themes are showing that now at this late date. I remmeber that it was five that showed the error though.

  21. macosx
    Member
    Posted 16 years ago #

    Hi guys,

    andrea, I tried what you said. deleting the template line from the comment of the anthurium(tp) style-sheet (does wp actually parse the comments?). no changes. banana-smoothie(tp) batavia(tp) and the others do not even contain a line w. template.

    There are 3 themes that come w. the installation: default, classic and home.
    All I see is "default". That answers also your question, kahless: apparently NO theme works for me, except "default".

    I see:
    Current Theme: Default
    Available Themes: <empty>
    Broken Themes:
    Anthurium Mix MU Template is missing.
    Banana SmoothieMU Template is missing.
    Batavia MU Template is missing.
    Blueberry BoatMU Template is missing.

    I reckon, the available section should contain home and classic? That would confirm, that there is something wrong w. the entire setup on my box as you suspect, kahless.

    The server by the way, is a Debian Sarge. MacOSX is "only" my client OS and my working environment since like 20 years ('Evangelist' :D )

    Thanks for your input!

  22. kahless
    Member
    Posted 16 years ago #

    Other than a wipe and reinstall, I don't know what to suggest. I assume you have looked at InstallingWordPressMU and DebuggingWpmu (seem to be down or VERY slow at the moment). Got ya beat. I'm going on 22 years with Apple.

  23. drmike
    Member
    Posted 16 years ago #

    I've got those 4 themes working on my site. Would you like to just have a zip of them?

  24. andrea_r
    Moderator
    Posted 16 years ago #

    Nobody loves the commodore 64 anymore do they? :D

  25. mickemus
    Member
    Posted 16 years ago #

    Game & Watch! Donkey Kong!! Still going strong!

  26. drmike
    Member
    Posted 16 years ago #

    huh?

  27. donncha
    Key Master
    Posted 16 years ago #

    andrea_r - I do :)

  28. drmike
    Member
    Posted 16 years ago #

    I'm still trying to figure out what this has to do with MU themes.

  29. andrea_r
    Moderator
    Posted 16 years ago #

    It doesn't but kahless and macosx started listing their system cred. ;)

  30. Misera
    Member
    Posted 16 years ago #

    Tried taking out the first line of these.. (anthurium works perfectly fine for me):
    Dark Maple MU
    Juicy
    Tropical Breeze
    Zen MinimalistMU

    It removed them from the broken list.. but they don't appear on the list of themes. Any idea why?

About this Topic