The MU forums have moved to WordPress.org

Multisite Plugin Makes Blog Blank (17 posts)

  1. thelaw
    Member
    Posted 11 years ago #

    I decided to create a thread for this problem. I installed Multi-Site manager. Put in the domain in the back end and BOOM. I got nailed with the below message on my home page:

    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.

    Removing the plugin doesn't remedy the problem. Removing the parked domains still results in the same problem. This is bad... The instructions I had were here:

    http://www.brilliances.com/multisite-manager-with-wordpress-mu/

    After further review and deleting all references of the second site I cloned in cpanel, which you have to do, I still couldn't get the home page to show up properly. To do this you will see most of the entries in two places: (1) The sites table which will have your new site, and (2) Several tables which have the latest entry for a new blog with the last/highest number entered.

    I had to reupload the wp-config.php and that did the trick for anyone wondering. MAKE SURE YOU BACK UP THIS FILE as well as your site before installing the Multisite plugin.

    I haven't tried to reinstall the Multisite plugin until someone can give me an explanation as to what happened and why I had the bad experience above. Hopefully this topic will help us install the plugin and provide an answer should you have a heart attack from the above problem.

  2. thelaw
    Member
    Posted 11 years ago #

    Is anyone using multisite manager successfully? I can't get it to work properly at all. The instructions here http://www.jerseyconnect.net/development/multisite-faq/ aren't very clear, just set up a new site and go. I'm not sure what seems to be the problem since my domains all point to the same server.

  3. thelaw
    Member
    Posted 11 years ago #

    I've just looked at the other multi-site plugin, which I think is a multi-domain manager. That will NOT work since it requires that WPMU is set up for subdomains, NOT subdirectories. That rules out my site, which uses subdirectories.

    Does ANYONE here use a multi-site capability successfully? Unfortunately I think I'm left needing to do a separate install on my other external sites and linking them in to use the current table, e.g. install on site2.com and put in the wp-config to use datbase site1_wpdb as its install. I wonder if this can work and is the only workaround left unless someone can explain how to get multisite manager to work properly.

  4. andrea_r
    Moderator
    Posted 11 years ago #

    Did you ask the plugin developer?

    Alternatively, if you want to muck aroudn in the database, there's manual instructions here:
    http://bui4ever.com/2007/06/wordpress_mu_with_domain_mapping/

  5. thelaw
    Member
    Posted 11 years ago #

    Thanks Andrea -

    The domain mapping for that plugin isn't going to work - it's for subdomains only.

    I finally got the multisite plugin to allow blogs to appear correctly. There are a couple of issues I should point out that with WPMU 2.7, as opposed to the notes which say to comment out the "current_site" variable, you need to put in the current site (domain.com) and the path (/ if in root) in order for your blog to work. Otherwise you will get the wpmu not found error every time.

    The remaining issue I have at present is that I'm getting the "no blog" error message at the domain that I'm trying to use. I added the new site instead of new blog and that is what happened.

    e.g. I go to http://www.domain2.com and it redirects me to http://www.maindomain.com with an error message that wpmu cannot find a blog installed. I thought with domain parking it would stay on http://www.domain2.com and show a blog associated with it.

    So at least we are getting somewhere but not yet to the promised land...

  6. thelaw
    Member
    Posted 11 years ago #

    Has anyone got this to work properly? I'd pay someone to get this to be set up properly since it seems that getting the multisite plugin to work is something like a black art. I wish this was simpler. I've tried everything and still don't know why creating a new site gives me the error message: "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance." There is just no love with multisite at all.

  7. mrarrow
    Member
    Posted 11 years ago #

    I have been happily using Multi-site Manager (007) on Wordpress MU 2.6.3 (and as far back as WPMU 1.3).

    I read your comments with alarm as I was thinking of upgrading to WPMU 2.7. I won't yet until issues like these have been resolved (or I can reclaim my development server first!).

    However, from poking about in the MySQL tables (using PHPMyAdmin for instance), the plugin itself simply creates a new site (with a new site ID) and a default blog for that site. Once its done that, all the web requests and subsequent routing is handled by Wordpress and the DNS setup rather than the plugin itself.

    So from experience, if I were you I would check out the wp_sites table and make sure that a new, unique site id number has been created for that site. Then go to the approriate entry in the wp_blogs table and make sure that the default blog that got created when you created the new site is also assigned to that SAME unique site ID.

    This mismatch of site id's to blogs caused me some issues at the start.

    Also, make sure that when you create the site using the plugin, you complete the fields as per the URL you have already mentioned. I've missed some of these before!

  8. thelaw
    Member
    Posted 11 years ago #

    Thanks for the reply! I've tried everything and I think that everything is set up correctly. I've noticed that the sites do display with a unique ID and in the database, all would seem to be fine.

    I'm wondering if the problem has to do with the server setup. I've got domainmain.com and domain1.com both pointed at the same server with identical nameservers. I then used CPanel's mapping to add an entry for domain1.com without any redirect, which is an option. From my understanding, that should be enough to trigger wordpress to kick in when domain1.com is called as it is "mapped" - but it's not working.

    The only other item I can think of is that I had to remove the depracate www line from wordpress since it's clear that there are some significant benefits, at least for my site, by keeping the www in there. I'm not sure if that could cause some conflict.

    Thanks for the post - I do appreciate the input and I'm going to keep testing this with a development site that I have running and we'll see if we can finally get it to work.

  9. mrarrow
    Member
    Posted 11 years ago #

    Yes, you need to point all domains to the same nameserver (in my case the VPS).

    Then park these domains (in my case using WHM) on to the top level domain/account that's already linked up to Wordpress MU.

    Then create the new site within WPMU with the appropriate domain name.

    Then I go into cPanel and set up a 'Permanent, wildcard' redirect (selecting 'with or without www') for any domain which you've already parked but which you wish to forward through to an existing site.

    As I say, the Multisite plugin only seems to be responsible for the initial creation of the new site and top blog, the rest of the routing is done via DNS and Wordpress itself.

    Unless 2.7 does something different now (perhaps Donncha is making his Domain Mapping plugin more integrated thus affecting the Multisite plugin). For instance I noticed that the new code that needs to be added to wp-config.php also refers to "site_id=1". Have you tried commenting out this line as well as the reference to current domain?

    Multisite Manager uses different site id's (unlike the Domain Mapping Plugin) so is this line also confusing the mapping process?

    Also its to be noted that I'm using sub domains not sub directories.

    Let me know how you get on!

  10. thelaw
    Member
    Posted 11 years ago #

    Great post! I think I may have figured out where I went wrong...

    1) I'm using subdirectories, not subdomains. With all the people going this route, perhaps there aren't so many SEO benefits... as long as this works! Perhaps multi-site will only work for subdomain installs?

    2) WHM... perhaps this is the problem - I was parking the domains in the primarily domain area in cpanel. I can try parking them using WHM instead but it shouldn't make a difference from what I know.

    3) What do you do in CPanel for your primary domain? I'm thinking if you've parked the domain in WHM, then it should appear as already parked in cpanel. Perhaps you can tell me where you're navigating and what you're changing.

    Regarding the config, I commented out the
    // define('DOMAIN_CURRENT_SITE', 'current_site_domain' )
    but that didn't seem to make a difference.

    Many thanks... perhaps we are getting somewhere!

  11. mrarrow
    Member
    Posted 11 years ago #

    Well I know that subdomains are generally preferred over subdirectories for a variety of functional and configurable reasons. After my sixth (count them, 6!) installs, I finally settled on subdomains!

    I always use a mixture of WHM and cPanel, mainly coz I often need to configure DNS entries for different domains (MX, CNAME etc) which I can only do in WHM. However, I find it easier to do domain redirects and to set up email addresses for instance in cPanel.

    Incidentally I've got several user accounts that I created in WHM (one for our WPMU install, one for our toolkits etc) so some configuration is easier to do by logging onto the relevant cPanel account rather than trying to do it in WHM.

    Re commenting out wp-config.php, the other line that I thought may be confusing things is:

    define('BLOGID_CURRENT_SITE', '1');

    If this is a fixed site id of '1', then how does this interact when other site id's are also being used? Donncha's Domain Mapping Plugin for instance hangs every blog (and therefore every domain and sub domain, regardless) off site ID 1. Where as the Multisite Manager creates incremental site ID's for each new top level domain, with those sub domain blogs still being unique blog id's but using the top level site id that its related to.

    So maybe this line is also causing grief.

    Hey its great, with you onboard, I don't need to liberate my development server after all ;-)

  12. easywizards
    Member
    Posted 11 years ago #

    Hi everyone,

    I have WPMU installed at http://easywizards.com hosted on MediaTemple's Grid Service.

    I am using the Multisite Manager mu-plugin in WPMU.

    I have added a second domain easyblogwizards.com mapped to the same directory as easywizards.com using a symbolic link, as per instructions on MediaTemple.

    Have also added a * wildcard to my DNS for the domains, but not yet sure if MT's GS HTTPD is set up to handle wildcards by default. I have asked them, waiting for reply. They already said I cannot edit httpd.conf myself with a GS account.

    I created a new site inside WPMU for the easyblogwizards.com domain and followed the instructions over at brilliances.com for Multisite Manager setup.

    http://easyblogwizards.com is still giving the dreaded white screen.

    I'm not sure about commenting out or modifying these lines in wp-config.php:

    define('DOMAIN_CURRENT_SITE', 'easywizards.com'); // don't include "http://www." at the beginning

    define('BLOGID_CURRENT_SITE', '1');

    As mrarrow points out Multisite Manager creates incremental site IDs for each new TLD and new blog ID's for each new blog.

    I have tried it with them commented out and included.

    Given that Multisite Manager won't work with subfolders, I wonder if that's my problem or not.

    I cannot remember now whether I set up my WPMU as subdomains or subfolders, as I installed it back in November. How do I check this?

    Any other things I should think about re. this white screen problem on the second blog?

    Really wanting to get this going, not sure how to proceed with troubleshooting at this point.

    Answering the subdomain or subfolder question probably a good place to continue from...

    Thanks!

  13. andrea_r
    Moderator
    Posted 11 years ago #

    If the blog you made is test.easyblogwizards.com then it's a subdomain install. As long as that's what was created when you went to Site Admin-> Blogs and Add A New blog and that's what it gave you...

    Take out the MSM plugin for now. Get the site working, because if the sub-blog has a WSOD that means an error. That also means you have to go turn on error logging and read 'em. :)

    I'm also thinking that you don't have to set up that symlink. You aren't getting any actual folders, so on MT you have to do something different. (I need to remember hang on...)

    Edit: and your wildcard subdomains aren't set up right. Yes, they can do that on MT.

  14. easywizards
    Member
    Posted 11 years ago #

    Thanks Andrea!

    on the sub-domain issue...

    I created test.easywizards.com to try to find out if I had subdomains or subfolders.

    Note that it is not test.easyblogwizards.com - I set up test.easywizards.com as I wanted to get a subdomain blog working on the main easywizards.com to start with.

    I confirmed that test.easywizards.com is what MU created and that's what the blogs screen in MU shows.

    Therefore I gather from what you're saying that's a subdomain install.

    Good, I made a sensible choice when I installed in November.

    I added a specific A record for test.easywizards.com because I wasn't sure if the * wildcard on MT was active in their httpd.conf or not.

    Still getting the WSOD on http://test.easywizards.com

    WPMU shows wp-content/blogs.dir/4/files as the upload path for the test.easywizards.com blog, as its the 4th blog I have added.

    Suggests to me that WPMU should know where to look for the content for test.easywizards.com when it gets a httpd request for that subdomain.

    Hence I don't know yet why it is WSOD'ing.

    A n00b question, where do I turn on error logging?

    Is that something I need to do with php.ini or is there internal eror logging in WPMU that I haven't spotted yet?

    Now for the multi-domain issue...

    I have removed the MSM plug-in for now as you suggest.

    The symlink for the easyblogwizards.com is to map it to easywizards.com

    I think that is required so MT's httpd knows to send requests to the easywizards.com directory?

    Without that, I think any httpd requests to easyblogwizards.com will fail with no available directory structure to support them.

    By having the symlink for that domain, httpd requests on the domain should hit the WPMU install on easywizards.com which should then handle them accordingly.

    The fact it is WSOD for http://easyblogwizards.com suggests it is getting to the WPMU index.php and failing because the WPMU doesn't know what to do with that domain.

    Now I've taken out MSM its definitely not going to work?

  15. andrea_r
    Moderator
    Posted 11 years ago #

    "I wasn't sure if the * wildcard on MT was active in their httpd.conf or not."

    It's not. You can always test this by typing in anything.yourdomain.com (in other words, a blog that doesn't exist). If it redirects to the main MU page, it works.

    Turn on error logging in your MT control panel. :) I think it's off by default.

    Yes, you will need to let MT know where to point your second domain, but I'm suggesting to drop & forget that part right now, as you have other issues to fix first. Can't fix 'em all at once.

  16. easywizards
    Member
    Posted 11 years ago #

    As I have removed the Multisite Manager mu-plugin, my issue is no longer relevant to this thread.

    Just for closure before I jump to another thread or make a new one, http://blah.easywizards.com redirects to http://easywizards.com/Object so the * wildcard looks to be working.

    http://test.easywizards.com being an active subdomain blog with the WSOD, I have enabled error logging as per Andrea's suggestion and can report that:

    [Mon Mar 02 18:20:53 2009] [error] [client 124.170.112.156] WordPress database error Table 'db56166_wpmu.wp_user_activity' doesn't exist for query SELECT COUNT(*) FROM wp_user_activity WHERE user_ID = '1' made by require, require_once, require_once, require_once, do_action, call_user_func_array, user_activity_init, user_activity_global_db_sync
    [Mon Mar 02 18:20:53 2009] [error] [client 124.170.112.156] WordPress database error Table 'db56166_wpmu.wp_user_activity' doesn't exist for query UPDATE wp_user_activity SET last_active = '1236046853' WHERE user_ID = '1' made by require, require_once, require_once, require_once, do_action, call_user_func_array, user_activity_init, user_activity_global_db_sync

    Which suggests a missing table in my install. I checked with PHPMyAdmin and indeed I do not have that table wp_user_activity in my database.

    Will update with a new thread link when I find an appropriate thread to continue my quest...

  17. andrea_r
    Moderator
    Posted 11 years ago #

    See: http://codex.wordpress.org/WPMU_Database_Description

    wp_user_activity is a table generated by the User Activity plugin. You may want to remove it for a bit. (The plugin, that is since obviously the table's not there and it's looking for it.)

    To start a new thread:
    - go to the main page of the forum
    - scroll down to the bottom
    - pick a sub-topic (Troubleshooting is a good one) and click the heading
    - scroll down to the bottom of that page
    - see the new post box.

About this Topic