The MU forums have moved to WordPress.org

Problem with Dashboard in 2.7 (3 posts)

  1. slambert1971
    Member
    Posted 13 years ago #

    Ok, this is a weird one, and I have searched here to see the problem has occurred before, but there were never any answers that I could find. Running a fresh install of Mu 2.7 and everything works great. I even have several files in mu-plugins that don't cause problems.

    Then, I copied over all of the plugins I used on an older version 2.5.1 of Mu and all of a sudden the dashboard button on the side nav broke - as it had the following URL:

    http://domain.com/mu/wp-admin/admin.php?page=index.php

    I have about 30 plugins that we use and I removed them all and it worked. I slowly added them back to find the problem, and can you believe the problem was caused by a file named "index.php" in the plugins folder? It's basically the index.php file from stand alone wordpress, just the "silence is golden" thing. Remove that and the link works fine. Put it in and the link breaks.

    Not sure if this is a bug in MU, and I see that file is not included in the 2.7 zip file. However, if you migrate an older version of MU, make sure you DO NOT have this file in your plugins folder, or you will spend 2 hours trying to figure out what broke that darn dashboard link.

  2. techlover
    Member
    Posted 13 years ago #

  3. Driftless1
    Member
    Posted 13 years ago #

    Yup - that seems to help... however, I just installed WPMU three days ago (2.7.1) and its still has the index.php files in the directories (despite the trac file saying they're gone...)

    Also - people might be interested to know that you need to clear the cache of your browser after delet'n 'em.

    Just an update.

About this Topic

  • Started 13 years ago by slambert1971
  • Latest reply from Driftless1