The MU forums have moved to WordPress.org

Do you know what the friggin' problem with BuddyPress is? (23 posts)

  1. billdennis5
    Member
    Posted 13 years ago #

    During the course of trying to troubleshoot two problems with my BuddyPress installation (one problem an annoyance, the other a SERIOUS problem that has screwed up my home site), I posted twice to the BuddyForum.

    And now, there's not the slightest evidence anywhere that either post ever existed. And I gave up even trying to post a new topic. All I got was a message telling that that topic never existed.

    It's one thing to have a problem operating open-source, Beta version software. I know that support on the forum is voluntary.

    But I don't think that's it's too much to ask that the stinking forum itself not be so buggy it cannot be used. It's YOUR OWN forum platform!

    Oh, and I'd be more than happy to report a bug, since apparently that's the response to to ALMOST EVERYONE seeks help on the forum, but when I do, I am told that I have to log into the trac first, and there's no friggin' button to click to sign up.

    This should not be this hard.

    GRRR!

  2. andrewbillits
    Member
    Posted 13 years ago #

    Hiya,

    Try using your forums user account to login to Trac.

    Thanks,
    Andrew

  3. andrea_r
    Moderator
    Posted 13 years ago #

    Time for a break, Bill. :)

  4. Trent
    Member
    Posted 13 years ago #

    There is some serious "cache" and lag problem in the buddypress forums and it seems like the same exists here when you look at the duplicate posts. Strange.

  5. burtadsit
    Member
    Posted 13 years ago #

    @billdennis5 I looked at your profile in the bp forums and don't see any topics started by you or replies to any topics. It seems the wp forums are having a bad day across the board.

    I responded in this forum about your bp widget problems.
    http://mu.wordpress.org/forums/topic.php?id=10993

    The people who are helping out over in the bp forums do the best we can guy. bp didn't even exist 6 months ago and it's only weeks out of alpha. If there are any buddypress experts, we're growing them at this very moment.

    One of the problems we have helping out with bp is that each of us needs to be a linux, apache, php, buddypress, wpmu and bbpress guru.

    The problems encountered in the bp forums can come from any and all those areas. It's a challenge and a definite learning experience.

    I've had days like yours.

  6. burtadsit
    Member
    Posted 13 years ago #

    Here's a good example of what I'm talking about.

    http://buddypress.org/forums/topic.php?id=938

    Karl reported this problem about a week ago. Does this problem relate to bp, yes. Does this problem relate to bbpress, after questioning, no. Does this problem relate to wpmu, maybe. Does this problem relate to internationalization of applications, yes. Does this problem have something to do with php, maybe.

    Do fishbowl81, trentadams or I know how to solve his problem of the top of our heads, no. We've all spent time thinking and plowing through code trying to determine where the problem is.

    We're getting closer to a solution. Does any of the effort the three of us put into solving Karl's problem pay the rent or put groceries on the table, no.

    If I jump in and start helping somebody I know I'm not going to let up until the problem is solved. It may not be me that solves it but I'll add what I know to the effort.

  7. andrea_r
    Moderator
    Posted 13 years ago #

    And the size and scope of BP makes it a lot of code to wade thru.

    Burt, these two posts were almost as awesome as that time you sang me that song.

  8. burtadsit
    Member
    Posted 13 years ago #

    Mornin' andrea_r! Took two whole days off. Damn andrea, can't you keep a secret. Shhh. If my girlfriend finds out about that singing to you thing, she'll cut off something important. Like the cord to my laptop power brick. Try to be more circumspect. Like me.

  9. andrea_r
    Moderator
    Posted 13 years ago #

    It'll be our secret, babe.

  10. billdennis5
    Member
    Posted 13 years ago #

    Stop flirting with andrea_r and get back to work.

    ;-)

    Seriously, thanks for BuddyPress. I appreciate all the hard work. But please fix the forum issues is you can.

    I have the problem with the blogs plugin fixed. But I still cannot upload an avatar for groups. As far as I know, no member has been able to upload an avatar to their profile.

  11. anointed
    Member
    Posted 13 years ago #

    I have no problems uploading group or member avatars
    example: (serious work in progress, just screwing around so far)
    http://anointed.net/groups/support

  12. billdennis5
    Member
    Posted 13 years ago #

    The message I'm getting tells me I need to check permissions on the upload folder for groups. I cannot find this upload directory.

  13. Trent
    Member
    Posted 13 years ago #

    It is the same as anything else for buddypress content, the upload directory for the main blog.

    wp-content/blogs.dir/1/ ......

    Trent

  14. billdennis5
    Member
    Posted 13 years ago #

    The messsage is "Upload Failed! Please check the permissions on the group avatar upload directory."

    The permissions on "blog.dir/1/" is 755. I can upload images just fine to this director.

    I think this is a bug, and if the BuddyPress forum and Trac worked, I report it. Sorry if I sound snarky, but it's the truth.

  15. burtadsit
    Member
    Posted 13 years ago #

    The group avatar upload mechanism had a bug that was fixed this last friday. rev 1011.

    From SVN:

    "Fixing avatar editing for users where the correct upload directory was not being set on avatar editing. Fixes #425. Thanks to geordee for spotting this one. "

    Try the most recent trunk billdennis5. The bp forums have been having a problem lately. Like now. I can't seem to login. Maybe it's just me. :)

  16. burtadsit
    Member
    Posted 13 years ago #

    I think my last post just went into the twilight zone here. (sigh). I'll wait a bit and repost if I don't see it. Don't know if I'm gonna see this one. Just talking to myself...

    whoop. There it is all of a sudden.

  17. billdennis5
    Member
    Posted 13 years ago #

    Thanks! I should download then upload (to my server) which file?

  18. burtadsit
    Member
    Posted 13 years ago #

    I'm not going to recommend just installing one updated file. That can cause problems. I would just download the latest svn trunk and upgrade to the latest.

  19. billdennis5
    Member
    Posted 13 years ago #

    Right on top of the old files? Sure ...

  20. billdennis5
    Member
    Posted 13 years ago #

    Just uploaded the trunk to my server.

    I am having the exact same problems:

    Cannot upload avatars
    The site wide blogs blugin breaks.

    Tried to log into the bug tracker using the same password I use to log into main BuddyPress site. Getting a no such password/username found.

  21. billdennis5
    Member
    Posted 13 years ago #

    Bumping this up

  22. gazouteast
    Member
    Posted 13 years ago #

    The avatar upload issue is still not fixed in BP 1.1.2 on WPMU 2.8.4a

    With a brand new install - creating first group, first ever arrival on group creation screen 3 (avatars) displayed a "Skip" button and a "Back" button as well as the upload tools.

    Tried to upload a known good image at 150x150 and got a truncated image display approx 60w x 10h and a non-functioning image cropper ... waited ... and waited ... and waited some more, thinking this could be similar to the unfixed flash uploader problem in WP Media Library ... waited ... made a coffee ... still didn't complete.

    tried to use the cropper (thinking maybe I had to s-t-r-e-t-c-h the image before cropping it - nope, that just returned an image failed to save error - checked in cPanel file manager and the image was there, correctly saved.

    Went to Group admin - Avatars and there was no avatar and tried to upload from there. Same issue.

    Checked in the database - no tables or references to avatars anywhere.

    The "good" folks over at BuddyPress are simply in denial of this type of issue - there are loads of threads about this very topic and they all point the finger at GD Lib and waggle it.

    Sorry guys, but if it's such a massive issue for so many users - change the damn code so that GD is NOT required. Use something else that will not give so many people this issue. Simple as?

    Gaz

    (very close to ditching "bluddypress" entirely - and that's EIGHT MONTHS after the above posts and still not fixed).

  23. gazouteast
    Member
    Posted 13 years ago #

    Forgot to say - after that very first visit to screen 3, the back and skip buttons have never been seen again - even when trying to create yet another new group. Yet another moment in the life of a "buggyPress" install.

About this Topic

  • Started 13 years ago by billdennis5
  • Latest reply from gazouteast