The MU forums have moved to

Installing wordpress mu 2.7 (34 posts)

  1. VentureMaker
    Posted 15 years ago #

    Then I guess your hoster did something. Maybe busted wildcard DNS record for your domain.

  2. tspoonrocks
    Posted 15 years ago #

    I am having the exact same problem. I installed and had wordpress running and the next day I was getting 404 error - Not Found errors. I've tried reinstalling multiple times. I've deleted everything including the database and the entire domain at one point. Linux acct. On your suggestion, I tried the following .htaccess:

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    then I recieve 500 Error - Internal Server Error.

    My ix webhosting has 2 other domains (no wordpress installed) but I'm wondering if they can affect this one. Awhile back, my .htaccess got 'hacked' and it was deleting or renaming my html files and forwarding visitors to other sites so it got deleted but I'm not sure where it was in the first place. My ftp program can see .htaccess files and I put the above in the root of my domain where the wordpress files were installed.

    I use ws_ftp pro and uploaded the files but I've also uploaded the zip file and uncompressed it with webshell. I didn't change any permissions.

    Next, I will try to install wordpress into a subfolder and redirect as you suggest. I may also try to install into one of the other 2 domains too to see what happens.

    I have a help ticket at ix but haven't heard anything - I also chatted with a ix person online but they weren't helpful at all...

    I've done so many different variations of database host names, users and user rights, and have uploaded config.php about a 100x - wondering if browser cache or if there's a time issue for changing db users and passwords and such...

    maybe it's not meant to be but I can't accept that...


  3. tspoonrocks
    Posted 15 years ago #


    So it worked brand new on 2nd domain. When I copy over config file to primary domain, still get the same 404 error. Now going to put wordpress into subfolder.


  4. andrea_r
    Posted 15 years ago #

    "and have uploaded config.php about a 100x -"

    You don't edit the config file for MU. It builds it on install.

About this Topic

  • Started 15 years ago by jagalizzi
  • Latest reply from andrea_r