The MU forums have moved to WordPress.org

Problems with upgrade to mu 2.7 (24 posts)

  1. @lex
    Member
    Posted 9 years ago #

    I had a fully working wpmu setup. decided to take the leap to the new 2.7
    Followed the upgrade instructions to the letter (as far as i can tell at least)
    http://codex.wordpress.org/Upgrading_WPMU
    I can log in to the admin area fine, and i can see all the blog info and posts etc, so thats fine.

    The problem is that i get completely blank blog pages...
    Any ideas would be greatly recieved!

  2. nibb
    Member
    Posted 9 years ago #

    If you get an utterly blank page its possible PHP is freaking out somewhere but is unable to send error reports to your browser, you need to make sure you have
    error_reporting = E_ALL & ~E_NOTICE
    set in php / php5.ini

    That said, sometimes I've seen that not work too well. It can also be a problem with writing to files or that the php files you've just unzipped over your old install either don't have the right user applied to them or don't have 'x' permisssions applied.

    I've tried all these cures in different circumstances. Sorry if its doesn't help

  3. @lex
    Member
    Posted 9 years ago #

    I have set all the permissions and on files n folders + child objects to '755' so there shouldn't be an issue there...?

    I will have to get someone with access to apache to check the error logging.
    thanks for the tips nibb,

  4. lunabyte
    Member
    Posted 9 years ago #

    error_reporting = E_ALL & ~E_NOTICE isn't the answer, usually, and has nothing to do with white screens of death.

    E_ALL & ~E_NOTICE is PHP's default, and 99 times out of 100 hasn't been changed.

    If the screen goes blank like that, it's a PHP problem somewhere that will show up in the error log because it's a fatal error. On occasion there may be so many errors that it just doen't log anything, or gives a cryptic broken pipe type of error which suggests turning the log level up to debug. (Which in turn really doesn't give anything useful, and at that point needs to have a stacktrace done.)

    What you appear to have been referring to is the setting for logging errors to the screen. Which is, and should always be, turned off in a live environment for security purposes.

    It won't tell you anything that the error log won't, anyway.

  5. @lex
    Member
    Posted 9 years ago #

    I feel there could be a problem around the step 10 in the codex install. Can someone explain exactly the ramifications of adding the lines of code in correctly/incorrectly please?

  6. VentureMaker
    Member
    Posted 9 years ago #

    Nope, step 10 is OK

  7. mushin69
    Member
    Posted 9 years ago #

    What about the .htaccess?

  8. tanvir
    Member
    Posted 9 years ago #

    at step 10:
    define('DOMAIN_CURRENT_SITE', 'yourdomain.tld');
    define('PATH_CURRENT_SITE', '/');
    define('BLOGID_CURRENT_SITE', '1');

    most probably u don't have change the last two line. Just change the first line according to your address. It's simple :)

  9. @lex
    Member
    Posted 9 years ago #

    The .htaccess is as follows:

    php_flag register_globals 0
    php_flag display_errors 0
    RewriteEngine On
    RewriteBase /
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    And it looks like my step 10 could be ok then, as it is set like tanvir suggested. The second part of step 10 though:

    #  After "define('SECURE_AUTH_SAULT' ...":
    
       1.
    
          define('NONCE_KEY', ''); // replace '' with value from http://api.wordpress.org/secret-key/1.1/
    
       2.
    
          define('AUTH_SALT', ''); // replace '' with value from http://api.wordpress.org/secret-key/1.1/

    I have added in the pw-config.php above the thats all commment as i couldn't fine the ""define('SECURE_AUTH_SAULT' ...":" line, so it is in as below:

    define('NONCE_KEY', 'r|?,t9n{4{~Iqh0zicEk]p7wbsXe{|7QdH00%i-Lt<0P7!D5v:iDY9]:~$^?==3P'); // replace '' with value from http://api.wordpress.org/secret-key/1.1/
    
    define('AUTH_SALT', 'X6$yAG#wZ=.jImrNFdX;t^TO0za$siX%$JIJT2$F.DZz%uya}&_Vi8jnM Tw@5t@'); // replace '' with value from http://api.wordpress.org/secret-key/1.1/
    
    /* That's all, stop editing! Happy blogging. */
  10. lunabyte
    Member
    Posted 9 years ago #

    Me personally, when a new version comes out I like to take the new wp-config and bounce it against the old one. If there are changes, I tend to migrate my old config into the new one, and carry on from there.

  11. @lex
    Member
    Posted 9 years ago #

    Ok, i have taken the sample wp-config.php from the 2.7 install files and updated the settings in it to match the info from the previous version.
    I am still getting blank blogs (root + 2 other sub blogs) I can login to the admin area fine.
    I have disabled and removed all plugins, widgets and set the theme to the wpmu default theme on all blogs.

  12. andrea_r
    Moderator
    Posted 9 years ago #

    and you hit the upgrade button in the back?

  13. @lex
    Member
    Posted 9 years ago #

    sure did :0) (A few times now to make sure!) Its says everything was sucessful.

  14. @lex
    Member
    Posted 9 years ago #

    If I reinstall wpmu fresh due to the upgrade not working properly, can i then import the posts easily enough from my db backup?
    thanks

  15. lunabyte
    Member
    Posted 9 years ago #

    The database should be fine. Back it up, naturally, but there shouldn't be a need to completely reinstall MU. Backup your .htaccess file and wp-config.php file, and then delete everything else EXCEPT your wp-content directory.

    Upload new files, compare your wp-config.php file to the new wp-config-sample.php file, and either add your details to the sample and rename or add anything new to your old one, and it should be just fine.

    Also, when doing things like this, you can check for your IP address in htaccess and if it's not yours you can redirect to a maintenance.html file or something. Thus keeping users off the site while you're tinkering. You may also have to add this to an htaccess file in wp-admin as well, just to be safe.

  16. aarongrill
    Member
    Posted 9 years ago #

    I'm having the same problem after an upgrade, but instead I only have a couple blank pages in the wp-admin. I get a blank page when I try to add users or look at current plugins. I removed all plugins and have changed/reinstalled my .htaccess and wp-config.php countless times. Still no luck.

  17. tanvir
    Member
    Posted 9 years ago #

    check out the theme, most probably your default theme template inherited from the previous version

  18. cgrymala
    Member
    Posted 9 years ago #

    at step 10:
    define('DOMAIN_CURRENT_SITE', 'yourdomain.tld');
    define('PATH_CURRENT_SITE', '/');
    define('BLOGID_CURRENT_SITE', '1');

    most probably u don't have change the last two line. Just change the first line according to your address. It's simple :)

    Unless, of course, your WPMU installation is not located at the root of your domain. If you have your WPMU installed at http://www.example.com/blogs/ or something like that, you will need to edit the second line. If you don't, you will get a basically empty blog with the default WP theme when you try to visit one of your existing blogs.

  19. Klark123
    Member
    Posted 9 years ago #

    If one follows the upgrade directions here:

    http://codex.wordpress.org/Upgrading_WPMU

    won't the wp-content folder be deleted?

    As in Step 4: "Remove all the files in your www directory:
    e.g., rm ~/www/* ~/www/.htaccess"

    There is never a step to put it back!

    Or, am I reading wrong?

  20. DanYork
    Member
    Posted 9 years ago #

    Klark123, on Linux/UNIX systems, doing "rm ~/www/*" will remove only the files in the directory and NOT the folders/directories.

    You would need to do "rm -r ~/www/*" to remove any folders.

    So the instructions are correct, although they could be clarified so that people understand you want to remove all the files in the top-level of your WPMU installation, but not the subdirectories/subfolders.

  21. djsteve
    Member
    Posted 9 years ago #

    I had the same problem.. upgrading from 1.5 to 2.6 then the 2.7 upgrade failed - it produced the blank screen (firefox said redirect issue) that was the problem in the original post. I decided to try Luna's advice, took a wp-config file from a different 2.7 install I had on another server, put that side by side with my old wp-config from the 1.3 ->1.5 ->2.6 file - filled in all the blanks, crossed my fingers when I uncommented the line for define( 'NOBLOGREDIRECT', 'http://example.com/' ); and added my dot com in there..
    uploaded the new wp-config - and now it works - woo hoo - thanks for the idea Luna...
    Hope this helps someone out there...

  22. Klark123
    Member
    Posted 8 years ago #

    DanYork, thanks for your explanation!

  23. andreao
    Member
    Posted 8 years ago #

    I just created an MU site at http://www.pampermeplace.net/blog and everything was working fine until just now when adding a few plugins and changing some widgets, etc. All of a sudden my admin is a totally white page! What ever could have done this so suddenly?

  24. andrea_r
    Moderator
    Posted 8 years ago #

    "until just now when adding a few plugins and changing some widgets, etc. All of a sudden my admin is a totally white page!"

    White page = errors. Those plugins and widgets you added & messed around with did it. Go remove them via ftp.

About this Topic