The MU forums have moved to WordPress.org

Upload Image Issue (7 posts)

  1. mytechlogic
    Member
    Posted 13 years ago #

    I know you all have seen this before but here is a new twist. I have downloaded the lastest MU and the latest BuddyPress and I cant upload images.

    "Upload Failed! Error was: The uploaded file could not be moved to the upload folder."

    Now, I have checked permissions and I have checked ownership of the blogs.dir folder and all it's subfolders. I have root access and I have changed the ownership to the current user. I have tried ownership of root, apache, nobody and none of them will allow photos to be uploaded. Same error everytime.

    I have even tried to remove blogs.dir and all it's subfolders and then try to upload again. The directories are created but the photos just won't load. This is so strange to me because it's not a permission issue and it's not a group/ownership issue.

    Has anyone had this problem with the MU and BP latest downloads? The new MU has the wp 2.7 look and feel.

    I'm at a loss.

    Michael

  2. mytechlogic
    Member
    Posted 13 years ago #

    OMG, this is really funny. Here is the fix. I had to create a folder at the MU root called "avatars". Once I created that the photos loaded just fine. How funny is that! You would think that the files were going to blogs.dir

    FYI my peeps!

    Who you calling "My Peeps"? LOL

  3. coto
    Member
    Posted 12 years ago #

    Really? i had to create the folder at MU root, but the issue persist

  4. tim.moore
    Member
    Posted 12 years ago #

    Coto,

    Are you using BuddyPress? If so, you might try the BuddyPress forums.

    Otherwise, check file permissions on the wp-content/blogs.dir directory. The server needs write access to upload files.

  5. coto
    Member
    Posted 12 years ago #

    Hi friend, i'll try with BuddyPress Forum, because (may be) i don't have problem with permisssions

    These are my configuration:

    chown USER:apache -R /var/www/html/SITE/
    chmod 755 -R /var/www/html/SITE/
    chmod 775 -R /var/www/html/SITE/wp-content/blogs.dir/
    chmod 666 /var/www/html/SITE/.htaccess
    chmod 666 /var/www/html/SITE/wp-settings.php
    chmod 666 /var/www/html/SITE/wpmu-settings.php
    chmod 666 /var/www/html/SITE/wp-config.php
    chmod 666 /var/www/html/SITE/wp-content/wp-cache-config.php

  6. tim.moore
    Member
    Posted 12 years ago #

    Part of the issue may be the chown USER:apache -R /var/www/html/SITE/ that you are running. Usually, Apache runs as user www-data or nobody (depending on the server operating system), not as user Apache.

  7. skcsknathan001
    Member
    Posted 12 years ago #

    do this

    chown -R 99:99 blogs.dir

About this Topic

  • Started 13 years ago by mytechlogic
  • Latest reply from skcsknathan001