The MU forums have moved to WordPress.org

Dashboard loads horribly slow (8 posts)

  1. bechster
    Member
    Posted 15 years ago #

    Hi,

    I'm having trouble with horribly slow loading admin pages. The dashboard for my main blog loads ok, but it takes forever (2-5 minutes) to load for all the other blogs (I only have 8). My site is behind a firewall and the problem seems to relate to http requests not being able to get through the firewall.

    Pbearne suggests "a setting in MU that stops the server trying to make http (or any calls) off the box".

    I have an MU install behind a firewall through which the sever can not get through and therefor have to go through the plug-ins and core to remove/override/disable all the calls to get the news etc. to stop the admin been very slow as it kepps waiting for time outs!

    Such a setting would, in my case at least, be very welcome.

    But for now, how do I, for instance, go through the plug-ins and core to remove/override/disable http calls? Does anybody know of any plugins that do just that?

    Or can anyone come up with an alternative solution?

    Any help is very much appreciated.

  2. tanvir
    Member
    Posted 15 years ago #

  3. bechster
    Member
    Posted 15 years ago #

    @tanvir: Thanks. I tried this, but it didn't really make any difference.

    What wonders me is that this problem is not inflicting my main blog. That leads me to think it may have something to do with the rewriting of URL's, because that is the only difference between the main blog and the other blogs, that I can come to think of. Or am I wrong? I'm just guessing here.

    If this is the case, might this be solved in any way via .htaccess?

    By the way, I'm using virtual folders instead of sub domains for my blogs. Does this make any difference?

  4. Ovidiu
    Member
    Posted 15 years ago #

    use the "wp tuner" to check what components are givign you trouble. or maybe a firefox add on like YSLOW?

  5. bechster
    Member
    Posted 15 years ago #

    @Ovidiu: Thanks! I've tried installing WP Tuner and it does give me some hints.

    The functions "widgets_init" and "init" seem to be making some trouble, loading with 74,990.8 and 80,078.7 ms respectively, with 0 bytes of output.

    What do these functions do, except from registering the sidebar widgets (in the front end)? And if possible, is there any way to disable them in the back end without messing something up? (They don't seem to be working after all)

    Why doesn't this occur in the admin of my main blog?

  6. bechster
    Member
    Posted 15 years ago #

    I think I just found a fix for this issue. The problem relates to http.php transport.

    Cross referencing:
    http://core.trac.wordpress.org/ticket/8590

    Disabling all external HTTP access may solve the problem temporarily. Of course this means losing cron, pinging, plugin updates and more, but it has to do for now.

    Think I need to speak with the guy who administers our firewall, because that must be the real source of this problem.

  7. azsportshub
    Member
    Posted 15 years ago #

    Ok this fixed it for me (or at least it seems so) http://yjsoon.com/2008/12/11/wordpress-mu-upgrade-issues/

    @bechster's fix also worked temporarily, but since http requests were disabled it ended up crashing other things.

    It turns out that the upgrade script just did not work for us, so after manually updating our 100 or so blogs we are back in business

  8. bechster
    Member
    Posted 15 years ago #

    @azsportshub: Thanks a lot! This immediately seemed to fix the performance issue in my installation of WPMU.

About this Topic

  • Started 15 years ago by bechster
  • Latest reply from bechster