The MU forums have moved to

I am just not getting the Domain Mapping. . . (12 posts)

  1. worldblogosphere
    Posted 15 years ago #


    I have read the tutorial section about it, Donncha's site, and the WordPress plugin page for it. I just can't sem to figure it out though.

    What I want is for my blogs which are originally created as subdomains ( to be switched to their own actual domain ( which I already own). I want ALL of the pages within the blog to automatically become

    I think my problem is there just isn't a lot of instruction. I mean I have the Domain Mapping link in the admin area. Then when I click I have two options. the first is loading the IP Address, which I have done.

    Now with only one other box I don't know what address to put there. Do I put in the domain I want everything to go to, or do I put in the subdomain? I tried both, and it still just shows as the subdomain unless I manually type in the real domain. the only reason the real domain opens is because I put in a redirect to point it to a page that would load.

    Thanks for any guidance,
    Gene :-)

  2. superbison
    Posted 15 years ago #

    I use this plug-in successfully.

    Go to prosportswrapup DNS add A record for IP.

    Go to Hosting Control Panel and "add-on" domain to add domain pointing to your WPMU root. This way your hosting account knows where to send the domain when the domain comes calling your server's IP.

    Finally enter just the domain name, "" in the domain_mapping admin text field.

    Even though on the backend things seem to link to checking my keywords in Google shows every result is to the straight up domain.

    BTW: some of my domains I just pointed at my hosting account using the hosting account nameservers. No A record to an IP.

  3. worldblogosphere
    Posted 15 years ago #

    OK, Apparently I have to have my server administrator make this change for me.

    Now I just need to know exactly what to ask them to do. I am not sure I quite understand what "add A record for IP" means.

    I will want to do this for multiple domains, in the long run many domains. Do I need to have the same exact thing done for each one? Does it need to be a little different for each one?

    Thanks again for any assistance.

  4. worldblogosphere
    Posted 15 years ago #

    I now have a wildcard DNS setup on my server.

    Domain Mapping is still not working.

    Can someone please help me get this figured out?

    I have added the domain within the backend.

    I have then went and switched the domain setting in the first box in the main blogs ( Admin>Blogs>Edit page.

    When I switch it from a sub domain to the actual domain and then go to load the site it loads as my main site instead of the other blog.

    Thanks for any help at all,
    Gene :-)

  5. andrea_r
    Posted 15 years ago #

    Did you install the domain mapping plugin?

  6. worldblogosphere
    Posted 15 years ago #

    Hi Andrea,

    Yes, the domain mapping is installed on both the main site, and the second blog site at the moment.

    I followed what you had said in another post...
    I went to the second blog and add the domain i wanted for the second blog.

    Then I went to the main blog's admin and clicked on Blogs and then clicked Edit for the second blog. Then in the first box on the edit page "Domain" I changed the url to the actual domain of the second blog, rather than the sub domain.

    Then once it is changed - when I load the second domain it loads as the main blog instead.


  7. andrea_r
    Posted 15 years ago #

    Did you leave the www off of the address?

  8. worldblogosphere
    Posted 15 years ago #

    Yes, it is just listed as with no www.

  9. andrea_r
    Posted 15 years ago #

    And then it's redirecting to

    See the www? That's gonna be part of your issue.

  10. PerS
    Posted 15 years ago #

    I did the following:

    in my apache conf: ServerAlias *
    dns: IN CNAME (note the trailing . after .no). is the wpmu site

  11. worldblogosphere
    Posted 15 years ago #

    That is actually where it is supposed to be redirecting from. I want it to redirect to the main domain

    I just went and changed it to the way it is supposed to be and if you check again you will see it loads instead.

    I had reset it to the normal subdomain so the page would load at all and I could get to the admin area.

  12. worldblogosphere
    Posted 15 years ago #


    So, after you mentioned the www. portion possibly being the problem I went and checked by addon domains settings, and then my redirect settings.

    I had set to redirect to the sub domain because I didn't know of another way in the beginning.

    I removed the redirect and then loaded the page. It worked.

    Again, thank you all for your help.

    As always I do hope my mistakes make it easier for someone down the road to learn.

    Gene :-)

About this Topic

  • Started 15 years ago by worldblogosphere
  • Latest reply from worldblogosphere