The MU forums have moved to WordPress.org

Cannot create new blogs (29 posts)

  1. darkfish
    Member
    Posted 13 years ago #

    Hi,
    I am running WPMU 2.7 at http://blognuno.com/ .
    So far, there have been three blogs created on there. The first two worked fine, however the third one(and more created after that) did not work. The subdomain is created fine but when you go on the newly created blog it says 'The blog you have requested is not installed properly. Please contact the system administrator.' I have tried creating blogs both as a new user and a registered user but with no luck. You can see the proof for yourself at http://blog.blognuno.com/, or even try signing up at http://www.blognuno.com/ .

  2. chaty1
    Member
    Posted 13 years ago #

    This is one of the more maddening errors to get. What trips this into occurring is enough information,
    like a config file, to convince WPMU there is a working install present, but not enough information in
    the database.
    First check the database. Are all the tables there? If so, do they have the correct information? You may
    have to reinstall.
    In some cases, you may get this message even before you have installed WPMU. This is because
    Wordpress is installed elsewhere on your server. There's some code in there from regular Wordpress
    that will travel up a directory, and if it finds a config file, tries to use it. You can disable your other
    config file for the few minutes the install will take, or you can edit WPMU to ignore it.
    Go to wpblogheader.
    php in the root folder, and look for line 9:
    if ( !file_exists( dirname(__FILE__) . '/wpconfig.
    php') && !file_exists( dirname(
    dirname(__FILE__) ) . '/wpconfig.
    php')) {
    Change it to:
    if ( !file_exists( dirname(__FILE__) . '/wpconfig.
    php') /*&& !file_exists( dirname(
    dirname(__FILE__) ) . '/wpconfig.
    php')*/) {

  3. chaty1
    Member
    Posted 13 years ago #

    This is one of the more maddening errors to get. What trips this into occurring is enough information,
    like a config file, to convince WPMU there is a working install present, but not enough information in
    the database.
    First check the database. Are all the tables there? If so, do they have the correct information? You may
    have to reinstall.
    In some cases, you may get this message even before you have installed WPMU. This is because
    Wordpress is installed elsewhere on your server. There's some code in there from regular Wordpress
    that will travel up a directory, and if it finds a config file, tries to use it. You can disable your other
    config file for the few minutes the install will take, or you can edit WPMU to ignore it.
    Go to wpblogheader.
    php in the root folder, and look for line 9:
    if ( !file_exists( dirname(__FILE__) . '/wpconfig.
    php') && !file_exists( dirname(
    dirname(__FILE__) ) . '/wpconfig.
    php')) {
    Change it to:
    if ( !file_exists( dirname(__FILE__) . '/wpconfig.
    php') /*&& !file_exists( dirname(
    dirname(__FILE__) ) . '/wpconfig.
    php')*/) {

  4. darkfish
    Member
    Posted 13 years ago #

    Thanks for the info.
    When you say: Are all the tables there?
    What excatly are all the tables meant to be?
    Also, I attempted the code you put last but the wp-blog-header.php file did not include such a line.
    Here is the contents of mine:
    ------------------
    <?php
    /**
    * Loads the WordPress environment and template.
    *
    * @package WordPress
    */

    if ( !isset($wp_did_header) ) {
    if ( !file_exists( dirname(__FILE__) . '/wp-config.php') && !file_exists( dirname( dirname(__FILE__) ) . '/wp-config.php')) {
    if (strpos($_SERVER['PHP_SELF'], 'wp-admin') !== false) $path = '';
    else $path = 'wp-admin/';
    include( "index-install.php" ); // install WPMU!
    die();
    }

    $wp_did_header = true;

    require_once( dirname(__FILE__) . '/wp-load.php' );

    wp();

    require_once( ABSPATH . WPINC . '/template-loader.php' );

    }

    ?>
    -----------
    I hope I won't have to re-install, if I do will i have to lose all of the data?

    Many thanks again,
    Henry

  5. grandslambert
    Member
    Posted 13 years ago #

    Can you explain more about what you mean by "the subdomain is created fine?" Where are you creating the subdomains?

    Do you have wildcard subdomains enabled on your server - that is a requirement to a subdomain install of MU.

  6. darkfish
    Member
    Posted 13 years ago #

    Yes, I have wildcard subdomains enabled. All the domains have been created automatically by wordpress fine.

  7. darkfish
    Member
    Posted 13 years ago #

    I am in the process of doing a re-install, therefor the links I provided earlier will not be working.

  8. chaty1
    Member
    Posted 13 years ago #

    Sorry I had to go. Did the re install work?
    here is a way to re start the home page to default with out re installing.
    Warning you will lose work if you perform this.
    delete the .htaccess file
    delete wpconfig.php if one was created
    drop the tables in the database.
    goto home page and start over.
    Ok when you say subdomains where created fine do you mean that the link was created fine or the file in your data base

  9. chaty1
    Member
    Posted 13 years ago #

    to check your wildcard is working enter a subdomain that doesn't exist in your browser. Wildcard should redirect to your home page. If you get the same error page you probably go a install problem.
    ps are you running any other wordpress files or have a back up wpmu file?

  10. darkfish
    Member
    Posted 13 years ago #

    Hi again,
    The reinstall I am doing right now.
    When I say the subdomain was created fine I mean it was there and working and with all three blogs it pointed at them fine.
    The wildcard is working yes.
    And yes I was running a copy of normal wordpress in the parent directory, which I have now moved to another subdirectory, so that may have been the problem.
    Many thanks again everyone.

  11. darkfish
    Member
    Posted 13 years ago #

    Three Cheers!
    I have the answer!
    Here's the story:
    1. Uploaded wordpress
    2. Installed Wordpress
    3. Set up themes and styles etc.
    4. Created a new blog
    5. The same old error message :@
    6. Stripped site down to basics and put theme back to wordpress mu default
    7. Tried blog again
    8. Same old error message
    9. Created a new blog with the wordpress mu theme selected
    10. Success!!!

    So, it looks like there was something wrong with the theme I had selected (Chris Pirillo's Wicketpixie). I had previously done some editing to include my adbrite codes so I will download the theme fresh and try again. I will update this when I have done that. Hope I have helped anyone with the same issue.

  12. jackson100
    Member
    Posted 13 years ago #

    experiencing the same problem, cannot create blogs, neither through admin nor through wp-signup.php.

    tried reinstalling, connecting fresh install to existing dbs, nothing seems to work:

    what do you mean by this:
    9. Created a new blog with the wordpress mu theme selected

  13. andrea_r
    Moderator
    Posted 13 years ago #

    jackson, do the blogs show up on the admin list but aren't accessible?

    If so, you missed the wildcard steps.

  14. jackson100
    Member
    Posted 13 years ago #

    yes, andrea, the newly created blogs show up on the admin list, but no user is bound to them and when trying to enter either backend or frontend, it says:

    'The blog you have requested is not installed properly. Please contact the system administrator.'

    first i though there might be a plugin which is not compatible with 2.7, but then tried a fresh install with existing dbs and same problem again...now reverted back to 2.6.5 which works fine

  15. racin36er
    Member
    Posted 12 years ago #

    Okay guys, I know this is bringing an old post back from the dead, but my issue is similar, didn't want to open a new post for it.

    My wordpressmu install will create new users and blogs (show up in admin, send out activation links/emails/etc), but it's not creating directories for the new blogs. all i ever get after creating a new blog and attempting to visit it, is a 404 error, telling me the directory doesn't exist. this is verified when checking the directory WPMU is installed in.

    Can anyone help me out here? I assume it's got something to do with permissions, but I'm fairly new to Linux (ran a server under Ubuntu for about 6 months now), and I'm still not the greatest with permissions and so forth.

    I use the newest version of WordpressMU, no themes, no special plugins, nothing special about it. It was fresh installed last night (along with a fresh install of Ubuntu 9.10), so other than the administrative blog, it's a completely clean install.

    Thanks in advance!

  16. SteveAtty
    Member
    Posted 12 years ago #

    WPMU blog directories are virtual

    Is mod_rewrite enabled on your server? (on ubuntu you do sudo a2endmod and then enter rewrite when it asks you for the module name).

  17. racin36er
    Member
    Posted 12 years ago #

    Thanks for the reply.

    Yes, I have mod_rewrite enabled. (checked, double checked, triple checked last night).

  18. racin36er
    Member
    Posted 12 years ago #

    I've just gone through my entire configuration, tested and retested - and I still don't get it.

    Virtual Domain and Wildcard is enabled and tested working 3 times over. The accounts get created, emails are sent (as i said above) - everything seems to be working just fine - except the new blogs *always* return 404 not found...

    anyone? this is driving me nuts! :P

  19. andrea_r
    Moderator
    Posted 12 years ago #

    subdomain blogs or subfolder ones?
    on a Windows server?
    can you send a link?

  20. racin36er
    Member
    Posted 12 years ago #

    Linux Ubuntu 9.10
    Subdomain blogs (speaking of which, how can I change this to test?)
    link is http://wpmu.bp-tech.net - but it's down currently as I'm doing some things to the server today. It'll be back up tonight or tomorrow.

  21. racin36er
    Member
    Posted 12 years ago #

    Got it.

    I had to remove WPMU and reinstall it to make it work - it works and it creates the blogs, no problems.

    NOW, however, when I go to the new user, tburns.bp-tech.net, and log in, I get an error that says:

    You do not have permission to view this blog. Please contact the system administrator.

    Any ideas? I've checked permissions in Admin, all look set okay?

  22. andrea_r
    Moderator
    Posted 12 years ago #

    Who are you logging in as?

  23. racin36er
    Member
    Posted 12 years ago #

    when i log in as the new user (sorry)

    I have the admin user, and then I created a new blog at tburns.bp-tech.net. When I log in as the new user (tburns) i get the above permissions error when I try to go to my admin page to update my blog.

  24. andrea_r
    Moderator
    Posted 12 years ago #

    Is the user assigned to that blog? IF you (as admin) are creating a new blog, and inputting your own email address, the YOU own the blog.

  25. racin36er
    Member
    Posted 12 years ago #

    negative, i had the new user signed up as if it was someone i didnt even know signing up

  26. andrea_r
    Moderator
    Posted 12 years ago #

    What plugins are you running that may affect signups or blog defaults?

  27. racin36er
    Member
    Posted 12 years ago #

    The only plug in in I have installed is Callum Macdonald's WP SMTP Mail plugin.

  28. andrea_r
    Moderator
    Posted 12 years ago #

    and that included whatever you have in mu-plugins?

  29. racin36er
    Member
    Posted 12 years ago #

    No other plugins are present. I now have BuddyPress installed, but thats separate to the matter. (sorry for the delay - just started planning a wedding - haha.)

About this Topic

  • Started 13 years ago by darkfish
  • Latest reply from racin36er