The MU forums have moved to WordPress.org

Fatal Error on Install (19 posts)

  1. richardshields05
    Member
    Posted 13 years ago #

    I get the following error when Installing. I used the sample config file to create my own config file because the web installer was not able to do it (it just reloaded index.php). I have Chmod-ed everything correctly as well.

    Fatal Error
    If your blog does not display, please contact the owner of this site.

    If you are the owner of this site please check that MySQL is running properly and all tables are error free.

    Database Tables Missing.
    Database tables are missing. This means that MySQL is either not running, WPMU was not installed properly, or someone deleted mt_site. You really should look at your database now.

    What do I do now?
    Read the bug report page. Some of the guidelines there may help you figure out what went wrong.
    If you're still stuck with this message, then check that your database contains the following tables:

    * mt_blogs
    * mt_users
    * mt_usermeta
    * mt_site
    * mt_sitemeta
    * mt_sitecategories

    I looked at my database and it is empty - I dont know why? I have installed regular WordPress and MU before without problems so what's up?

    I use GoDaddy, and have wildcard enabled.

  2. andrea_r
    Moderator
    Posted 13 years ago #

    Why are the db tables prefixed with mt and not wp?

    And you have to let the installer create the config.

  3. richardshields05
    Member
    Posted 13 years ago #

    I used wp_ first, but that didnt work, so I changed it to mt_ to try something different without success.

    I could not use the installer create the config because when I click the "Create a Configuration File" button, it just reloads index.php (despite 777 chmod). So I had to do it manually.

  4. richardshields05
    Member
    Posted 13 years ago #

    Perhaps I cannot automatically create the config file because I have a regular WP site in the root. My structure is:

    /public_html/
    /public_html/wp-content and all other WP files for Site 1

    /public_html/domainfolder/wp-content and all other WPMU files for Site 2. Site 2 uses domainfolder.

    Do I need to somehow disable Site 1 while installing Site 2? If so, how?

  5. richardshields05
    Member
    Posted 13 years ago #

    I fixed it - it was because of the issue listed above (multiple WP sites on same host).

  6. sammythebull
    Member
    Posted 13 years ago #

    Hi Richard,

    I seem to be going through the same problem as you did. I have the regular WP version installed in my root folder and am now seeking to install MU in this same hosting package in a subdirectory.

    Here's the error I'm receiving:

    -------------
    Fatal Error
    If your blog does not display, please contact the owner of this site.

    If you are the owner of this site please check that MySQL is running properly and all tables are error free.

    Database Tables Missing.
    Database tables are missing. This means that MySQL is either not running, WPMU was not installed properly, or someone deleted wp_site. You really should look at your database now.

    What do I do now?
    Read the bug report page. Some of the guidelines there may help you figure out what went wrong.
    If you're still stuck with this message, then check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories
    If you suspect a problem please report it to the support forums but you must include the information asked for in the WPMU bug reporting guidelines!
    -------------

    I noticed that you said you managed to fix the problem. Can you please share it with someone who's as frustrated as you must have been? :)

    Thanks.

  7. andrea_r
    Moderator
    Posted 13 years ago #

    There's a check in WP that goes up one directory to see if a config file is there. It's a security feature not a bug. :)

    See line 9 here:
    http://trac.mu.wordpress.org/browser/trunk/wp-blog-header.php

    Comment it out so you can install.

  8. sammythebull
    Member
    Posted 13 years ago #

    Did that, now get the following:

    "There doesn't seem to be a wp-config.php file. I need this before we can get started."

    There's a button to click that says "Create a Configuration File" but when clicked, nothing happens.

  9. kevmille
    Member
    Posted 13 years ago #

    Thanks, that fix worked for me :-)

  10. sammythebull
    Member
    Posted 13 years ago #

    Still looking for a fix regarding my above post.

    Thanks.

  11. andrea_r
    Moderator
    Posted 13 years ago #

    "There's a button to click that says "Create a Configuration File" but when clicked, nothing happens. "

    That's for single WP. You don't see that in MU if you've got it right.

    Your single WP in the rot is interfering with the installation. There's countless threads here explaining the same thing over and over agaon:

    - you can disable the top-level config file long enough to install MU
    - you can comment out one line in wp-blog-header.php so it doesn't travel up a directory and check

    Or, you knpow, you can spend the five bucks for a second hosting account and play with MU in the root and save yourself a whole pile of issues.

  12. vskylabv
    Member
    Posted 13 years ago #

    @andrea_r
    Actually I receive "Create a Configuration File" under MU. If you're using MU in the root and then another in a sub, you'll receive that same message.

  13. andrea_r
    Moderator
    Posted 13 years ago #

    ... becasue it's going up and looking for single-WP specific files, which are still there but unused in MU....

  14. bbampi
    Member
    Posted 13 years ago #

    Hi, same problem here... solved finally... So open wp-blog-header.php, comment line 9 "if ( !file_exists( dirname(__FILE__) . '/wp-config.php') && !file_exists( dirname( dirname(__FILE__) ) . '/wp-config.php')) {"

    then go to line 24, which is "}" and comment it. That's all, works perfectly!

  15. dainismichel
    Member
    Posted 12 years ago #

    bbampi: WORKED! :-)

  16. dainismichel
    Member
    Posted 12 years ago #

    darn....installed, can see my back end, but when I visit the site, it asks me for all of my install information again (wpmu install).

  17. dainismichel
    Member
    Posted 12 years ago #

    Ahh...uncommented and the install looks to be working...

    umm

    What do you mean by:

    Or, you knpow, you can spend the five bucks for a second hosting account and play with MU in the root and save yourself a whole pile of issues.

    I'm on dreamhost's standard multi-domain account. This install is it's own sub-domain. Commented the lines to install, uncommented and Buddypress and WPMU seem to be working...

    What kind of issues can I expect?

    Best,
    Dainis

  18. andrea_r
    Moderator
    Posted 12 years ago #

    none, now that it's running.

  19. rolandinsh
    Member
    Posted 12 years ago #

    as far as I understand there is no way to run two WPMU un same domain in different subdirectories (don't ask why I need so).

    Example:
    mydomain.local => regular front page.
    mydomain.local/blog => regular WP blog
    mydomain.local/wpmu1 => first WPMU
    mydomain.local/wpmu2 => second WPMU

    I get that FATAL ERROR mesaage. Is it some how connected with
    define('DOMAIN_CURRENT_SITE', 'mydomain.local' );
    for both WPMU?

About this Topic

  • Started 13 years ago by richardshields05
  • Latest reply from rolandinsh