The MU forums have moved to WordPress.org

404 on all newly created blog posts (11 posts)

  1. christofire
    Member
    Posted 13 years ago #

    A day ago, I tried to install WP Super Cache onto a perfectly working mu2.7 subdomain setup installed in root. The WPSC install worked, but I started noticing images appearing as broken links in some, then all blogs. I Determined, with the help of my host, that I had some incorrect ownership/permissions settings that were probably brought to light by the cache software. So we removed all the cache stuff and tried to take care of the permissions - perhapse too quickly - and managed to have to correct ourselves 2-3 times. (PHP 5.2.8 now verified file by file that directories are now 755 and files are 644)

    The primary thing we were seeing with some of our improper repairs was that every post from all blogs went to a 404, even though the posts appeared as expected on the front page of the blogs, category lists, and feeds. But if you click on a post link, 404 every time. We believe the ownership/permissions stuff is correct now, but the final trick we had to do to fix the existing blogs was to revert the permalinks for each blog to the default setting then back to the /%postname%/ custom structure I have set up as the new account default. THEN all the posts in that blog worked fine.

    The remaining issue I have is still a serious one: All *newly* created blogs have the 404 for all posts including the "Hello World". The set-up process works like a charm including email verification etc. Adding a new post shows no problems, URLs are correct, Pages work fine, but clicking on Posts always goes 404. The permalink flip trick still works on these.

    Host says nothing is in the error logs. They did a repair on database which coughed up errors, but there are none now. I reinstalled the wpmu2.7 files overwriting the existing, then did an "Upgrade" from the admin - just in case. The script ran happily, but to no effect.

    I asked my host to confirm that my current server settings for Apache, DNS, and PHP still match this setup doc (still waiting for result of that check):

    http://trac.mu.wordpress.org/browser/trunk/README.txt

    You can see the result of a new blog setup here:
    http://captaincrunch.bestagentblogs.com/

    Feel free to whip up your own. It'll look the same.

    I freely admit that I am a hack and pushing the envelope of my skills here, so hopefully I'm just missing something that is obvious to the talented and experienced folks here.

    TIA

  2. andrea_r
    Moderator
    Posted 13 years ago #

    Ooo, ooo! I came across the exact same thing, now to remember what it was...

    To clarify, the page slugs work, the archives and category archive works, it's just the individual page permalinks that 404.

    I need to think about it.

  3. christofire
    Member
    Posted 13 years ago #

    Andrea, you are some kind of goddess. Your posts *everywhere* have saved my butt and countless hours of frustration again and again!

    You are exactly right with your summary.

  4. andrea_r
    Moderator
    Posted 13 years ago #

    Hee!

    At least I'm a goddess somewhere. :D

    *put on mom invisibility cloak*

  5. christofire
    Member
    Posted 13 years ago #

    I just got this from Mike at asmallorange.com - BTW, if anyone needs a host that *ALWAYS* goes above and beyond, I've used asmallorange.com for years and have referred lots of people to them. :-)

    ---

    The settings are are good. Ive been looking into this a bit more trying to wrap my head around why it will show previous posts, but not new ones. Since some work, we know the mod_rewrite rules are working. Ive looked at the database tables, and the test blog and posts i made are there (obvious also since they show correctly in the preview). Ive tried both php4 and php5 and get the same results. I've ran the cron.php and wp-cron.php files from the command line thinking maybe cache needs to be updated.

    I have a feeling its something to do with supercache. There are still some remnants of it around, and i wonder if its still "working" in wordpress, and not getting updated with new blogs since it was uninstalled? (shot in the dark guess, but maybe that might spark something with andrea_r on the forum post)

    [/home/xxxxx/public_html]# find . -type d |grep cache
    ./wp-content/mu-plugins/wp-super-cache
    ./wp-content/mu-plugins/wp-super-cache/plugins
    ./wp-content/cache
    ./wp-content/cache/supercache

  6. christofire
    Member
    Posted 13 years ago #

    Narrowing things down a little, I got rid of the remaining supercache bits.

    The new blog permalinks are set up by:
    http://wpmudevorg.wordpress.com/project/New-Blog-Defaults

    Since this was updated *yesterday* I uploaded the new one. All options work fine except for the permalinks. *NONE* of the permalinks options, except for "default," will work. All 404.

  7. MrBrian
    Member
    Posted 13 years ago #

    Check that you're htaccess file has the supercache rewrites init

  8. christofire
    Member
    Posted 13 years ago #

    MrBrian, I'm not sure I understand. I removed all supercache bits.

    .htaccess looks like this now:

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

  9. christofire
    Member
    Posted 13 years ago #

    Just something interesting to note:

    When I go into the backend of a newly created blog and then I go to settings/permalinks from the menu, the radio button for "Custom Structure" is selected with /%postname%/ in the box.

    If I do nothing more than click the "Save Changes" button, permalinks for the blog will work correctly.

  10. christofire
    Member
    Posted 13 years ago #

    Any ideas, Andrea?

  11. selfmade64856
    Member
    Posted 13 years ago #

    Any luck with this one?

About this Topic

  • Started 13 years ago by christofire
  • Latest reply from selfmade64856