The MU forums have moved to WordPress.org

Sub-Directory Installation Problems (11 posts)

  1. jhartje
    Member
    Posted 13 years ago #

    Hi guys,

    I've been trying to install mu for a week now and am stuck. I've read through the README.txt and am following all steps but still seem to hit the same wall. SPecifically, I'm using sub-directories (not sub-domains) on my server. The install "seems" to complete correctly, but when I try to access blogs which are located outside of wp-admin, I get a 404 error. If I've missed a post that covers this, I apologize. Here's my .htaccess:

    [root@mseli social-net]# cat /var/www/html/social-net/.htaccess

    RewriteEngine On
    RewriteBase /social-net/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    And here's the error I see in my apache log:

    [Sat Feb 21 06:47:48 2009] [error] [client 67.171.70.78] File does not exist: /var/www/html/favicon.ico, referer: http://mseli.mse.cs.cmu.edu/social-net/
    [Sat Feb 21 06:47:51 2009] [error] [client 67.171.70.78] File does not exist: /var/www/html/social-net/blog, referer: http://mseli.mse.cs.cmu.edu/social-net/

  2. andrea_r
    Moderator
    Posted 13 years ago #

    Got mod_rewrite on your server?

  3. SteveAtty
    Member
    Posted 13 years ago #

    And you are running subdirectory in a subdirectory so the urls look like :

    domain/subdir/blogname

    I assume you're doing this because you're shoe-horning WPMU onto an existing website?

  4. jhartje
    Member
    Posted 13 years ago #

    Sorry for the delayed reply - was at school. Yes, mod_rewrite is enabled. Specifically:

    [root@mseli conf]# cat /etc/httpd/conf/httpd.conf | grep -i rewrite
    LoadModule rewrite_module modules/mod_rewrite.so

    For the second question, yes I'm adding this to an existing site. I also have a mediawiki installed that I hope to phase out using wordpress-mu. This is the part where I get a bit confused though. The "main" blog seems to be located at the root of the package (i.e. mseli.mse.cs.cmu.edu/blogs/ ) Is this correct or do I does the mu package assume that all blogs are under a subdirectory?

    Thanks for the quick responses. Much appreciated!

  5. SteveAtty
    Member
    Posted 13 years ago #

    Main blog front page will be at domain/

    Rest of main blog will be at domain/blog/post-name

    Other blogs will be at domain/blogname/ and domain/blogname/post-name

    I run my site in subdirectory mode.

  6. jhartje
    Member
    Posted 13 years ago #

    If it helps, here is an outline of my installation procedure:

    1. Downloaded the latest .tgz of wordpress-mu

    2. Untarred this into /var/www/html/blogs/

    3. chown apache:apache -R /var/www/html/blogs

    4. Created mysql database and associated user (full permissions)

    5. Ran the installer via a web browser. (I choose the sub-dir option)

    6. Logged in as admin.

    All is well. It's when I try to access the default post that I get the 404 error. I can create users, but their blogs yield 404 as well. Basically, any page which isn't in wp-admin or the main domain/blogs/ page, fails. The apache log doesn't point to anything conspicuous...

  7. GeoffreyKOBrien
    Member
    Posted 13 years ago #

    Sounds like you need to look at your httpd.conf file and fix the FileInfo Options line as mentioned in the install instructions.

  8. jhartje
    Member
    Posted 13 years ago #

    This is what I currently have in my httpd config:

    #
    # Each directory to which Apache has access can be configured with respect
    # to which services and features are allowed and/or disabled in that
    # directory (and its subdirectories).
    #
    # First, we configure the "default" to be a very restrictive set of
    # features.
    #
    <Directory />
    Options FollowSymLinks
    AllowOverride FileInfo Options
    </Directory>

    Am I placing the overrides in the wrong place?

  9. jhartje
    Member
    Posted 13 years ago #

    GeoffreyKOBrien

    Thank you!! I think I finally have it fixed. That said, I'm still a bit confused. I ran a full search through the httpd.conf and found:

    321-#
    322:# AllowOverride controls what directives may be placed in .htaccess files.
    323-# It can be "All", "None", or any combination of the keywords:
    324-# Options FileInfo AuthConfig Limit
    325-#
    326: AllowOverride None

    According to the readme:

    2. In the <Directory> directive of your virtual host, look for this
    line
    "AllowOverride None"
    and change it to
    "AllowOverride FileInfo Options"

    I understood this to mean the <Directory /> entry. But it seems that it is the second one in my config file which makes the difference. Can you please explain? I can post the entire httpd.conf if it would help..

    Thanks again for the help!

  10. phipps
    Member
    Posted 13 years ago #

    Hey Steve: Thanks for the overview of where the main blog and sub-blogs are installed. My problem is that in the main blog, all auto-generated links point to my.domain/xyz (for example, my.domain/wp-admin), which does not work. Is there a way to make the main blog stay in my.domain/blog, but have the links work?

    Thx - P

  11. panneer
    Member
    Posted 13 years ago #

    i am having same problem

About this Topic