The MU forums have moved to

MU 2.7 blog not installed properly after initial installation (5 posts)

  1. tekiedude
    Posted 15 years ago #

    I just downloaded the latest release, ran through the installation, a wp-config.php was created and tables were created. After the install is complete and I try to click on the 'login' link, the message I get on my screen is:
    "The blog you have requested is not installed properly. Please contact the system administrator."

    After some digging around, I found that the blog_id in wp_blogs is set to '2' but the tables created are all linked to blog_id '1' (ie. wp_1_*). Setting the blog_id in wp_blogs for site_id=1 to '1' fixes the problem but I'm still unable to login.
    sql command:

    update wp_blogs set blog_id=1 where site_id=1;

    The next thing I had to do was update the option for 'siteurl' in wp_1_options and remove 'index.php' from the option value.
    sql command:

    update wp_1_options set option_value='' where option_name='siteurl';

    Any ideas why this is happening? I think this a bug that needs to be fixed.

    Furthermore, when I create a new blog, register as a new user and then try to login to say, i get a 'too many redirections error' trying to constantly redirect to '' and I'm not sure how to fix that now.

    Here are some relevant wp-config.php entries:

    define('VHOST', 'yes');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', '' );
    define('PATH_CURRENT_SITE', '/' );
    define('BLOGID_CURRENT_SITE', '1' );

  2. jdboer
    Posted 15 years ago #

    I had a similar problem with WordpressMU today when I added a blog, but it was not caused by the same problem. Somehow when creating the blog, the options 'siteurl' and 'home' were not added to the options-table. After I added these manually via phpMyAdmin the new blog worked. No idea why this occured. I have added more blogs before and never had this problem.

  3. SteveAtty
    Posted 15 years ago #

    @tekiedude : Did you enable DNS wildcards and update your webserver config to enable rewrite and wildcard aliases?

    Given the number of WPMU 2.7 installs out there it is not likely to be a bug but something in your configuration

  4. tekiedude
    Posted 15 years ago #

    @SteveAtty - yes, both rewrite rules are enabled and allowed and wildcard aliases are setup in the apache config.

    @jdboer - both of those options are set correctly in the db.

    still having the same problem.

  5. bewst
    Posted 14 years ago #

    I had the same problem today with the latest wpmu (2.9.1). I don't know whether this was the cause, but it happened after this sequence:

    1. Delete a blog using the "delete blog" link at the very bottom of the admin page. Then it tells me I need to answer a confirmation email to get it deleted.

    2. Instead of answering the email, go to the WPMU site admin area and delete the blog as site admin, which is immediate.

    3. Go back and recreate the blog. Then I get "The blog you have requested is not installed properly. Please contact the system administrator."

About this Topic