The MU forums have moved to WordPress.org

2.7 upgrade headache. (7 posts)

  1. horrorshow
    Member
    Posted 13 years ago #

    I am getting the following error on my site after the upgrade to 2.7 (from 1.5.1): http://achillesblog.com

    Can't leave comments, sign-up for blogs.

    It might be due to the memory limit, which I am aware can be set in wp-config.php, but that doesn't help. Also, unless new release has become a memory hog, I don't see why it would require much more memory all of a sudden. I haven't changed my hosting serice, php.ini config, etc.

    Any help would be greatly appreciated. I've been trying to track down upgrade issues for the past 6 hours, and I am running out of steam.. :(

    Just might go back to 1.5.1 and just stay put.

    Warning: Cannot modify header information - headers already sent by (output started at /home/valuemav/public_html/achillesblog/wp-settings.php:4) in /home/valuemav/public_html/achillesblog/wp-content/plugins/wp-ajax-edit-comments/wp-ajax-edit-comments.php on line 754
    
    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/valuemav/public_html/achillesblog/wp-settings.php:4) in /home/valuemav/public_html/achillesblog/wp-content/plugins/wp-ajax-edit-comments/wp-ajax-edit-comments.php on line 755
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/valuemav/public_html/achillesblog/wp-settings.php:4) in /home/valuemav/public_html/achillesblog/wp-content/plugins/wp-ajax-edit-comments/wp-ajax-edit-comments.php on line 755
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/valuemav/public_html/achillesblog/wp-settings.php:4) in /home/valuemav/public_html/achillesblog/wp-comments-post.php on line 79
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/valuemav/public_html/achillesblog/wp-settings.php:4) in /home/valuemav/public_html/achillesblog/wp-comments-post.php on line 80
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/valuemav/public_html/achillesblog/wp-settings.php:4) in /home/valuemav/public_html/achillesblog/wp-comments-post.php on line 81
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/valuemav/public_html/achillesblog/wp-settings.php:4) in /home/valuemav/public_html/achillesblog/wp-includes/pluggable.php on line 856
  2. andrea_r
    Moderator
    Posted 13 years ago #

    Did you do incremental upgrades or just go straight to 2.7?

    And all those messages mean there's some blank lines at the end of files.

  3. horrorshow
    Member
    Posted 13 years ago #

    andrea_r: I was too brave, this time. foolishly. :( I went straight from 1.5.1 to 2.7. I wanted to be a rockstar, but I am not! :) Which files are you referring to..?

  4. horrorshow
    Member
    Posted 13 years ago #

    andrea_r,
    Also, would I have avoided this problem if I upgraded 1.5.1 to 2.6 and then 2.6 to 2.7? Thanks for your help! I am sure the AchillesBlog community appreciates your help as well. I'll be sure to give you a loud standing applause on AchillesBlog once I've resolved this issue.

  5. andrea_r
    Moderator
    Posted 13 years ago #

    Yes, upgrading in one big jump like that does fun things.

    "Warning: Cannot modify header information " these messages have files mentioned. those ones.

  6. horrorshow
    Member
    Posted 13 years ago #

    FYI, this was fixed after wp-settings.php's extra lines at the beginning of the file were removed. thanks andrea_r

  7. rudy3107
    Member
    Posted 13 years ago #

    i upgraded from 1.3.1 to 2.7 and its working fine [ http://mynation.net ]

    and another site i upgraded from 1.3.1 to 2.6 wihtout any step in between [ http://supari.org ]

    but 2.6 is faster than 2.7, and 2.7 started to creat errors for many plugins.which forced me upgrade or delete.

About this Topic

  • Started 13 years ago by horrorshow
  • Latest reply from rudy3107