The MU forums have moved to WordPress.org

WPMU broken after moving to OS X Server (7 posts)

  1. wfairchild
    Member
    Posted 13 years ago #

    I am in the process of moving my WPMU site over to an OS X Server from linux. I desperately need to upgrade (it is currently version 1.0) it but initially just wanted to get it running on the new arch.

    I moved over the wpmu directory and copied the database into MySQL on the OS X box.
    The main page comes up properly, and even the admin pages work fine. I can edit and delete posts that were made on the old server but it will not display any of the blogs that were on the old server. It lists them, but I can't view them. It will always give an "Object not found!" Error 404. This is for any linked page except for the "action" pages in the admin section such as "write a new post".

    So if you go to http://www.example.com/wpmu/wp-admin, everything looks as it should, and if you want to write a new post, it will work fine, but if you want to go to http://www.example.com/wpmu/myBlog it will not find it.

    It seems like something went wrong in the database import to me but I'm fairly new to this type of migration. Thanks in advance for any ideas.

  2. wfairchild
    Member
    Posted 13 years ago #

    It doesn't seem to be mapping the blog_id to the path correctly, but I don't know where to look to repair it...

  3. wfairchild
    Member
    Posted 13 years ago #

    It seems like this post gets closest to my problem:
    http://wordpress.org/support/topic/158680?replies=5

    but none of these seem to solve it.

  4. VentureMaker
    Member
    Posted 13 years ago #

    Did you try to switch to standard 'ugly' permalinks? Does it work?

  5. wfairchild
    Member
    Posted 13 years ago #

    Thanks VentureMaker! Yes, I did, but it still didn't work. What helped me out was that I created a totally new blog with a fresh database and it did the same (no secondary blogs in subdirectories) thing, so then I knew that the problem was with my server config and not wordpress.

    In OS X there there are all these different httpd.conf files scattered around. In the very bottom of my main httpd.conf it listed several other places where it reads configuration information for Apache from. In there it still had AllowOverride None in the <Directory></Directory> section. It seems like that's all it was.

  6. VentureMaker
    Member
    Posted 13 years ago #

    I've got no experience with OSX :(
    Anyway, make sure that you enable mod_rewrite for apache.

  7. GeoffreyKOBrien
    Member
    Posted 13 years ago #

    you need to manually modify the site's config file, and dont use the gui. I had this issue, modifying the conf file manually to add the appropriate changes fixes the issue.

About this Topic

  • Started 13 years ago by wfairchild
  • Latest reply from GeoffreyKOBrien