The MU forums have moved to WordPress.org

Domain mapping and sevage.net (10 posts)

  1. Hassan1
    Member
    Posted 13 years ago #

    Hi-
    My WPMU[subdomain] hosted on servage.net[share] and everything is great but domain mapping.

    Now domain DNS is the same that server is.I added domain via Tools->Domain Mapping,too.but it doesn't work.

    After lots of search I understood that CPanel admins should addon the domain. but what about non-cpanel servers?
    Is there any servage user here?
    How wordpress.com do all of this process automatically?

    I think this great plugin should have a better documentation.

    Thanks!

  2. Trent
    Member
    Posted 13 years ago #

    However you do it on your host, you have to put the domain to point at the same folder as your wpmu install. Once you know the domain is pointing there, then the plugin will pick up the domain mapping settings, but not before. I just put my wpmu install vhost as the first entry in my httpd.conf and it picks up all the requests that don't have a vhost specific for it.

  3. selad
    Member
    Posted 13 years ago #

    Trent, can you please explain what you have done in the httpd.conf? Is it like a wild card for domains?

  4. Trent
    Member
    Posted 13 years ago #

    If you use an * for your name virtual hosts, it picks up all requests that are not defined in other virtual hosts. EG:

    NameVirtualHost *:80
    
    <VirtualHost *:80>

    If you use that kind of VirtualHost, it works. You can have others, but if the WPMU install is defined first, it works. At least it does for me.

    Trent

  5. Hassan1
    Member
    Posted 13 years ago #

    Thank you Trent for your great reply.

    Maybe some useful information:
    http://httpd.apache.org/docs/1.3/dns-caveats.html

    As a shared host admin I haven't access to Apache config file. Can I add the code to htaccess? If I can then there's another problem. What will happen for other sites in the server (or with same shared IP)?

  6. VentureMaker
    Member
    Posted 13 years ago #

    Best bet would be to contact your hoster and ask to setup wildcard DNS for your domain :)

  7. Hassan1
    Member
    Posted 13 years ago #

    @VentureMaker I think DNS wildcard installed because subdomain works correctly.

  8. VentureMaker
    Member
    Posted 13 years ago #

    Sorry, expressed myself wrong :) Happens, I'm out of coffee today.

    You, you've got WPMU with subdomains option and domain mapping. You say you added another domain in domain mapping settings.
    1. Did you specify your IP in domain mapping settings?
    2. Did you add A record for the mapped domain pointing to your IP?

  9. Ovidiu
    Member
    Posted 13 years ago #

    the plugin works like this:

    if your vhosts are set up like pointed out above: <VirtualHost *:80> every domain pointing at your server will be caught but if you don't have such a * vhost, you have to manually point/park/whatever the domain towards your wpmu install.

    above you ask what about non-cpanel users?

    what control panel is your hosting provider offering you? you must have one. it doesn't matter which one you still must point the domain towards your wpmu install.

    how does wordpress.com do it?
    well, you being on a shared host, share your IP with other users so if someone redirects his domain towards your IP, how would your host know that it should point towards your wpmu install and not the other guys wpmu install on the same shared host?
    see? wordpress.com does only host wordpress.com on their servers so they can by default point unknown domains towards their only domain...

    you on the other hand, must manually point the domain towards your wpmu install,

    ###pretty simplified, but it should convey the bigger picture###

  10. Hassan1
    Member
    Posted 13 years ago #

    Thanks all for useful replies.

About this Topic