The MU forums have moved to WordPress.org

"Error! Options page not found" - a frequent problem (13 posts)

  1. josswinn
    Member
    Posted 15 years ago #

    Recently, when trying new plugins, I seem to be getting: Error! Options page not found. It's happening on WPMU but not WP. I'm guessing that the plugins require just a slight modification to work correctly. Is it wp_nonce related? Does anyone know of a fix that might work?

    Thank you

  2. josswinn
    Member
    Posted 15 years ago #

    I think this page on the Codex is the answer to my question. Now, if only I understood it :-)

    It looks like all plugins are going to have to adopt the new security approach which WPMU has lead the way with.

    http://codex.wordpress.org/Migrating_Plugins_and_Themes_to_2.7#Plugins

  3. VentureMaker
    Member
    Posted 15 years ago #

    Would be good to know what plugin is causing this error in WPMU and how you fix it ;)

  4. josswinn
    Member
    Posted 15 years ago #

    The plugin causing the error (on this occasion) is TweetMeme: http://wordpress.org/extend/plugins/tweetmeme/

    I've not fixed it. At some point, the plugin author themselves will have to make it work with newer versions on single install WP, which is following WPMU in plugin security by the looks of things.

  5. tfbpa
    Member
    Posted 15 years ago #

    If you want a quick, dirty and temporary solution upload the .../wp-admin/options.php from the NORMAL Wordpress into your MU .../wp-admin/options.php, update your plugin and then upload the original MU .../wp-admin/options.php again.

  6. komozi
    Member
    Posted 14 years ago #

    thanks for the tip !
    calii slideshow is working now on it but I'll try to improve the original plugin for mu soon ...

  7. GwynethLlewelyn
    Member
    Posted 14 years ago #

    A good way to patch WP plugins that have this issue is to follow this tutorial.

    I managed to get CR Post to Ping.fm working that way.

  8. selfmade64856
    Member
    Posted 14 years ago #

    There is a simple 1 minute fix for this now located here:

    [link removed]

    Hope this helps!

  9. tdjcbe
    Member
    Posted 14 years ago #

    Someone else has already marked this as modlook but I'm still calling BS on this. Not cool that you ask for a tutorial and handholding and then spam your link for your paid service.

    There's about 4 or 5 posts with this link. I hope you find them all, Donncha.

  10. selfmade64856
    Member
    Posted 14 years ago #

    touché.... too late to back pedal though isn't it :P. My apologies, however just because I asked for a video about another matter that was turned away http://www.binarymoon.co.uk/2009/10/timthumb-wordpress-mu/comment-page-1/#comment-24046 there should be no reason that I cannot find a solution to a different problem and if I so choose charge a small fee for something that works. Maybe I'm wrong.

    I do however now understand that maybe I should not have spammed my solution all over the place. My excuse is that I got greedy, I was thinking about Hawaii :)

  11. donncha
    Key Master
    Posted 14 years ago #

    The correct solution is to contact the plugin author and tell them they have to update their plugin to use the new whitelisted options in MU as that will become the standard in WP too.

    There's a HUGE GIGANTIC SECURITY HOLE leaving the options page from WordPress on a WordPress MU site. Really. Your users will be able to change any setting in your options table that they like.

    So please, contact the plugin author and give them this link. Encourage them to update their plugin. If you must pay someone, pay the original author of the plugin.

  12. SteveAtty
    Member
    Posted 14 years ago #

    Oddly enough Donncha - that post contains a hard coded form action="options.php" which certainly doesn't work in subdirectory mode - where you seem to need "./options.php"

  13. SteveAtty
    Member
    Posted 14 years ago #

    Actually its something odd - you get the options page not found error if you've not got things quite right in the form. I don't know what I did but its working now.

About this Topic

  • Started 15 years ago by josswinn
  • Latest reply from SteveAtty