The MU forums have moved to WordPress.org

Upload Image Problems (11 posts)

  1. dadevr
    Member
    Posted 13 years ago #

    I have some problems to upload image in my WPMU account. The images are currently stock in "blogs.dir" directory but the rewrite rules in htaccess don't need to view the images in the browser.

    I used the standardt .htccess, like this:
    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

  2. VentureMaker
    Member
    Posted 13 years ago #

    Can you explain what is the problem you have?

  3. dadevr
    Member
    Posted 13 years ago #

    When view a post in my browser (such as IE or FF) the image are located in http://www.mywebsite.com/files/2009/03/image.jpg but isn't display in the monitor.

    All images are correctly stored in "/wp-content/blogs.dir/"

    The path is right becouse are regolated by .htaccess file rules.

    But I dont't find where is the problem!

  4. VentureMaker
    Member
    Posted 13 years ago #

    This is not a problem, this is default WPMU behavior.

  5. lamont
    Member
    Posted 13 years ago #

    VM, I'm encountering the same problem. The images are in their correct subfolder under /wp-content/blogs.dir/, but the file path in the post is not showing the image. From another thread, I tried this url: http://mywebsite.com/MU_dir/blog3/wp-content/blogs.php?file=/2009/03/image.jpg and the image is displayed. But the path in the post, http://mywebsite.com/MU_dir/blog3/files/2009/03/image.jpg does not.

    There has been a lot written in threads about .htaccess code. My htaccess is the default, nothing changed. I've removed code from htaccess to test with no change. I've ck'd the options for each blog, paying attention to the upload urls, etc. but have found nothing to get the images to display.

    Any pointers?

  6. VentureMaker
    Member
    Posted 13 years ago #

    Actual URL to your website might help :)

  7. andrea_r
    Moderator
    Posted 13 years ago #

    Did you check any options in cpanel to block hotlinking? Because that will interfere.

  8. lamont
    Member
    Posted 13 years ago #

    Thanks VM & andrea_r for the comebacks. It must have been a cache thing because the next day the images were showing up and it seems to be working fine with new image uploads. Sure caused me to lose several hours of time researching and a sleepless night. Now, all seems well.

  9. dsalon
    Member
    Posted 13 years ago #

    Actually we also have image upload problems via the

    http://wpmudomain.net/wp-admin/media-new.php

    whereby the upload is very very slow and it appears that there is possibly caused an endless loop...

    However via the

    http://wpmudomain.net/wp-admin/media-upload.php

    which is accessible via a button above the edit post / page editor everything works fine...

    We would be happy if someone may have noticed similar problems and may have found a solution.

  10. VentureMaker
    Member
    Posted 13 years ago #

    there is possibly caused an endless loop...

    If there's a loop your error log should have something in it.

  11. irwnsyh
    Member
    Posted 13 years ago #

    same problem on me. I have read much topic at this forum n zero result. I was frustation. But, finally I am succes with this way.
    I try install wp-mu 2.6 first and then follow Upgrading WPMU at http://codex.wordpress.org/Upgrading_WPMU.
    it's worked for me and have no problem with uploding image.

About this Topic