The MU forums have moved to WordPress.org

broken links after install? (9 posts)

  1. ccnyctl
    Member
    Posted 18 years ago #

    HI,

    I was able to successfully install and recieved an email for login.

    Dear User,

    Your new blog has been successfully set up at:
    http://ctl.ccny.cuny.edu/blog/

    You can log in to the administrator account with the following
    information:
    Username: admin
    Password: ******
    Login Here: http://ctl.ccny.cuny.edu/blog/wp-login.php

    We hope you enjoy your new weblog.
    Thanks!

    --The Team @

    However, the link results in a file not found (404) error. wp-login.php is actually located in the "wp-inst" folder inside my wpmu follder, which I renamed to "blog" and put into the public folder of the webserver. As I am running on OS X (10.4.6) Server, the full paths for the wpmu install and file in question are,

    /Library/WebServer/Documents/ <== Root Public Folder for WebServer in OS X
    /Library/WebServer/Documents/blog <== Wpmu Folder renamed to "blog"
    /Library/WebServer/Documents/blog/wp-inst/ <== a subfolder that is part of the wpmu installation when the downloaded file is decompressed.

    The trouble I have with "File not found" seems to stem from the link, not only in the email sent by wordpress but also the links on different php pages when I type in the absolute path into the webrowser's URL window.

    To access the login, I added "wp-inst" and "wp-admin" to the path sent me in the email.

    http://ctl.ccny.cuny.edu/blog/wp-inst/wp-admin/index.php

    But the result is unsatisfactory as every links are broken, anywhere I click once I logged in the login page!

    Also, my index.php in my blog root directory (one level above wp-inst) keeps serving the wpmu install page. I'm not sure what to do!

    All help is appreciated, but I'd especially like to hear from anyone running MU on an OS X Tiger Server.

    Thanks,
    ccnyctl

  2. samchng
    Member
    Posted 18 years ago #

    If you are running the latest build, you have to install MU into the root directory and not a subdirectory eg. blog. Also is mod_rewrite available for apache?

  3. ccnyctl
    Member
    Posted 18 years ago #

    Hi,

    I'm running the 4-17-2006 build (it was recommended as a stable release in a thread). mod_rewrite is available and on in my apache server (os x 10.4). I modified the httpd.conf file for that and can see that the module in my os x server config interface.

    I think I did install Mu into the webserver's root directory (/Library/WeServer/Documents -> os x's "public_html" directory). A "wpmu" directory was created there in the webserver's root. I later renamed the directory to "blog" so that I can access it by going to http://ctl.ccny.cuny.edu/blog (instead of ctl.ccny.cuny.edu/wpmu).

    Should I have not renamed the directory from wpmu to blog? I'm confused, and after having read some threads on 404 errors: stuff about .htaccess rewrite rules, I'm not sure if the rewrite rules are screwed or my directory structure is screwed.

    Any Help is much appreciated!

  4. pscblog
    Member
    Posted 18 years ago #

    no what they are saying is that the index.php file should reside in http://ctl.ccny.cunny.edu/ and the wp-inst would then look like http://ctl.ccny.cunny.edu/wp-inst that is the root directory.

  5. ccnyctl
    Member
    Posted 18 years ago #

    I think I now see what you meant, pscblog. I should move all the content of the "wpmu" directory into the webserver's root directory. However, there is one thing that prevents me from doing this. Pages to my main website resides at http://ctl.ccny.cuny.edu.The web server is not exclusively used for hosting blog service. That's why I wanted to have the blog be reached at http://ctl.ccny.cuny.edu/blog instead ("blog" being the "wpmu" directory renamed).

    Is there any other way around this problem? I've been looking at the .htaccess file I find in the "wpum" directory (one level above the "wp-inst" directory) and it seems that if it works, it should rewrite URL requests to the right sub-directory location for requested file, e.g., http://ctl.ccny.cuny.edu/blog/wp-login.php should be rewritten to http://ctl.ccny.cuny.edu/blog/wp-inst/wp-login.php (which serves me the login page when i manually type this into the url address bar in my browser).

    Could it be that the rewriting is failing? Or that I must dump the entire content of the "wpmu" directory into my webserver's root directory for it to work?

  6. samchng
    Member
    Posted 18 years ago #

    Does all yoru rewrites have a /blog/ in front.
    Eg.
    RewriteRule ^([_0-9a-zA-Z-]+)/templates/(.*) /blog/wp-inst/wp-content/blogs/$1/templates/$2 [L]

  7. ccnyctl
    Member
    Posted 18 years ago #

    Samchng, all my rewrites in .htaccess in the "blog" directory have a /blog/ in front.

    RewriteRule ^(_0-9a-zA-Z-]+)/templates/(.*) /blog/wp-inst/wp-content/blogs/$1/templates/$2 [L]

    and so on.

    I'm not sure if there is something wrong with the .htaccess file or my apache server, or a file permission thing in Unix (OS X).

  8. ccnyctl
    Member
    Posted 18 years ago #

    Hi All, it seems it was a .htaccess issue alright. However, the root culprit was the apache settings on my Mac OS X (10.4.6) server.

    For all those who wish to install wpmu on your Mac OS X Server (10.4.x), you need to-- in addition to the modifications suggested in the Readme.txt file--add a <Directory> section in your httpd.conf file (/private/etc/httpd/httpd.conf).

    An example would go like this:
    <Directory "/Library/WebServer/Documents/wpmu">
    Options FollowSymLinks
    AllowOverride FileInfo Options
    Allow for all
    </Directory>

    If you don't--even if you have the FollowSymLinks and AllowOverride lines enabled for the "root" directory, the apache on your OS X Server won't read the .htaccess file inside your wpmu directory (and subdirectories). You will get a bunch of "File not found" / 404 errors due to broken links (being the links for wpmu are rewritten to the actual location of the files on your file system).

    After all the monkeying, I would really like to share this tip to all wpmu on Mac OS X Server (10.4.x) users out there.

    For now, my wpmu installation is working at last (HAPPY DAY!) at
    http://ctl.ccny.cuny.edu/blog

    I've yet more work to do, setting up blogs on the thing. I hope there will be more configuring and less hacking from here on (touch wood).

    Thanks to all for your suggestions in solving the problem I'd been experiencing, although I might not have taken some (dumping all of wpmu into the web server's root was not an option for me. Plus, it now seems unnecessary as .htaccess redirects requests to where they ought to go).

    One happy wpmu installation camper,
    ccnyctl

  9. surfacescan
    Member
    Posted 17 years ago #

    Hi all - just wanted to thank ccnytl for the work and add on a discovery I made about working under Mac Server OS 10.4

    I wanted to put my WPMU in the root directory "Library/WebServer/Documents" and it would not resolve any urls that were not physical files (ie wp-login.php etc)

    For example: http://yourdomain.tld/blog/2006/11/06/hello-world/

    Would throw a 404 error. I had to change some settings in this file here:


    /etc/httpd/sites/0000_any_80_.conf

    I changed AllowOverride none to AllowOverride FGileInfo Options as below:


    <Directory "/Library/WebServer/Documents">
    Options All -Indexes +MultiViews -Includes -ExecCGI
    AllowOverride FileInfo Options
    <IfModule mod_dav.c>
    DAV Off
    </IfModule>
    </Directory>

    Hope this saves someone some time... now if I can just get the subdomains working

About this Topic

  • Started 18 years ago by ccnyctl
  • Latest reply from surfacescan