The MU forums have moved to WordPress.org

Is there any workaround for WWW (6 posts)

  1. vihervaara
    Member
    Posted 13 years ago #

    I've installed WPMU to two servers now and I just cant get it work when the site has subdomain "www". With an other subdomain everything is just rolling fine, butwhen I need to install it to www-subdomain, it just doesn't work – "The requested URL /blogs/ was not found on this server".

    So is there any workaround to this problem? Other subdomain or stabbing the httpd.conf aren't right answers.

    TIA

    P.S. Can someone explain me, what is the bright idea to treat www differently than the other subdomains.

  2. SteveAtty
    Member
    Posted 13 years ago #

    WPMU isn't designed to work with www in the url. What do you mean about treating www differently than other subdomains? Do you mean why does WPMU not use it and why you can't create a blog called www?

    IF you are running in subdirectory mode then you can install on a non http://www.domain.com address and then add ServerAlias http://www.domain.com to your apache config file which means that http://www.domain.com/blog automatically gets redirected to domain.com/blog.

    A lot of people get hung up on www not being there for some reason.

  3. andrea_r
    Moderator
    Posted 13 years ago #

    Sometimes people are stuck becasue of the server setup.

    http://wpmututorials.com/hacks/forcing-mu-to-use-www/

  4. roberthq
    Member
    Posted 13 years ago #

    Andrea,

    Sometimes people are stuck becasue of the server setup.

    http://wpmututorials.com/hacks/forcing-mu-to-use-www/

    That link is out of date and no longer works in wpmu 2.8.4 as no code like that in the wp-settings.php file.

    I'm on page 18 and still no chance of sorting out my original problem...found here...I'll get to page 80...some day!

    http://mu.wordpress.org/forums/topic/14501?replies=3#post-83637

  5. andrea_r
    Moderator
    Posted 13 years ago #

    Yep, I know. Code changes that fast sometimes.

  6. rsgrone
    Member
    Posted 13 years ago #

    I ran into the same problem and can be resolved if you have access to the "bindings" on your server (if you have a server)

    There is one simple question to answer before you can proceed:
    Do you provide your own DNS or is the DNS provided by your hosting provider?

    For example (and I am a Microsoft person) if you edit the bindings on the default web you are using, for example, simply remove and portion of the binding that references the http://www.foo.com and simply use the protocol "http", "IP address", and Port "80" DO NOT ADD THE http://WWW.FOO.COM to the bindings. This will allow your hosting provider to the domain name resolution for you.

    IF, you provide your own DNS then you will have to edit the bindings in the A table to reflect both http://WWW.FOO.COM and FOO.COM for the proper DNS resolution to your IP address.

    How can you tell quickly?

    If during your install, http://www.foo.com appeared in the field right below I the MySQL table setting [wp_], then you have your local DNS bindings set, change them.

    If in that same step your IP address 10.10.10.1 (for example) and 10.10.10.1 appeared in the field for the name of your blog, then you will need to check with your hosting provider regarding your DNS bindings,

    Now, (these do get windy, I'm a network engineer by trade, not a wordpressmu guru, but this fixed my problem) if you check with your hosting provider and they tell you they handle the DNS for you, or have set it to your private domain, you must ask them how to edit the" A" record... with Microsoft it easy to do.... Don't let them give you the run-a-round regarding this simply allow them to handle the DNS for you and have them make the changes....

    If you are your own DNS provider (running DNS servers) then you'll need to edit your own DNS records to reflect the http://www.foo.com and foo.com to bind to your IP address... that is the ONLY fix for DNS settings...

    email me if you're confused....

About this Topic

  • Started 13 years ago by vihervaara
  • Latest reply from rsgrone