The MU forums have moved to WordPress.org

No images at all (4 posts)

  1. dayfalljesse
    Member
    Posted 8 years ago #

    I have been up, down and over these forums, and no post has helped me figure out the image upload problem.

    when I upload an image, it does in fact upload to the ftp.
    However, when Wordpress spits out the path to in for the frontend, it doesnt work.

    Here is my htaccess settings:
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    Here is my Options settings in the MU Backend:
    upload path: wp-content/blogs.dir/3/files
    upload url path:http://www.enticentsupport.com/wp-content/uploads
    fileupload url:http://enticentsupport.com/best-practices/files

    Here are the wp-settings.php
    if( !defined( "UPLOADBLOGSDIR" ) )
    define( "UPLOADBLOGSDIR", 'wp-content/blogs.dir' );

    if( !defined( "UPLOADS" ) )
    define( "UPLOADS", UPLOADBLOGSDIR . "/{$wpdb->blogid}/files/" );

    if( !defined( "BLOGUPLOADDIR" ) )
    define( "BLOGUPLOADDIR", WP_CONTENT_DIR . "/blogs.dir/{$wpdb->blogid}/files/" );

    Any help/light/devastating revelations so i can stop pulling my hair out would be great.
    Thanks!

  2. tdjcbe
    Member
    Posted 8 years ago #

    Let's please start off with a specific link so we can see what's occurring. I'm flipping through your site but don't see any posts with broken images. It's always a plus to provide a link so that folks can see what's happening.

    Also have you checked the webserver's error logs?

    You may want to review the debugging page the readme file links to. I know it's frustrating but both of those items I've asked for are mentioned in that file while the information you provided isn't.

    http://codex.wordpress.org/Debugging_WPMU

  3. dayfalljesse
    Member
    Posted 8 years ago #

    Here is a direct link to a page with a broken image:
    http://enticentsupport.com/best-practices/audience-appointments/?preview=true&preview_id=98&preview_nonce=fddba4271d

    There is nothing in the error logs, because im not getting an error. It is upload the file, and the file is in fact in the ftp. But Wordpress isnt linking it correctly.

  4. andrea_r
    Moderator
    Posted 8 years ago #

    "upload url path:http://www.enticentsupport.com/wp-content/uploads
    fileupload url:http://enticentsupport.com/best-practices/files"

    See that? Two different URLs there. Take the WWW out of the top one.

About this Topic

  • Started 8 years ago by dayfalljesse
  • Latest reply from andrea_r