The MU forums have moved to WordPress.org

2.7.1 auto upgrade (18 posts)

  1. bschwarting
    Member
    Posted 13 years ago #

    When I run the auto upgrade from 2.7 I get this:

    "Connection Information

    To perform the requested action, connection information is required."

    According to Donncha it's supposed to auto upgrade. This a bug?

  2. KennethJ
    Member
    Posted 13 years ago #

    Dont know if its i bug, but im kinda unsure what information to fill in..

    A description would have been helpfull.

  3. donncha
    Key Master
    Posted 13 years ago #

    bschwarting - that's ftp connection information for your server. It's the same way WP upgrades and ensures that the fiels on your server are owned by your user rather than the web server.

  4. Ovidiu
    Member
    Posted 13 years ago #

    can't believe it. clicked the auto upgrade and 30 seconds later I am running 2.7.1!!!! good work donncha!

  5. bschwarting
    Member
    Posted 13 years ago #

    ok, that makes sense donncha, tks.

    i'm on a VPS, curious as to what others on VPS are using for their login/pass info for auto upgrade?

    I use root for most everything, and don't want to use it since I have multiple domains on this box.

  6. andrea_r
    Moderator
    Posted 13 years ago #

    It should be the ftp info. Even on a VPS, you should be in a separate web account.

    unless your mu install is in the root account and not a virtual host...

  7. kgraeme
    Member
    Posted 13 years ago #

    You shouldn't be installing or running stuff as root. Basic security. Generally you'll want to install using an account that has apache privileges.

    For what it's worth, the auto-upgrade won't work for me either because we use svn to install our software. Our individual user accounts don't even have privileges. If we ftp stuff to the server we have to chown it to the account with privs for it to run under apache. Again, for security reasons.

    The auto-upgrade is really designed for the typical hosting environment where the account they give you for ftp is the account you'll run wpmu under.

  8. bschwarting
    Member
    Posted 13 years ago #

    kgraeme, what is the best way to setup an account that does have privileges to do the auto upgrade?

  9. kgraeme
    Member
    Posted 13 years ago #

    I don't know about the best way, but since you mentioned that you have multiple domains, you could create an account for each domain. Give that account the same group privs as apache. Use that account for installing the software. And then that account is what you use for the auto update ftp information.

  10. bschwarting
    Member
    Posted 13 years ago #

    ok, now I'm getting:

    Downloading update from http://mu.wordpress.org/wordpress-mu-2.7.1.zip

    Unpacking the core update

    Could not copy files

    Installation Failed

  11. croif
    Member
    Posted 13 years ago #

    I run WPMU 2.7 and I it doesn't show me any option to upgrade to the new version.
    I mean it is supposed to announce me that there is a new version in place, or am I doing something wrong here?

  12. bschwarting
    Member
    Posted 13 years ago #

    croif, it should show up in your dashboard, at the top in yellow, when logged in as site admin.

  13. bschwarting
    Member
    Posted 13 years ago #

    anyone have an idea on my error?

    "Could not copy files

    Installation Failed"

  14. andrea_r
    Moderator
    Posted 13 years ago #

    Permissions/ownership issues is my guess.

  15. kgraeme
    Member
    Posted 13 years ago #

    If you originally installed the files as root and then created accounts like I mentioned, you might need to chown the existing install to the new account.

    Be sure the new account has apache rights or your entire site will likely stop working.

  16. bschwarting
    Member
    Posted 13 years ago #

    Unpacking the core update

    Verifying the unpacked files

    Installing the latest version

    Upgrading database

    WordPress upgraded successfully

    :)

  17. bschwarting
    Member
    Posted 13 years ago #

    for others looking for help, this is what I did:

    #1) Made a backup :)
    #2) gpasswd -a yourftpuser apache (add your FTP user to the apache group)
    #3) chown -R yourftpuser:apache /var/www/vhosts/domain.net/httpdocs (change all wordpress files to your FTP user as owner of the files and then to the apache group)

    thanks to all who pointed me in the right direction!

  18. croif
    Member
    Posted 13 years ago #

    Thanks bschwarting!
    The link showed up today finally. Now upgrading! Hope all works well or I will have to upgrade manually!

About this Topic

  • Started 13 years ago by bschwarting
  • Latest reply from croif