The MU forums have moved to WordPress.org

404 not found on site pages after upgrade to 2.7.1 (12 posts)

  1. rrijke
    Member
    Posted 15 years ago #

    I just upgraded to 2.7.1 and i'm having problems with my links. Using the postname as a link (like i always did) i get a 404 not found page. Setting it to standard (postid) does work but this is no what i want.

    I checked if mod_rewrite is on. It is. Checked error log on server too. Nothing reported after the wpmu upgrade.

    I saw a few posts in this forum but not what I'm looking for. Is there something new in this upgrade that I am overlooking?

  2. donncha
    Key Master
    Posted 15 years ago #

    That's odd. Go into the permalinks page and save the permalinks settings again?

  3. rrijke
    Member
    Posted 15 years ago #

    Yup!.. I tried all the possible permalink settings. Still no luck.

  4. tdjcbe
    Member
    Posted 15 years ago #

    Can we get an example link please? Also what specifically is appearing in the webserver's error logs?

  5. Nimwit
    Member
    Posted 15 years ago #

    I had this issue with Wordpress (not MU) in the past while hosted at DreamHost.com, but only in admin pages. I had to add a few lines to the .htaccess file to specify error pages. I can't remember what those lines were now but the following link details the same issue I had:

    http://wordpress.org/support/topic/252861?replies=2

  6. tdjcbe
    Member
    Posted 15 years ago #

    Um, I think the poster is trying to stop the 404's, not send visitors to 404 pages.

  7. takuya
    Member
    Posted 15 years ago #

    Similar things happened twice today. Just all in sudden all my blogs' posts went 404. But once I login wp-admin, they got fixed. Not a cookie problem, as I used two different browsers for login and just viewing.

    Maybe some kind of bug of 2.7.1? But I can't reproduce it...I don't know if it happens again or not.

  8. re5et
    Member
    Posted 15 years ago #

    I am experiencing the same issue, but it is only on the main blog, the several others I have are functioning as expected. Is this some kind of useful clue?

    I haven't determined if this is related, but in the admin, it is still showing "WordPress MU 2.7.1 is available!" in my admin although it definitely thinks that I am upgraded elsewhere (the meta generator, showing in the footer, my admin bar is gone).

    This is quite a problem and I have no idea how to approach troubleshooting it.

  9. andrea_r
    Moderator
    Posted 15 years ago #

    Did you go to Site Addmin -> Upgrade and click the button?

  10. tlehman
    Member
    Posted 15 years ago #

    I had the same issue suddenly with one of my projects. After reading this and reviewing everything I did during the day, it seems there was a conflict with the permalink settings, which was verbose ex. http://www.site.com/gallery/ and a file that was uploaded to the root by accident, called gallery.php. Once I pulled this file from the root, it corrected the 404 issue, which was not a wordpress 404, but a server 404.

    Hope that helps in some way.

  11. focusplane
    Member
    Posted 15 years ago #

    I had the same problem.
    After I followed the instructions on http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks for my apache configuration, it is now working.

  12. amskape
    Member
    Posted 14 years ago #

    Hello pals,

    I Install Wordpress MU as You Directed Here. Installation is Success,
    But When I create a user Blog eg: it's name is firstone then the
    url is : http://localhost.localdomain/wpmu/firstone/ But when I visit this page I got a 404 page Not Found Error. How it can Avoid? As an Experience I copy all files in /wpmu installation Folder to this /wpmu/firstone folder. Then I got the page, but When I click some
    links like Comment , I got another page Not Found 404 Error.

    Sir , please Give a Work arounf for it .... I know Copy the Content to
    new folder is not a Solution..... I am working in Red Hat Linux Fedora
    Core 8 PC .... ok I am waiting your Reply... Kindly give a Solution as Early as Possible.....
    You can contact me : anes.pa@amskape.com

    With Great Regards
    Anes P.A

About this Topic