The MU forums have moved to WordPress.org

Another SubDomain question, I thought I was almost done? (14 posts)

  1. Dirt2
    Member
    Posted 13 years ago #

    So for the last few days I've got the runaround from my hosting and domain registrar who were telling me to ask the other company to do the DNS change that wordpress requires in order to run the subdomain blogs. So.. Finally name.com said they had made the change, so I am thinking "Okay so now it should work?"

    So I load up a subdomain blog and I was glad to see there is no longer an error but... Instead it says "There is no website configured at this address" with some of my host's links and stuff?

    http://andrew2.contentshops.com/

    I checked with bluehost support and it says they have mod_rewrite enabled, name.com assures me that the DNS issue was taken care of (Maybe it hasn't fully finished? Does it take a day or so to function?) so what am I missing?

    I've looked on wordpress for similar problems already and I hate to contribute to the help, it's just a difficult install compared to the usual wordpress install.

    Thank you, Andrew

  2. SimonJ
    Member
    Posted 13 years ago #

    As we can see folowing your link, you seem to have Cpanel on your server.

    [1] Log in to your cpanel

    [2] Go to subdomain

    [3] Create a subdomaine with the name *
    (*.contentshops.com)

    Hope this helps.

    S.

  3. vlm
    Member
    Posted 13 years ago #

    Interesting SimonJ, I did not know this could be done. What is the effect of creating a subdomain with a wildcard as name?

  4. SimonJ
    Member
    Posted 13 years ago #

    Well... The more obvious effect is that it works :-)

    I found this trick via this forum when I made my migration to mu. Editing the DNS was not enough on my side, so I made a little google quest and found this.

    Also, I don't have any problem/conflict with other subdomains created via cpanel.

    Ok, I found the link :

    http://www.blogopreneur.com/2006/11/06/installing-wordpress-mu-on-a-cpanelwhm-server/

    Quote : "Update: If you have CPanel X3, you DO NOT have to configure the DNS zones or make changes the http.conf file. All you have to do is to create a subdomain, called “*”. "

    On my side, I did both : edit the DNS zone AND the * subdomain...

    S.

  5. andrea_r
    Moderator
    Posted 13 years ago #

    And did it work?

    because in the past, bluehost has not supported the wildcard needed for subdomain WPMU installs.

    And for the rest - yes, this is part of the instructions. The wildcard in the subdomain "catches" any subdomain and tosses it at the MU install. WPMU looks up the info in the database, if it exists, it serves that blog.

    Helpful site: http://wpmututorials.com

  6. Dirt2
    Member
    Posted 13 years ago #

    Thanks simon but that didn't quite help:
    Look at the page now and look what happens to my wp-admin on the subdomain..

    http://andrew2.contentshops.com/andrew2/wp-admin/

    It's like somethings still missing.
    HTACCESS?

    "because in the past, bluehost has not supported the wildcard needed for subdomain WPMU installs."

    They said they were unable to do it and explained that name.com had to forward something to them to make it work.. So I can't say for sure what happened but obviously something happened since that bluehost page comes up instead of a 404 error.

  7. SimonJ
    Member
    Posted 13 years ago #

    hum... weird weird weird... It looks like if you had both subdomain and subdirectory...

    But, If I look at the subdomain adress :

    http://andrew2.contentshops.com/

    There is something different... Il looks like you have a parked domain name in a frame...!

    !?

    And here is the frame with the parked domain :

    http://www.bhdefaultparking.com/?a=andrew2.contentshops.com

    Maybe it's just a DNS propagation time issue...

    S.

  8. Dirt2
    Member
    Posted 13 years ago #

    I'll give it 24 hours and is the /andrew2/wp-admin just supposed to be /wp-admin?

    Is there anyway I can just make it so it doesn't even use subdomains? That might be better and less crap to deal with.

  9. SimonJ
    Member
    Posted 13 years ago #

    What it will be in 24 hours, I have no idea... :-) I don't work at bluehost... :-)

    But yes, normally, it should be something like :

    blogname.domainname.ext/wp-admin

    Of course, you can set WP MU to use subdirectory (domain.ext/blogname) instead of subdomain (blogname.domain.ext). At least, with this setup, you won't have to care about a domain name server and such.

    But my five cents : I don't know what you're trying to do with WP Mu, but from my point of view, I wouldn't consider to use it on a server where I don't have personnal acces to the DNS, ssh, apache, php, backup, and so on... Or, at least, an host where you can have direct and personnal access to technical support. Setting it on my box took 15 min. I'm far than being a guru in these matters, but if you have problems to just get it working, imagine what it wil be later... :-)

    Just my five cents...

    S.

  10. MAVIC
    Member
    Posted 13 years ago #

    Contrary to what's often said, the domain should not be "parked." Parking is just another term for pointing a domain to a temporary website. In this case, it looks like it's parked at bluehost which means it will alway show some monetized bluehost page.

    I am confused what domain you're actually using. Did you setup the wildcard for contentshops.com, or for andrew2.contentshops.com? Eg, is it *.contentshops.com or *.andrew2.contentshops.com?

  11. Dirt2
    Member
    Posted 13 years ago #

    The site with MU installed is contentshops, the subdomain was andrew2.contentshops.com

    Can anyone tell me how to change it so it's sub-directories instead of subdomains? Hopefully it is an easier switch.

    Thanks all.

  12. andrea_r
    Moderator
    Posted 13 years ago #

    Reinstall and pick subfolder/subdirectory.

  13. ScottWood
    Member
    Posted 13 years ago #

    Based on the link to "Andrew2's shop" on the front page of your main site, you're already in subdirectory mode - though the link isn't working. This link does work though: http://contentshops.com/andrew2/wp-login.php

    If you've made any settings in cpanel, you might consider resetting them back to their default to see if it helps.

  14. andrea_r
    Moderator
    Posted 13 years ago #

    Looks like he reinstalled with subfolders.

About this Topic