The MU forums have moved to WordPress.org

Install WPMU on MAMP (23 posts)

  1. 2bak860
    Member
    Posted 15 years ago #

    Hi,

    I've been trying to get WPMU running on MAMP for the past 5 hours - not a lotta reference to this online.

    I've got as far as to get this:

    http://localhost:80/wpmu/

    redirects to

    http://localhost:80/wpmu/wp-signup.php?new=localhost

    and back again.

    My details in wp-config.php are as follows:

    define('DB_NAME', 'wpmu');

    /** MySQL database username */
    define('DB_USER', 'root');

    /** MySQL database password */
    define('DB_PASSWORD', 'root');

    /** MySQL hostname */
    define('DB_HOST', 'localhost:80');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'localhost:80' );
    define('PATH_CURRENT_SITE', '/wpmu/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );

    Any ideas to get it going to actual installation?

    thanks,

    Ross

  2. tdjcbe
    Member
    Posted 15 years ago #

    - Don't use localhost, use an actual domain, even if it's something you set up locally like localhost.tld

    - Don't use a port number. Mu is hard coded for port 80.

    Both of those should have kicked out with errors during the install process as the software checks for both. They've been discussed a number of times previously here in the forums.

    - Install the software within root, not a subdirectory.

    - Don't edit the wp-config.php file. The software creates it;s own during the install. I believe it even states so at the top of that file.

    Please give the readme file included with the download a read, even if it;s written for a *nix install. There's also a ebook that you can grab off of this site that should help.

    http://wpmututorials.com

    Best bet would be to delete the wp-config.php file that you have, delete any database tables that got created, make sure you have an untouched wp-config-sample.php file, move the files into root, read the readme file, and try again.

  3. 2bak860
    Member
    Posted 15 years ago #

    Thanks for your help! I've started again with a new install:

    Now trying to access from:

    http://127.0.0.1/mu/

    In the httpd.conf file, I've made the changes noted in README and I've put this right at the bottom, but am not sure if it's right:

    <VirtualHost *>
    DocumentRoot "/Applications/MAMP/htdocs"
    ServerName 127.0.0.1
    </VirtualHost>

    Any ideas on what I should look at next? I've left all the WordPress MU files well alone, apart from changing the chmods as instructed. Can't wait to get started!

  4. tdjcbe
    Member
    Posted 15 years ago #

    You may have missed the bits about using an actual domain, even if it;s a local one, and not installing it into a subdirectory.

  5. cafespain
    Member
    Posted 15 years ago #

    Don't mess with the httpd.conf file.

    Search google for instructions on setting up your hosts file, add a few records in there such as:

    127.0.0.1 mysite.dev
    127.0.0.1 sub.mysite.dev
    127.0.0.1 sub2.mysite.dev

    Then install MU on the main one: mysite.dev. If you are installing in the MU sub directory then the site will be at mysite.dev/mu

    I've got 3 quarters of an ebook done for installing on MAMP, must get it finished.

  6. 2bak860
    Member
    Posted 15 years ago #

    @cafespain - I'd be happy to look at a really rough version!

    Will look into mysite.dev stuff - thanks!

  7. 2bak860
    Member
    Posted 15 years ago #

    Hi,

    I have now setup just using Leopard (MAMP was such a headache!).

    At the installation screen, I can't seem to get the right "Database Host" right. I have tried:

    localhost
    localhost.localdomain
    127.0.0.1

    Any ideas?

    many thanks in advance

  8. 2bak860
    Member
    Posted 15 years ago #

    Found it - should have left username blank!

    For anyone with similar issues to me - here's what I did:

    Follow this tutorial: http://www.withinsightdesign.com/2009/installing-wordpress-mu-on-mac-os-x-leopard/

    On installation, use this info:

    Database Name: wpmu
    Username: (leave blank)
    Password: your password
    Database Host: localhost
    Server Address: localhost.localdomain

    Any issues, please post below!

    thanks!

  9. tdjcbe
    Member
    Posted 15 years ago #

    Username: (leave blank)

    I would think that would be a security risk. Wouldn't that allow any username to work?

  10. Melton Cartes
    Member
    Posted 14 years ago #

    Hi,

    I've tried every configuration I could find of instructions in this post as well as every other post on "installing WPMU on MAMP" or XAMP or WAMP and I keep getting the same fail errors.

    Either: WPMU only works without the port number in the URL.

    Or: Error establishing a database connection

    I've followed the README to the letter. I've done several things recommended by the posts mentioned above. I've undone those things to start over. I've done a clean install...
    ...and nothing.

    Help!

    Thanks!

  11. cafespain
    Member
    Posted 14 years ago #

    So, you're running MAMP on port 80 yes? And you've set up your hosts file? And looked that the docs for MAMP to get the username and password for your database? (On my installation the initial username is root BTW).

  12. Melton Cartes
    Member
    Posted 14 years ago #

    I tried that but my browser couldn't find localhost:80. I switched MAMP back to its defaults (8888, 8889? it's a blur).

    I tried to set up my host file (not exactly knowing what I'm doing, but following some recommendation at some link..."setting up mysite.dev, etc.") and it didn't seem to make a difference.

    And looked that the docs for MAMP to get the username and password for your database?

    Which docs? I thought I knew my dbase name, username and password from phpMyAdmin (wpmu,meltonMU,and a password). But it didn't work.

    I did try wpmu, root, root. Didn't work. Tried localhost.localdomain, 127.0.0.1... ditto.

    A friend just said that MAMP and WPMU don't play nicely together because of the configuration (I'm not sure whose configuration he meant). He suggested I just use XAMPP, which I'm about to install.

    Another friend pinpointed the "proper domain name" requirement WPMU seems to have. My suspicion is that this might be a big part of my problem, since I don't think I was ever able to achieve a definitive result with setting one up.

    Thanks!

  13. Melton Cartes
    Member
    Posted 14 years ago #

    Okay.

    1. I've got XAMPP running.

    2. XAMPP is running on http://localhost/xampp/index.php and http://localhost:80/xampp/index.php. Don't know if that matters....

    3. I set up my host file based mostly on what I gathered from this thread and these two (managing dns and the hosts file on your mac os x system and How To Setup A Local DNS Host File On Mac OS X).
    It now contains:
    127.0.0.1 mysite.dev
    127.0.0.1 sub.mysite.dev
    127.0.0.1 sub2.mysite.dev

    4. I browsed to http://localhost:80/wpmu/index.phpto install WPMU and first got a chown and chmod error.

    Using Get Info (on my Mac) I made everything for the WPMU and wp-content directories Read and Write.

    That got me to a successful install.

    Just before logging in.... I double-checked to see if what I did with Get Info actually did change the permissions (chown and chmod) by changing two settings back to Read Only and instantly got an Internal Server error (at http://localhost:80/mysite.dev/index.php).

    I changed the permissions back to Read and Write again and I'm still getting the Internal Server error.

  14. pumpkinpatch
    Member
    Posted 14 years ago #

    This may not be directly related to solving the errors you get, but I suggest that you try the following:

    1) Try this on another Mac. If still the same issue, then:
    2) Ask someone on this forum to send you the xampp folder of a sample installation on their machine. Also the hosts implementation.

    I would have done this for you, but unfortunately haven't evolved into a Mac user yet. That might be the next rung in my evolutionary ladder :)

    I think xampp, at least on a PC, is just a folder installation without using Windows system files.

  15. Melton Cartes
    Member
    Posted 14 years ago #

    pumpkinpatch

    Thanks!

    1.) Great idea, but not available right now...

    2.) Good idea. But I think the installation isn't the problem.

    I've managed to get it installed, I just have a Internal Server error now. This happened just after I got a "Successful Installation" page. I've tried a clean install of WPMU and will try again with a brand new download of...

    I wonder if I should try a clean install of XAMPP, even though it seems to be working (my localhost WP works...).

    Clearly, something's broken. But I can't figure out where...

    Thanks!

  16. pumpkinpatch
    Member
    Posted 14 years ago #

    My reply was intended for you to have a completely new install. If you go with Option 2, this install would be one that was running on some other person's Mac. You would end with either of 2 situations:

    1) If that still doesn't work on your machine, then you have a good place to start troubleshooting.

    2) If it works, then the way you installed it previously was not the right way.

    Of course, you need to completely remove your old install before you do all this.

    There are so many places things can go wrong, including while setting up xampp. If you have a working install folder from another person, and it works on your machine, then it definitely was you doing something wrong :) If it still doesn't work, then its something on your machine...

    Hope it work out for you. I know how frustrating things can get when you can't even get started!

  17. Melton Cartes
    Member
    Posted 14 years ago #

    Okay.

    I've managed to get back to the WPMU install page with the same chown and chmod Warning. (With help from a kind soul I managed to use Terminal to see the error log and narrow things down. I even downloaded WPMU again for a clean install.)

    What a made a difference and got me back to the WPMU install page was using "127.0.0.1" instead of "localhost."

    Also, "localhost:80" seems to work.....

    So, I'm going to change the permissions again on my WPMU install directory ("mysite.dev") and wp-content, as directed by the warning above. Actually, just wp-content; mysite.dev is not mentioned this time (of course).

    Okay, here goes.

    Using Get Info, I've turned Read Only into Read & Write for Group and Others.

    I now have a full WPMU install page (e.g. "Database Name," "User Name," etc.). I've clicked on "sub-directories."

    Okay, I've reached "Installation Finished."

    I clicked on Log-in and I get Internal Server Error.

    I've added "localhost.localdomain" but it makes no difference.

    I've even {tried to) turned off RewriteEngine (On to Off and off) in the htaccess file.

    I just dumped that install, replaced it with a clean one, browsed to 127.0.0.1/mysite.dev/index.php and I got the Installing WordPress page again.

    Tried another time and still no luck.

    Seems like it has something to do with RewriteEngine according to my error log.

  18. andrea_r
    Moderator
    Posted 14 years ago #

    "and I get Internal Server Error."

    you;re consistenly gettign the same error, and it means your local server is indeed messed up / configured wrong.

    Now, for the MU part - did it make the .htaccess file? Did it create wp-config.php? Did it add tables to the db?

    Those answers will help see where in the install it failed, and where you need to look.

    And you can't install it under just "localhost". It *will* tell you on the screen not to do that.

  19. Melton Cartes
    Member
    Posted 14 years ago #

    Hi, Andrea:

    Some progress.

    With help from Nobbie at the Apache Friends Support Forum I edited the "httpd.conf" file.

    AllowOverride All for <Directory "/Applications/xampp/xamppfiles/htdocs">

    That got me to Installation Finished and to be able to click "Log in." But then I get an unstyled "My Blog" log-in page.

    Then, instead of being in the Admin area, I just see a Kubrick page with a 404 error. When I try to log-in, I get the un-styled page and round we go. If I click on "Create New Blog" I get: The blog you have requested is not installed properly. Please contact the system administrator.

    Now, for the MU part - did it make the .htaccess file? Did it create wp-config.php? Did it add tables to the db?

    Yes, htaccess (but it is no different than the one generated before I could get this far...).
    Yes, wp-config.php.
    Yes. Went from 17 to 25.

    FYI, this is what I'm inputting:
    Sub-directories (not sub-domains)
    DBName: wpmu
    DBUser: wpmu
    DBpw: *password*
    DB Host: localhost
    Server Address: localhost.localdomain

    Site Title: Localhost.Localdomain:80 blogs
    Email: my email...

    Thanks!

  20. Melton Cartes
    Member
    Posted 14 years ago #

    I think I put a typo in the Site Title..... I'm going from memory.

  21. Melton Cartes
    Member
    Posted 14 years ago #

    Thanks, Pumpkinpatch. I didn't see your second message until now.

  22. Melton Cartes
    Member
    Posted 14 years ago #

    I haven't been able to move past the point described above. If anyone has an idea, thanks!

  23. moonstar7
    Member
    Posted 14 years ago #

    Did anyone get this working yet? I tried for hours last night and couldn't. If you have MAMP set up running WordPress MU could you please share your install with me and explain what you did..

    Thanks!

About this Topic

  • Started 15 years ago by 2bak860
  • Latest reply from moonstar7