The MU forums have moved to WordPress.org

subdomain help (4 posts)

  1. kunal17
    Member
    Posted 13 years ago #

    I have WPMU/Buddypress installed on an addon domain (theindianstartup.com) on my Hostgator baby account. However the DNS provider is Godaddy. To enable wildcard subdomains I added an A record to Godaddy (* MYIP 1 hour). When I tried to click on a user created blog (Blog1), it goes to blog1.theindianstartup.com and shows a directory structure with cgi-bin as the only directory (instead of the blog).

    I asked Hostgator support to help me and they said that it all like its all set up correctly and that he '
    checked the Apache config and it seems the wildcard vhost is pointing to public_html/theindianstartup.com. If you would like this changed update this ticket to the new location and I would be happy to do this.''

    Please note that public_html is the root directory of my main domain name and the root directory of theindianstartup is 'public_html/theindianstartup/'

    Please let me know what needs to be changed to make it point to the blogs being created by users in WPMU.

    Thanks.

  2. andrea_r
    Moderator
    Posted 13 years ago #

    Did you wait the 1 hour to make sure the godaddy wildcard record was in effect?

    The wilcard vhost in apache is pointing to the right place, BUT sometimes WPMU does not like being installed as an add-on domain.

  3. kunal17
    Member
    Posted 13 years ago #

    Andrea_r, thanks for responding. I tried it this morning and it still shows the same issue. I hope its not a random problem with WPMU as I was really hoping for the subdomain blogs functionality :(

    Could it be that the wildcard vhost is pointing to the wrong address? The hostgator techie says that it is currently pointing to 'public_html/indianstartup.com'. indianstartup.com is the domain but the WPMU root directory is actually called just 'indianstartup'. Should this then be changed to 'public_html/indiastartup'?

    Also, will just pointing to the root directory of the WPMU install prompt WPMU to take care of the subdomain redirect or does it have to be pointed somewhere else?

    I apologize if I am asking stupid questions. This is my first time with WPMU (or buddypress or wildcard subdomains) :)

  4. kunal17
    Member
    Posted 13 years ago #

    Hey Guys,

    Just wanted to update that the wildcard subdomain working fine now. The hostgator techie had it point to the wrong directory in the vhost, as I thought.

    Thanks for your help.

About this Topic