The MU forums have moved to WordPress.org

Have issues with "Problem in wp-config.php - $base is set to BASE when it sho... (14 posts)

  1. ibsystems
    Member
    Posted 13 years ago #

    I just tried to install wrodpress MU (v2.7.1) on our Apache/php5.2.5 Linux (redhat 4) server and received The above error after populating the information in the idex.php page. I tried to dig in the Internet and in this forum, but no hit how to solve it. So here are the steps I did:
    - I created new (empty) mysql database.
    - Added a use and it's access privileges.
    - untar/unzip the Wordpress-mu under my root web-server directory.
    - Renamed it to blog
    - Make sure it is accessible to the user of the server ($ chmod -R 777 blog). I know it is too match, but for installation phase it was okay with us.
    - Make sure that there are no tables in my database.
    - Make sure that there is no .htaccess file under ../blog/
    - Make sure that there is no wp-config.php.
    - Access my website under http://www.mysite.com/blog/
    - Select "Sub-directories (like example.com/blog1" under "Blog Addresses", filled up the other filled and click submit.

    The result is a page with the above error. Checking the directory I found a new file 'wp-config.php' that was identical to 'wp-config-sample.php'. No .htaccess file was found.

    Anyone can help ?

  2. andrea_r
    Moderator
    Posted 13 years ago #

    Hmm, so it died trying to write the htaccess file...

    Ownership of the folders?

  3. ibsystems
    Member
    Posted 13 years ago #

    Everything under and including the blog are 777

  4. tdjcbe
    Member
    Posted 13 years ago #

    Sounds like a CPanel box. If so, please give this a read:

    http://mu.wordpress.org/forums/topic.php?id=99

    CPanel has some weird protections on the htaccess file.

  5. andrea_r
    Moderator
    Posted 13 years ago #

    777 is permissions, I'm talking ownership of the directories. :) CHOWN, for example - are the folders owned by the web account, apache, www or ...?

  6. SteveAtty
    Member
    Posted 13 years ago #

    Does it do it if you put the files at the server root rather than in a subdirectory? Don't forget that the primary blog is called "blog" so with subdomains that would give you mydomain.com/blog/blog

    Also try installing it without the www

  7. ibsystems
    Member
    Posted 13 years ago #

    Andrea_r: The owner and the group of the files are the same as the apache server. Thank you

    !!! I found the issue !!!
    That web-server also support the Oracle database. Therefor the magic_quote_sybase was turned on (made the escape character ' (single quote instead of slash) (in php.ini). Turning it of broke everything else, but I was able to install it.
    My solution was:
    Keep the magic_quote_sybase on in php.ini, but turn it off for the directory (using .htaccess).

    Improving the script (turning magic_quote_sybase off in the code or adding to the installation docs)would be helpful.

  8. tdjcbe
    Member
    Posted 13 years ago #

    ibsystems, please go ahead and open up a ticket on the trac system.

    http://trac.mu.wordpress.org

    The login information is the same as here in the forums.

    To be honest though, I can't see how an Oracle setting would affect what's occurring. That's weird.

    Also I believe the software checks for magic_quotes.

  9. ibsystems
    Member
    Posted 13 years ago #

    Done (Ticket #981)

  10. spherical
    Member
    Posted 13 years ago #

    I'll jump in here and add some data. I've never been able to get 2.7.1 to write an .htaccess file, no matter what I've tried. WPMU directory and all files in it are owned by me. Chmod 777 everything in sight, inluding the wpmu/ itself. Delete the existing .htaccess. Place one but make it empty. Change permalink settings. You name it. Nothing ever happens.

  11. andrea_r
    Moderator
    Posted 13 years ago #

    If a program on the server is unable to write a file to the server, then it's a server setting somewhere.

  12. ibsystems
    Member
    Posted 13 years ago #

    spherical,
    Rename your php.ini to php.ini.old; restart the web-server; delete wp-config.php (if it was created) and try again.

    For sure it will be easier to debug those installation failures if the installer will give a message for each failure.

  13. andrea_r
    Moderator
    Posted 13 years ago #

    It has a lot of error checking in there already, but it's hard to code for every possible server config out there.

  14. ibsystems
    Member
    Posted 13 years ago #

    It will be good enough to write down when the copy/write of a file such as wp-config.php or .htaccess failed.

About this Topic

  • Started 13 years ago by ibsystems
  • Latest reply from ibsystems