The MU forums have moved to WordPress.org

Wordpress MultiUser on MediaTemple (dv) (15 posts)

  1. kmrd
    Member
    Posted 13 years ago #

    Just spent 3 days getting this going, so putting this here for future reference.

    To get WPMU working on (mt) (dv) server using subdomains (ie. blog1.domain.tld, blog2.domain.tld, etc), first follow the usual step of setting up a wildcard domain.

    If you do it right, you'll have something (usually the default MediaTemple screen) come up at blog1.domain.tld, etc. If it's not right, you won't be able to connect to the address.

    ---

    The httpd.conf you have to edit is NOT the one in /etc/httpd/conf (like some tutorials say); you want the one in /var/www/vhosts/domain.tld/conf.

    Type the following (without quotes) to get at it (replace domain.tld with your actual domain name):
    "cd /var/www/vhosts/domain.tld/conf"

    Then type:
    "vi httpd.include"

    You'll be in the editor now. Add the *.domain.tld under ServerAlias.

    Restart Apache and you're good to go. FINALLY. Hope this helps someone.

  2. cafespain
    Member
    Posted 13 years ago #

    How would you set up a wildcard dns entry for multiple sites, or add multiple sites to this set up?

    Just curious as you seem to be editing the conf specific to the domain. Is there not a "master" conf file which is including all of these domain specific ones?

    I'm actually asking here, never used the (dv).

  3. andrea_r
    Moderator
    Posted 13 years ago #

    It's an Apache 2 feature to include them all.

  4. tdjcbe
    Member
    Posted 13 years ago #

    I could have sworn we've discussed hosting platforms that do trickery with their apache con fig files. Both CPanel and Direct Admin do this.

  5. Trent
    Member
    Posted 13 years ago #

    It is similar to Plesk in the fact that httpd.conf includes the specific domain files as a wildcard. Each file has the specific domain apache config. I spent a great deal of time looking at that the last time I saw a Plesk install. Nice that you put that in. You can edit the master httpd.conf but it still might be overwritten by the specifc domain. Nice share :)

  6. polle001
    Member
    Posted 13 years ago #

    Hey kmrd, can you please give me your advice here ?

    http://mu.wordpress.org/forums/topic/12713?replies=1

    I am getting some problems and it seems you have it working correctly ?

    Thanks.

  7. PubDirLtd
    Member
    Posted 13 years ago #

    I currently run WPMU on their grid servuce (gs) platform but am just about to do the very same thing, i.e. set up WPMU on a MediaTemple (dv) platform. So your advice is really timely. Many thanks.

    I have 700 quite old but still serviceable static *.htm pages I want to serve on the new platform. There are about 14 different pages for each sub-domain.

    What would be the best/easiest/fastest way to serve these pages with WPMU or am I better off to just leave them as static *.htm pages?

  8. andrea_r
    Moderator
    Posted 13 years ago #

    Leave 'em as static, becasue to server them with WPMU or WP, you'd have to manaully put the content of the html page inside posts/pages within WP. Where everything is stored via the database.

  9. fernando.borba.br
    Member
    Posted 13 years ago #

    KMRD,

    I am dealing with the same problem at my MediaTemple settings... but my main domain is not the one that hosts WP MU.
    I still cannot create a subdomains blog:

    My main domain is institutodocorretor.com.br
    My Wp MU domain is cidadedocorretor.com.br

    when I create a blog like:

    myblog.cidadedocorretor.com.br

    it automatically redirects to:

    http://www.institutodocorretor.com.br

    DO you have any tips to help a stucked friend here?

  10. erik810
    Member
    Posted 13 years ago #

    Having the same problem as fernando.

  11. jimmiejo
    Member
    Posted 13 years ago #

    None of the methods mentioned above worked for me, so I gave MediaTemple a call, and they kindly walked me through the process.

    After installing WordPress MU and creating a new sub-domain blog or two through the wp-admin, you should see the MediaTemple default webpages at the sub-domains, like kmrd mentioned in the first post.

    Then follow these steps, which took less than 5 minutes, and worked like a charm for me:

    (note: don't use the ssh in the Plesk admin, they said its faulty. Use Terminal on a Mac, like I did, or your ssh app of choice)

    1) open up Terminal.

    2) type: ssh root@yourmainaccountdomain.com

    3) enter your password for the main domain

    4) type: cd /var/www/vhosts/thedomain.com/conf

    5) type: vi httpd.include

    6) to go into insert mode type: i

    7) Find: ServerAlias http://www.thedomain.com

    8) Change that to: ServerAlias *.thedomain.com

    9) Press escape to exit insert mode

    10) Then press :wq then enter to go back to the main terminal

    11) restart apache with: service httpd restart

    12) That's it! Visit your sub-domain blogs and they should all be working.

    Hope this helps others. Cheers!

  12. smartdumb
    Member
    Posted 13 years ago #

    Thanks OP! Saved me a ton of time. Followed OP steps on a 3.5 MT DV Server.

  13. philpeter
    Member
    Posted 12 years ago #

    None of these solutions worked for me.. I'm on a (dv) 3.5.

    Interestingly, when I edited httpd.conf there was no pre-existing ServerAlias, I had to add that in specifically.

    Any ideas?

  14. jasperespejo
    Member
    Posted 12 years ago #

    editing the domain conf also did not work for me :-( any other suggestions?

  15. larrucea
    Member
    Posted 12 years ago #

    for the question remains WHY OH WHY does WP recommend MT as a trsuted hosting partner when they dont intermingle with the DV service they run????? no bad press intented, just been facing few days of DV and i still cant get the wp properly running, nor the plugins. the guys are nice but dont really solve the problem. paying a good amount of cash and the thing is pretty much useless. i really hope to have the GS instead but with many more resources, wouldnt you?????

About this Topic