The MU forums have moved to WordPress.org

page links on blogs redirecting to homepage (27 posts)

  1. jaybuddy
    Member
    Posted 13 years ago #

    After upgrading to 2.7.1 from 2.7 I have noticed that all the links to "pages" redirect to the homepage.

    Here is an example:
    http://www.amateurendurance.com/social/ is a page and when you goto that page you end up at http://www.amateurendurance.com.

    Anyone else had this issue?

  2. gunnersteele
    Member
    Posted 13 years ago #

    I'm having the same exact problem.

    However, from your homepage, http://www.amateurendurance.com , I can still click to other pages, for example:

    http://www.amateurendurance.com/12/

  3. gunnersteele
    Member
    Posted 13 years ago #

    I think I've isolated the problem to my Permalink Settings.

    I had set my Permalink Settings to custom:

    /%category%/%postname%/

    and all Page links redirected to the homepage.

    When I set Permalink Settings back to the Default setting, the page links now work.

    How can I set my permalinks to use:

    /%category%/%postname%/

    ??

    Here's my setup:

    WMPU 2.71
    Blogs in subdirectories
    Multi-site Manager

    Host:
    Media Temple Grid Service
    MySQL 5.1.26
    PHP 4.4.8-1 (Should I upgrade to PHP 5.2.6-1??)
    Apache 2.0.54

    Thanks - any help is appreciated.

  4. jaybuddy
    Member
    Posted 13 years ago #

    Gunner,

    I also have permalinks set to custom. We have identical setups except for the theme. I will dive into this tonight and see if I can't figure it out.

    j

  5. jaybuddy
    Member
    Posted 13 years ago #

    btw... the blog addresses (eg. /4, /5, /7, /11, etc.) work fine... but pages, like social and subscribe, redirect to the HP

  6. spherical
    Member
    Posted 13 years ago #

    Are you forcing the "www." sub-domain?
    WP defaults to non-www.

  7. jaybuddy
    Member
    Posted 13 years ago #

    tried not forcing www, still doesn't work.

    pages seem to be fine in all blogs except the main (#1) blog.
    http://www.amateurendurance.com/2/privacy <- works just fine.

    I check out this... but it crashed my site when I did what it said. http://trac.mu.wordpress.org/ticket/57

  8. gunnersteele
    Member
    Posted 13 years ago #

    I'm not forcing www on mine.

  9. gunnersteele
    Member
    Posted 13 years ago #

    I feel like I'm getting closer to finding where the problem lies, and I think it's a .htaccess issue, because of this thread:

    http://mu.wordpress.org/forums/topic.php?id=2694

    Because of MediaTemple's grid setup, I've got WPMU installed in the subfolder /html/ :

    /domains/DOMAINROOT.com/html/

    Appending /blog to the custom permalink structure, as suggested here: http://mu.wordpress.org/forums/topic.php?id=1474 "fixes" the permalinks for blog posts, but pages are still resolving to the main page.

    Here's my .htaccess file:

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I'm scouring the codex and forum threads for a solution, but am pretty reluctant to start changing .htaccess and WPMU code - as I'm pretty new to WPMU, just recently installing it for the first time...

  10. andrea_r
    Moderator
    Posted 13 years ago #

    Kinda odd, as it runs / installs on mt grid just fine.

    (well, until you toss some users at it, but that's a separate issue. ;P )

  11. gunnersteele
    Member
    Posted 13 years ago #

    What do you mean by "some users"?

    Do you mean traffic, or # of users creating blogs, or both?

    I'm using it as a platform to setup about 25-40 of my own blogs and sites, so I can manage them all in one place.

    All new blog and user signups are closed.

    Maybe I should go ahead and do the move to Media Temple's DV before I go any further with this install/setup....

  12. andrea_r
    Moderator
    Posted 13 years ago #

    "Do you mean traffic, or # of users creating blogs, or both?"

    Both.

  13. jaybuddy
    Member
    Posted 13 years ago #

    Still cant figure this out. Going to have to move pages to a different blog to get them to work temporarily.

  14. gunnersteele
    Member
    Posted 13 years ago #

    Anyone have any ideas on how to fix this?

    Is this perhaps a problem specific to Media Temple?

    I set up 20 blogs on this install before I realized that permalinks don't work; It'd be a nightmare to do it all over again.

    To avoid that, does anyone know of a wpmu 'fixer' that they can recommend?

    If there are any wpmu 'fixers' lurking, and want to take a crack at this, I'll pay you $25 via PayPal to fix it. If you think it should cost more, then tell me what you'll charge, fixed price, to fix the problem listed here - and I'll consider it.

    Email me at: admin (at) 87680 dot com

    Not in it for the money? Fix it and I'll donate $25 to your favorite charity.

    Either way, I'll be posting the fix here for all to see -- I'm just at my wits end with this one...

  15. gunnersteele
    Member
    Posted 13 years ago #

    Well....

    After reading this Media Temple knowledge base article last week:

    http://kb.mediatemple.net/questions/85/Using+rewrite+rules

    I added:

    Options +FollowSymLinks

    Above:

    RewriteEngine On
    RewriteBase /

    in my .htaccess file. I did this last week, and didn't notice any improvement in my permalink problem.

    Today I decide to revisit the problem to see if I could fix it with more trial and error, so I set my Permalink Settings to:

    /%category%/%postname%/

    without changing anything else - and my page links now work.

    I did a lot of trial and error: turning plugins off, turning all plugins off, the above mentioned .htaccess change. When the change didn't show immediate effect, I would reset it. The only change that I didn't reset was the addition of Options +FollowSymLinks to the .htaccess.

    I'm not sure if this is what fixed the problem, but I'm led to believe that it is. The only thing I can figure is that my browser, or even the blog cached the settings, and didn't show the effect of the new settings immediately.

    For now, I'm going to mark my problem resolved, so the $25 offer is no longer valid. No one stepped forward to as a 'fixer', but I appreciate all the great folks who've helped and post on this forum.

    Jaybuddy - my advice is to check your host's (Godaddy?) support and knowledge base to see how they implement mod_rewrite, because it looks like Options +FollowSymLinks is somewhat non-standard.

  16. gunnersteele
    Member
    Posted 13 years ago #

    I guess I got excited too soon....

    Since Custom Permalinks don't work on any of my other sites, I can't consider this resovled yet.

    Also, in poking around on the other sites on the same install, I found that all of my sites are showing the same sitemap. Ie. DOMAIN1.com, DOMAIN2.com, DOMAIN3.com,... are all showing the sitemap for DOMAIN15.com

    I'm using the XML Sitemap Generator for WordPress 3.1.2 plugin, installed in the /wp-content/plugins folder

    Back to the drawing board...

  17. atgeist
    Member
    Posted 13 years ago #

    Gunner, having the same problems. I upgraded from 2.6 to 2.7 and all my page and category links broke...resolving back to the main domain. I'm using a subdirectory domain install on http://atGeist.com. When I changed the permalink structure to "default", they all work fine but that's not good for my links indexed in google, etc. I tried the .htaccess addition above and /%category%/%postname%/ in permalinks and it still doesn't work. Ironically, the main domain is fine after I updated permalinks, just the other 40+ sites are messed up.

    I'd love to have a wordpress silver bullet here! thanks in advance for any help.

  18. andrea_r
    Moderator
    Posted 13 years ago #

    Double-check the htaccess and wp-config files with the newest ones to make sure any changes are moved over. If there are differences. the upgrade wouldn't have done them because you leave those files.

  19. atgeist
    Member
    Posted 13 years ago #

    thanks andrea, I updated both files and ran the "upgrade" script again and it's still redirecting to the homepage on all the blogs. I've left up http://atcarmel.com so you can see what it is doing (the home site is http://atgeist.com)

  20. andrea_r
    Moderator
    Posted 13 years ago #

    Yeah, I ran into this issue myself yesterday, but in my case it was an issue with a plugin and I had to edit the config file.

    Just for giggles, go into wp-config.php, and comment out the define vhost line. Put two slashes like this: // in front of it.

    Then see if the site still works and the issue gets fixed.

  21. atgeist
    Member
    Posted 13 years ago #

    thanks for the tip andrea. that didn't fix it, but I changed the vhost to "yes" and voila, it worked. commenting it out blew up a few widgets and threw some errors at the top of the site, but setting it from "no" to "yes" fixed it. thank you for your time and help!

  22. atgeist
    Member
    Posted 13 years ago #

    I recant that statement, it fixed the problem of all the links going back to the homepage, but it bombed out the subdirectory domains. Any other ideas?

  23. andrea_r
    Moderator
    Posted 13 years ago #

    That option actually controls telling MU what kind of setup you have, so yes, setting it to yes confused the hell out of it. :)

    No, I'm kind of stumped actually. I know there's other threads about it, but the only time I've had to fix it was because of a specific plugin.

  24. atgeist
    Member
    Posted 13 years ago #

    so in summary, I've got a subdirectory install of MU and the permalinks on the sub-blogs are all reverting back to the main domain "UNLESS" you use the default permalink status.

  25. blepoxp
    Member
    Posted 13 years ago #

    I had this problem on one of my client sites today.

    The client had defined WP_HOME and WP_SITEURL in the wp-config.php file but she had done it while on the dev server. I'm not sure how it happened, but it got out of sync with the sub blogs db options.

    What I would up doing was commenting out both of those definitions and then updating then making sure that site home and all the sub-blogs home were using the same sort of setup. (in my case the main blog was not using www and the sub blogs were).

    Once they were working the same, everything returned to normal and I could use custom permalinks again.

    You can update options with the update_option() function or by going to wp-admin/options.php

  26. atgeist
    Member
    Posted 13 years ago #

    thanks a lot blepoxp, that did it. for me, it was as simple as commenting out the 'DOMAIN_CURRENT_SITE' in the wp-config file.

  27. hydrastudio
    Member
    Posted 12 years ago #

    Reopening this thread...

    I'm with same problem: when set permalinks to anything different than default, category links and post links work, but pages link like mysite.com/about dont work. Itredirects to homepage.
    Subblogs are working fine, including their permalinks (like /%category%/%postname%/).

    I've checked and rechecked .htaccess, wp-config.php and DB config tables.
    Any idea? I saw that jaybuddy's site is working fine.
    Regards!

About this Topic

  • Started 13 years ago by jaybuddy
  • Latest reply from hydrastudio