The MU forums have moved to

Upgrade from 2.6.5 to 2.7.1 (14 posts)

  1. rcwatson
    Posted 15 years ago #

    Can someone help me see what I might be missing? I'm upgrading a 2.6.5 WPMU install to 2.7.1.

    I first want to try this on my local machine before doing it on the production server. However, the end result of just re-creating the 2.6.5 environment on my local machine is broken and I can't get beyond that to then try the upgrade to 2.7.1. I want to make sure it can run and do the upgrade before I do anything on Production.

    Here are the steps I'm following.
    1. Install WampServer Version 2.0 and get it running
    2. Point Apache docroot to c:\wamp\www where WPMU 2.6.5 files are located.
    3. Do all the Readme.txt steps to get 2.6.5 running. Check that the currently blank root blog and admin pages are accessible via the browser. They are.
    4. In Notepad++, open backup.sql file containing all SQL statements to re-create the production database. Find/Replace any instance of the production server domain name scheme to that of the localhost (i.e. --> abc.blogs.localhost). The root blog's title, which is "blogs@company", remains unaltered.
    5. Run backup.sql script in MySQL Administrator on local machine to drop and recreate tables and data. No errors occur, so all seems to be in order.

    At this point, if I understand correctly, I should be able to access http://blogs.localhost, see the "blogs@company" blog, and essentially be running a copy of what was on production on my local machine, being able to see a snapshot of all content and functionality at the time the backup was made. However, after the DB restore I only see a new blog generically named "My Weblog". No content in it and no sign at all of the root blog titled "blogs@company".

  2. andrea_r
    Posted 15 years ago #

    My guess is the data is restored to the wrong database.

  3. rcwatson
    Posted 15 years ago #

    I got the data to restore to the 2.6.5 install on my local machine.

    But, when I went to Site Admin > Upgrade and clicked the Upgrade button, it spun through all the blogs, supposedly doing its thing, and stopped on a "success" message. Only problem is, repeatedly logging out and back in still shows the 2.6.5 interface, not the 2.7.1 interface!

    What step am I missing? I can't find it in the forums.


  4. andrea_r
    Posted 15 years ago #

    Did you get the 2.7.1 files and overwrite them, replacing the 2.6.5 files?

    The upgrade button in the backend just steps thru any database changes *after* you install the new download.

  5. rcwatson
    Posted 15 years ago #

    Yeah, I did. I just did it again, and it put me back to the single "my weblog" site. Now, whenever I run the SQL script to restore the database content, it runs all the way through, no errors, but then something drops all the tables again and reverts the database back to the wp_1_### state it was in before.

    Going to try things by the book again to see if I missed something.

  6. rcwatson
    Posted 15 years ago #

    Arg. Still didn't work. First, I backed up the database. Then, I followed the 2.6 to 2.7 upgrade instructions to the letter. No dice. I end up with the "My Weblog" thing. My database remains intact ("wp_" tables up to wp_100).

    Not sure where to go from here.

  7. rcwatson
    Posted 15 years ago #

    Okay, more detail is in order. I'm performing this upgrade and content migration as a test on my local Windows machine (WAMPServer) before I apply it to Production (LAMP). On the Production machine, it's, with any sub-blogs taking the form of

    When I deploy it to the local machine, it's all "localhost", so I necessarily edit the database to replace "" with "blogs.localhost". This all works fine. I can load and view the blogs and contents just like on Production

    When I do the steps for a 2.6 to 2.7 upgrade, I find the following parts very confusing and need help figuring out if they're even right:

    5 Copy the new files from your scratch wordpress-mu directory into your www directory:

    e.g., cp ~/wordpress-mu/* ~/www

    Fine so far.

    6 Remove the wp-admin and wp-includes directories:

    e.g., rm -rf ~/www/wp-admin ; rm -rf ~/www/wp-includes

    Okay, but don't I need these to show the new admin interface?

    7 Copy the directories from your scratch wordpress-mu directory into your www directory:

    e.g. cp -R ~/wordpress-mu/wp-admin ~/www ; cp -R ~/wordpress-mu/wp-includes ~/www

    Didn't I just add these in step 5 and then remove these same directories in step 6, and now I'm copying them back? Is step 6 superfluous or left over from a previous edit?

    8. Copy the files wp-content/index.php and wp-content/blogs.php from your scratch wordpress-mu directory into your www directory:

    e.g. cp ~/wordpress-mu/wp-content/index.php ~/www/wp-content ; cp ~/wordpress-mu/wp-content/blogs.php ~/www/wp-content

    This seems outdated. The 2.7.1 version I downloaded doesn't have a "wp-content/blogs.php" file at all. Should it be there or does this step need an update?

    11. Login, run site wide blog upgrades by visiting the Site Admin -> Upgrade tab. If you have a lot of blogs, it may take a while.

    This is where it falls apart for me. When I log in after the previous steps, I get a strange screen only saying that the database needs upgrading and my only choice is to click a button to make that happen. After it finishes, I get redirected to "My Weblog" and the rest of the blogs (which still exist in the database) are inaccessible. There's just the "My Weblog" blog. That's it.

    Does that help shed more light on what I'm seeing?

  8. andrea_r
    Posted 15 years ago #

    Yeah, thsoe directions are confusing (I didn't write that part :P )

    Are you absolutely sure you got the download files from this page?

    Was there a mu-plugins folder in the download you got?

  9. tdjcbe
    Posted 15 years ago #

    Something's wrong with your download as there is a wp-content/blogs.php file in 2.7.1:

  10. rcwatson
    Posted 15 years ago #

    Doh! That was it. I was downloading the non-MU version. I got confused while reading the instructions at and then clicking on the red Download tab at the top of that page. That takes me to a different release than the page does.

    I've edited the instructions page to clarify the correct location of the MU version. However, I'm not sure I'm qualified yet to alter the extensive docs on the actual upgrade steps. Someone seems to have had a different scenario in mind when writing it and I wouldn't want to clobber things for people who are in that particular situation. Whatever that situation is, it needs to be clarified and specified.

    In my case, I just overwrote everything with the new release. I didn't have a need to copy files and folders in selectively.

    Thanks for your help.

  11. tdjcbe
    Posted 15 years ago #

    One suggestion: You may want to look into using SVN. It's a big help and makes upgrading a lot easier:

    Take a look for the bit about converting from a traditional install to one on svn.


    Make sure you;re running off branches not the truck. Also make sure you remember the period in the urls. You'll see it after the urls in the examples.

  12. andrea_r
    Posted 15 years ago #

    "In my case, I just overwrote everything with the new release. I didn't have a need to copy files and folders in selectively."

    Overwriting doesn't work on all setup (most do) so that's why it was written that way, plus it's "cleaner" and doesn't leave stray files around that may have been deleted / moved in core.

  13. rcwatson
    Posted 15 years ago #

    thanks to you both. i ran into other glitches after the upgrade, but I'll post those in separate threads. Lesson learned: Stay on top of the upgrades. Problem is, the plugin developers don't always keep up with their fixes after changes are made to the trunk. I had to eliminate three plugins that had worked on 2.6.5, but broke (even after upgrade) on 2.7.1. Quite the dilemma.

  14. andrea_r
    Posted 15 years ago #

    Feel free to list those plugins.

    Also, there were a LOT of changes between 2.6.5 and 2.7.

About this Topic

  • Started 15 years ago by rcwatson
  • Latest reply from andrea_r