The MU forums have moved to WordPress.org

http://www.example.com/user/ TO http://user.example.com/ (8 posts)

  1. Setti
    Inactive
    Posted 16 years ago #

    Hi all! Plese help me.
    Need to rewrite role for URLs like http://user.example.com/

  2. donncha
    Key Master
    Posted 16 years ago #

    1. Click the "virtual host" checkbox on install.
    2. Make sure that Apache is configured to use a wildcard virtual host.
    <VirtualHost *>
    ServerAdmin webmaster@example.com
    ServerName example.com
    ServerAlias *.example.com

    3. Add a wildcard dns entry for your domain. This is could be as easy as typing "*" in the host field of your dns software when creating a new entry.

    If you're using admin software to manage your site, then find out how to do the above as it's a fairly normal thing to do and not connected with WPMU specifically.
    Oh, and please reply here with instructions so others might benefit!

  3. cianuro
    Inactive
    Posted 15 years ago #

    Hi,
    I have the following added to my httpd.conf

    <VirtualHost *>
    DocumentRoot /home/totally/public_html
    ServerAdmin webmaster@mydomain.com
    ServerName mydomain.com
    ServerAlias *.mydomain.com
    </VirtualHost>
    (obviously with my REAL domain name!)

    On install I enabled virtual hosts and I added the wildcard entry to my zone file yet its still redirecting to the default CPANEL page when I visit the blogid.mydomain.com

    What am I doing wrong?

  4. JuanManuel
    Member
    Posted 15 years ago #

    Hi! I want to set my wpmu installation to work with subdomains how do you set up this on cpanel? thanks.

  5. donncha
    Key Master
    Posted 15 years ago #

    James - can you help here with the Cpanel setup?

  6. Farms
    Member
    Posted 15 years ago #

    Do my best :) Juan, have you FTP'd the files into the root (public_html) directory of the domain and set up an SQL database?

    After that what you need to do is, prior to touching anything, change the permisions on the .htaccess file on public_html to make it writable (777?) and get the people who are hosting you to set up a dns wildcard alias and an apache wildcard virtual host for the domain you're using.

    If you've got all of that going then the install should work just by following the regular steps.

    Hopefully...

  7. JuanManuel
    Member
    Posted 15 years ago #

    Thanks James I have it install but I need to setup the vhost on WHM of cpanel.

  8. donncha
    Key Master
    Posted 15 years ago #

    cianuro - is it working now? maybe the dns was cached in your browser?

  9. cianuro
    Inactive
    Posted 15 years ago #

    Sorry for the delay in replying.
    Yup, its working now on one of my sites.

    the httpd.conf file needs to be edited and for those who do not have access to this, you need to contact your hosting support. Remind them to restart apache.

    My biggest problem was trying to get vi into edit mode at the shell! Thats what salves to pico get!

About this Topic