The MU forums have moved to WordPress.org

Transferring from subdomain (8 posts)

  1. morzik
    Member
    Posted 15 years ago #

    Hi,

    our company faced a challenge with wpmu 2.7 subdirectory install and transfer.

    First of all we successfully installed and filled our blogs on subdomain. We choose subdirectory install and have the following blog structure:

    1. subd.company.com - main static page
    1. 1. subd.company.com/blog - blog page with posts
    2. subd.company.com/clients - blog for clients
    3. subd.company.com/service - blog for our services.

    Afterthat we started to transfer our db and wordpress files to new domain: 'http://company.com' on the same hosting platform. I changed all paths in db, and in wp-config.php, reupload all wp files on a new domain.

    On a new domain wp working very strange. All css files are broken, even in admin page for 'clients' and 'service' blogs I see page with content but without any css layout. Media library also damaged and all uploaded files don't correctly displayed in wp. Only main blog works correctly, any other subblogs and their themes are broken.

    It's seems that wp after transfer doesn't see path starts with:

    company/subblog_name/

    Please, help...

  2. Brayne
    Member
    Posted 15 years ago #

    From my experience there are some paths that need to be changed in the db dump file as well...

    subd.company.com/service

    changed to

    company.com/service

    And you may have some direct paths that need to change....

    I don't know what your environment is but it may be something like this...

    /html/public_html/subd/

    needs to change to

    /html/public_html/

    I change...

    01. paths (db dump file)
    02. urls (db dump file)
    03. wp-config file
    04. htaccess file

    Good Luck..

  3. saurabhjain
    Member
    Posted 15 years ago #

    how to change db dump file paths
    I have similar issues
    http://mu.wordpress.org/forums/topic/12605?replies=3

    If any 1 can suggest me...

    thx and regards

    saurabh jain

  4. morzik
    Member
    Posted 15 years ago #

    Brayne, I've changed all paths in db to new, but it doesn't work. Admin pages for sub-blogs have broken css, themes too. WPMU doesnt see links like company.com/subblog/

    Also I tryed to upload all files and refresh db for another 2lvl domain, i.e. 'company2.com', and suprisingly everything is good. What problems with domain can cause such effects?

  5. andrea_r
    Moderator
    Posted 15 years ago #

    Could be all kinds of things at this point. Did you search the *entire* db to find any stray domain names you may have missed?

    On the new server, do permalinks off the main blog work? If not, it's a mod_rewrite issue.
    Make sure the .htaccess file is there.
    If it's there, then Apache isn't reading it.

  6. morzik
    Member
    Posted 15 years ago #

    even empty new install of wpmu causes such kind of effects. .htaccess is available.

  7. andrea_r
    Moderator
    Posted 15 years ago #

    If it's there, then Apache isn't reading it.

    Check out the httpd.conf file. If it says something like AllowFileOption None, that's the culprit. Should be All.

  8. morzik
    Member
    Posted 15 years ago #

    problem solved, domain was recreated and all rewrites fired very well.

About this Topic